Question Is there a way to install NSPs that require a higher firmware than I'm on?

Discussion in 'Switch - ROM Hacking, Saves, Translations & Tools' started by Anoraki, Jun 20, 2019.

  1. Anoraki
    OP

    Anoraki Member

    Newcomer
    1
    May 9, 2017
    United States
    I got my Nintendo Switch in late June of last year and haven't updated it since. It's sitting on 4.1.0. Since I'm on a relatively dated firmware, a lot of the NSPs I've tried to install say they require a higher firmware version, when using Tinfoil. Just wanting to know if it's possible to get around this, because ZeroTwoXCI seems to allow the installation of these files regardless of the minimum req version. If not, would it be reasonable to update to a newer version?
     
  2. nekojosh

    nekojosh GBAtemp Regular

    Member
    5
    Jan 9, 2015
    Panama
    Panama City, Panama
    You can update using Choidojour and autoRCM to avoid burning fuses (get a nand backup before doing the upgrade in case you haven't done one from when you nand was clean)
     
  3. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    There are three kinds of version requirements:
    1. The system requirement flag, which is easily bypassed.
    2. The master key revision, which can be bypassed.
    3. The software development kit used, which cannot be bypassed.
    Because of #3, you will have to update in order to play some newer games/updates. You can use ChoiDujourNX to update offline, and you can use it to install AutoRCM during the update process if you don't want to burn your efuses. As of this post, Atmosphere is compatible with all system versions (1.0.0-8.1.0) on unpatched systems.
     
    Last edited by Lacius, Jun 20, 2019
  4. Anoraki
    OP

    Anoraki Member

    Newcomer
    1
    May 9, 2017
    United States
    What version do you recommend updating to?
     
  5. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    At this point, I see no reason not to update to 8.1.0. Atmosphere is compatible with 8.1.0, and you're going to have to update to 8.1.0 (and higher) eventually for newer games/updates.
     
  6. tegzie

    tegzie Member

    Newcomer
    2
    Jun 5, 2014
    Run the NSP file through reNXpack before you install it. Its what I've been doing and it works fine.
     
  7. Anoraki
    OP

    Anoraki Member

    Newcomer
    1
    May 9, 2017
    United States
    Thanks for the help. I backed up my NAND, switched to Atmosphere (from ReiNX), and updated to 8.1.0. Everything seems to be working fine and my NSPs are installing.
     
    Lacius likes this.
Loading...