is there a site that tells a list of compatibility...

Discussion in 'PSP - Games & Content' started by anthony001, Jun 13, 2010.

  1. anthony001
    OP

    anthony001 GBAtemp Regular

    Member
    299
    5
    Oct 19, 2007
    of games for a specific firmware(5.03 gen c).
     
  2. Ryufushichou

    Ryufushichou I'm Not British, I'm Just Gay!

    Member
    668
    15
    Mar 29, 2008
    Raimon Junior High
    As far as i know, all games work on 5.03 Gen-C, but ones that need 6.20 Need to be patched with Prometheus Method (i think) heres a link Prometheus Patching but yeah all work, just some need patching, hopes this helps.
     
  3. ragingchaosgod

    ragingchaosgod JUBILEUS QAAL OVOF VOMSARG

    Member
    575
    0
    Dec 20, 2008
    XD I asked this before during my first few weeks as a new PSP owner.... but yes. Almost everything works so far. If something doesn't work, most people usually mention it somewhere online so... when ya get a new game, google is your friend.
     
  4. anthony001
    OP

    anthony001 GBAtemp Regular

    Member
    299
    5
    Oct 19, 2007
    ok thanks
     
  5. steve-p

    steve-p GBAtemp Advanced Fan

    Member
    503
    0
    Apr 13, 2009
    anything for 6.0 or higher also needs to be decrypted.
    however - most downloads are decrypted already as long as you arent using "zero-day" type sites.
     
  6. anthony001
    OP

    anthony001 GBAtemp Regular

    Member
    299
    5
    Oct 19, 2007
    did anyone get a black screen while entering zack isalnd after i choose a girl(DOA paradise)?
     
  7. ragingchaosgod

    ragingchaosgod JUBILEUS QAAL OVOF VOMSARG

    Member
    575
    0
    Dec 20, 2008
    Didn't get one. o.o Try to find a new copy. The only problem I have with DoA is that I can't access the photo album.
     
  8. raing3

    raing3 CNET_Richard

    Member
    529
    8
    Apr 2, 2009
    Australia
    Well the posters question has been somewhat answered but there is a very helpful and quite detailed list of recently released games compatible with 5.00 M33/5.50 GEN as well as methods for getting them working. You can download the compatibility list from http://www.mediafire.com/?2ov4d1ymmwi if you still want it.