Is the DSTWO compatible with 1.4.4J DSi LL?

Discussion in 'Supercard' started by j0nathanp3ters, Aug 6, 2012.

  1. j0nathanp3ters
    OP

    j0nathanp3ters Newbie

    Newcomer
    7
    0
    Sep 13, 2009
    United States
    I have a DSTWO (1.17) both a DS Lite and 3DS (4.3.0-10) from the US and I have no problems at all with either system. I also just purchased a Japanese DSi LL (1.4.4J) and I cannot seem to get the DSTWO working. I get the "Alex" logo but when I launch the game I get this error message.

    [​IMG]

    I have tried doing the firmware/EOS update from http://jp.supercard.sc with no luck. Any ideas? :blink:
     
  2. wiiluver135

    wiiluver135 GBAtemp Fan

    Member
    322
    22
    Oct 7, 2008
    United States
    the system is region locked...so...yeah that probably won't work
     
  3. j0nathanp3ters
    OP

    j0nathanp3ters Newbie

    Newcomer
    7
    0
    Sep 13, 2009
    United States
    The system is region locked for DSi enhanced games, but it plays any region DS games without issues. The real question seems to be, is the DSTWO region coded similar to a DSi enhanced cart (ex. Pokemon Black). According to the download site, the newest firmware works with 3DS firmware 4.3.0-10U/E/J, and the 3DS is region locked exactly like the DSi (plays any region DS games/locks DSi enhanced). This would lead me to believe that the DSTWO isn't region locked, but I could be wrong.
     
  4. chris888222

    chris888222 GBAtemp's Flygon Fan

    Member
    5,532
    586
    Oct 11, 2010
    Senegal
    The DSTWO should work on any DSi/3DS since it runs in DS mode.

    Maybe you didn't update correctly. My DSTWO works on the latest JP 3DS firmware.
    It should work on DSi LL firmware as well. There's no reason why it won't.