Is possible to put in english the RVL-001(JPN)?

spawnerbr

Member
OP
Newcomer
Joined
Jan 14, 2022
Messages
10
Trophies
0
Age
48
XP
54
Country
Brazil
I got today a RVL-001(JPN) for my collection. I'm new using Wii and I'm looking for more infos. My model is running 4.2J but uLoader 5.1E is installed as a channel. As I know, there is no way to change the language on the system preferences to english but there is some kind of hack that do this? Or the best alternative is upgrade to 4.3 with Letterbomb and install USB Loader GX on SD with Channel to play games? Thanks.
 

The Real Jdbye

*is birb*
Member
Joined
Mar 17, 2010
Messages
21,897
Trophies
3
Location
Space
XP
11,054
Country
Norway
I got today a RVL-001(JPN) for my collection. I'm new using Wii and I'm looking for more infos. My model is running 4.2J but uLoader 5.1E is installed as a channel. As I know, there is no way to change the language on the system preferences to english but there is some kind of hack that do this? Or the best alternative is upgrade to 4.3 with Letterbomb and install USB Loader GX on SD with Channel to play games? Thanks.
Not without a region change. A region change will effectively fully turn your console into a USA or EUR one, it will be indistinguishable other than the serial number. You can use ModMii to region change. https://modmii.github.io/
You can change the language setting for games ran from a USB Loader though. Just the system menu and settings can't be changed without a region change.
 

spawnerbr

Member
OP
Newcomer
Joined
Jan 14, 2022
Messages
10
Trophies
0
Age
48
XP
54
Country
Brazil
Not without a region change. A region change will effectively fully turn your console into a USA or EUR one, it will be indistinguishable other than the serial number. You can use ModMii to region change.
You can change the language setting for games ran from a USB Loader though. Just the system menu and settings can't be changed without a region change.
Thanks. Trying to do the Region Change now. The Wii is exploited and I started the NAND backup with BootMii but got a lot of ECC Failure.

Photo 15-01-22 10 42 49.jpg
 

spawnerbr

Member
OP
Newcomer
Joined
Jan 14, 2022
Messages
10
Trophies
0
Age
48
XP
54
Country
Brazil
I confess too that there are a lot of options and I'm very confused. After the NAND backup I tried to run the Homebrew Channel from the ModMii menu (boot) and nothing, only black screen. Dunno if I need homebrew installed on Wii or if I need to add the homebrew channel on the SD that ModMii created.
 

spawnerbr

Member
OP
Newcomer
Joined
Jan 14, 2022
Messages
10
Trophies
0
Age
48
XP
54
Country
Brazil
Now I'm on the Priiloader step. Started it on the Homebrew Cannel and got this message:
IOS36 ins't ES_Identify patched: error -1017
Press A to exit back to loader...


Downloaded the latest version of Priiloader from wii.guide and some message. As I can see, after read the install steps for Region Change, without this step with Priiloader I will have a semi-brick....
 

The Real Jdbye

*is birb*
Member
Joined
Mar 17, 2010
Messages
21,897
Trophies
3
Location
Space
XP
11,054
Country
Norway
Now I'm on the Priiloader step. Started it on the Homebrew Cannel and got this message:
IOS36 ins't ES_Identify patched: error -1017
Press A to exit back to loader...


Downloaded the latest version of Priiloader from wii.guide and some message. As I can see, after read the install steps for Region Change, without this step with Priiloader I will have a semi-brick....
Your HBC is outdated.
"If you have The Homebrew Channel 1.0.7 or above, you don't need any patched IOS at all! If you don't, then a patched IOS36 is required (although it is recommended to just update the HBC)"
From https://github.com/DacoTaco/priiloader
 

N7Kopper

Proud lover of a three-inch girlfriend
Member
Joined
Aug 24, 2014
Messages
798
Trophies
0
Age
28
XP
1,011
Country
United Kingdom
Your HBC is outdated.
"If you have The Homebrew Channel 1.0.7 or above, you don't need any patched IOS at all! If you don't, then a patched IOS36 is required (although it is recommended to just update the HBC)"
From https://github.com/DacoTaco/priiloader
Grab yourself the open source version - it's the most up-to-date. It has a different Title ID though, so you'll need to delete the old one manually.
 

spawnerbr

Member
OP
Newcomer
Joined
Jan 14, 2022
Messages
10
Trophies
0
Age
48
XP
54
Country
Brazil
After the error message from Priiloader I restored the NAND from the version after all process using ModMii. Connected to the internet the Homebrew Channel updated to the latest version. @N7Kopper I don't have any idea how to do that. I got 3 Wiis (BRA/USA/JPN) some days ago :)
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    KenniesNewName @ KenniesNewName: https://youtu.be/5BgvxLd7G0Y