Is Menu 4.0 Officially Safe/"Worth it"?

Discussion in 'Wii - Hacking' started by jservs7, Apr 7, 2009.

  1. jservs7
    OP

    jservs7 GBAtemp Advanced Fan

    Member
    891
    6
    May 14, 2008
    You can close this thread, merge it or post pics of a dead horse getting beaten, but with all the guides I have read through and people still having certain problems, I wanted an opinion if I should even bother updating.

    I am on 3.2U with a Wiikey 1.9s, USB Loader 1.1s, Preloader 0.28, the latest HBC and cIOS36 Rev 9 from Waninkoko. I never used any loaders like Softchip, etc. and I never used cIOSCorps. I would like to have more space for WADS so I don't have to worry about game save space so much, but I am more concerned about the risks and 3.2U has been fine for me.

    Bottom Line, I want to make sure I can "officially" do the following:

    - Install WADS using WAD Manager
    - Use the few Trucha signed discs that I have through the Disc Channel and no other method
    - Not worry about Nintendo auto-updating (Again I feel I have never found an official answer on this)
    - Copy and transfer official & unofficial WADs onto my SD Card
    - Still have functional Forwarder Channels


    I was going to wait a bit longer to try and look more into this, especially with Marcan and Co. working on an updated Twilight Hack, but with so much stuff going on, I don't want to be even more confused when the time comes.

    If you think I should just shut up and keep 3.2U, then I'm down with that too. [​IMG]
     
  2. Sebastian25

    Sebastian25 GBAtemp Regular

    Member
    127
    0
    Mar 25, 2007
    United States
    4.0 is worth it if u have a SDHC card and a desire to play lots of virtual console games.

    You can always downgrade from 4.0 to 3.2. I thought it was worth it, u just have to be sure to have WAD MANAGER compatabile SDHC
    and a stable internet connection.
     
  3. Shinigami Kiba

    Shinigami Kiba GBAtemp Advanced Fan

    Member
    606
    10
    Oct 28, 2007
    Macedonia, The Former Yugoslav Republic of
    I personally wouldn't touch it as safe as it may be, I love my WiiWare games and all, but to me it's not worth the risk.
     
  4. Ethanx94

    Ethanx94 GBAtemp Regular

    Member
    279
    9
    Aug 8, 2007
    United States
    In the parallel dimension
    Just don't do it. I think Nintendo put a crappy sd loader in it just to draw in the pirates and screw up their consoles. Just a theory but it makes sense with all the reporting of bricks around here recently.
    EDIT: At the time this was posted there was hell going on at the forums. Now it's died down and I finally got around to backing up my NAND and trying it. So far, I have to admit, I like it. The SD feature that "technically" is crappy actually works well. The only thing I lost in the process was my theme but that's not a problem. My attitude toward this has completely changed and everyone that wants to should follow the ultimate guide on here and give it a shot.
     
  5. nIxx

    nIxx GBAtemp Advanced Maniac

    Member
    1,528
    78
    Sep 30, 2007
    Gambia, The
    Germany
    Totally safe if you have cIOS installed before and with IOS60 patched you can play every installed wad from your SD Card (already done it with 3 Wii´s).
    Unfortunatly you can´t take the card to a friend and the WiiWare,VC games (possibly if you installed the wad before it works never tried it)
     
  6. jservs7
    OP

    jservs7 GBAtemp Advanced Fan

    Member
    891
    6
    May 14, 2008
    We share conspiracy theories. [​IMG] I was thinking the exact same thing. I have a SDHC that is compatible with the HBC and should work with the 4.0 update, but I feel my 2GB still works better since I don't have to refresh the HBC as soon as I sign on, unlike my SDHC which for some reason, does not show apps as soon as I sign in.

    Better SDHC compatibility in the HBC might be my selling point to finally update.
     
  7. jesterscourt

    jesterscourt Not Brad.

    Member
    2,179
    65
    Jan 3, 2007
    United States
    For those of us that could easy fill a larger SDHC with either media or legacy games for the emulators, hell yes. If not, I'd say you could probably hold off for the time being.
     
  8. masamunecyrus

    masamunecyrus Advanced Member

    Newcomer
    59
    2
    Dec 26, 2007
    United States
    I installed 4.0 using the ULTIMATE Guide and no problems -- I updated from 3.2U w/Starfall to 4.0U w/Preloader 0.29. I can install wads and then move them to the SD card and play them that way. I can still play MadWorld via the gamma loader. I don't have a spare external HDD so I haven't tried that, but everything is in working order. I've also updated one other Wii to 4.0 using the same guide successfully.
     
  9. Vidboy10

    Vidboy10 Tsardom

    Member
    2,617
    7
    Dec 15, 2008
    Canada
    Vancouver, B.C
    If you use my tutorial you will have all of the functions needed.
    just click on my sig. [​IMG]
     
  10. mrgarrison

    mrgarrison Advanced Member

    Newcomer
    66
    0
    Mar 13, 2009
    Canada
    Kelowna BC
    I also went from Starfall 3.2 to preloader 4.0. It was totally worth it, i think the main channel menu is a bit faster now that all those damn VC games are off there [​IMG] I'm only using a 2gig SD card and it has tons of room, dont see the need for a bigger one...

    Strange though. I used the same guide but step 1 and 2 wernt there.. but i used network install and it worked fine anyways.

    EDIT:

    Vidboy10 thats a good guide but the one assassda made does not require you to search for any files at all, easier for the n00bs like myself [​IMG]
     
  11. BBking83

    BBking83 GBAtemp Advanced Fan

    Member
    676
    4
    Oct 23, 2008
    Australia

    Yep! Works for me!
     
  12. troa11

    troa11 Older Than You

    Member
    248
    71
    Apr 11, 2006
    United States
    Although I have no answer for you about auto-update, I can verify that all the other functions work perfectly in system 4.0 if you install the cIOS first and use the proper "safe" updating method.
     
  13. jservs7
    OP

    jservs7 GBAtemp Advanced Fan

    Member
    891
    6
    May 14, 2008
    Man, compared to the "ULTIMATE 4.0 GUIDE", this seems too easy to give me all the same functions. [​IMG]
     
  14. dinofan01

    dinofan01 Misses the old days...

    Member
    2,842
    1
    Jul 4, 2008
    United States
    I thinks its worth it. Haven't run into a problem yet. I really don't think there's been too much an increase in bricks around here.
     
  15. BBking83

    BBking83 GBAtemp Advanced Fan

    Member
    676
    4
    Oct 23, 2008
    Australia
    This, I definately disagree with.

    People have been complaining about storage for a while. If people have bricked their Wii, they must have done something wrong.

    It was a very good, yet prolonged move my N. [​IMG]
     
  16. OSW

    OSW Wii King

    Former Staff
    4,796
    6
    Oct 30, 2006
    If you do it right (that is, use waninkokos or equivalent updater, so that your IOSs arent updated to remove trucha bug), everything works the same, if not better.

    On the same note, there isn't really any HUGE advantages, just a couple of nice additions, so you're not missing out on anything crazy good by staying on 3.2.

    The only disadvantage is that a few hacks like system menu themes aren't updated to work on 4.0 yet.

    ps: if you do it, do it like this.

    1. ensure u have 300 or > free blocks on your wii memory and your cios installed.
    2. use waninkokos 4.0 updater
    3. install preloader .29 and configure all the hacks you want from hacks.ini.

    EDIT: OH, and disk channel backup loading is a bit dodgy still [​IMG]