Is it safe update my friend's Wii, it uses an original Wiikey

Discussion in 'Wii - Hardware, Devices and Utilities' started by RodrigoDavy, Mar 14, 2013.

  1. RodrigoDavy
    OP

    RodrigoDavy GBAtemp Maniac

    Member
    1,453
    572
    Feb 9, 2011
    Brazil
    So... My friend have a Wii and Wiikey 1 in 1.9g firmware. We wanted to softmod it but we would need to do a Wii system update for that. (The Wii firmware is between 3.0 and 3.3 if I remember right) Does the Wiikey work in latest firmware? What about if I update the Wiikey to the latest 1.99 beta version?
     
  2. Bladexdsl

    Bladexdsl ZOMG my posts...it's over 9000!!!

    Member
    16,382
    3,971
    Nov 17, 2008
    Australia
    Queensland
    i have latest firmware, cios etc and my wiikey still works although it's pretty much obsolete now unless your using it for cube games.
     
  3. RodrigoDavy
    OP

    RodrigoDavy GBAtemp Maniac

    Member
    1,453
    572
    Feb 9, 2011
    Brazil
    The wiikey 1? And do you know what firmware is your wiikey?
     
  4. Lacius

    Lacius GBAtemp Guru

    Member
    6,284
    2,566
    May 11, 2008
    United States
    Yes, the Wiikey will continue to work on 4.3 (the latest version). You will lose the Wiikey's native region-free ability, but you can put it back using options such as Priiloader hacks.
     
    RodrigoDavy likes this.
  5. Bladexdsl

    Bladexdsl ZOMG my posts...it's over 9000!!!

    Member
    16,382
    3,971
    Nov 17, 2008
    Australia
    Queensland
    yes it's a wiikey 1 as for fw haven't got a clue don't even remember if i updated it or not i use loaders now :P
     
    RodrigoDavy likes this.
  6. RodrigoDavy
    OP

    RodrigoDavy GBAtemp Maniac

    Member
    1,453
    572
    Feb 9, 2011
    Brazil
    Thanks I've already updated wiikey to latest firmware (after some heavy searching on google for the update files) and now I updated my friend's Wii. Everything is working like a charm! Thanks for the help! :lol: