Hacking Is it safe to use USB helper on 5.5.2 or do i have to downgrade somehow?

Acryex

Member
OP
Newcomer
Joined
Apr 13, 2017
Messages
13
Trophies
0
Age
33
XP
58
Country
So being a dumbass i forgot to use the DNS hack to block updates on my system, now it's upgraded to the latest firmware and i want to test out some games before i actually buy them honestly.

Is it safe to use the Wii U USB Helper tool and install everything as before?
Or do i have to downgrade my firmware to be completely safe and not brick the entire console?

I'm so unsure about this, any help is appreciated.
 

Lacius

Well-Known Member
Member
Joined
May 11, 2008
Messages
18,100
Trophies
3
XP
18,324
Country
United States
First, it is not currently possible to downgrade. You're stuck on 5.5.2.

Second, you can use Wii U USB Helper with 5.5.2, so there's no need to downgrade. If you are using the 5.5.2 internet browser on your Wii U as your entry point, it's going to crash a lot. It could take several tries with the web browser before it loads homebrew. If you have issues with using the internet browser as your entry point, it is recommended that you use the web browser to install Haxchi.

If you are installing disc-based games and won't be loading CFW a lot (or if the web browser works fine), then there's no need for Haxchi.
 
Last edited by Lacius,
  • Like
Reactions: Acryex

Acryex

Member
OP
Newcomer
Joined
Apr 13, 2017
Messages
13
Trophies
0
Age
33
XP
58
Country
First, it is not currently possible to downgrade. You're stuck on 5.5.2.

Second, you can use Wii U USB Helper with 5.5.2, so there's no need to downgrade. If you are using the internet browser on your Wii U as your entry point, it's going to crash a lot. It could take several tries with the web browser before it loads homebrew. If you have issues with using the internet browser as your entry point, it is recommended that you use the web browser to install Haxchi.

If you are installing disc-based games and won't be loading CFW a lot (or if the web browser works fine), then there's no need for Haxchi.

Thanks, i'm going to be installing disc-based games actually.

Good to hear that it works then.

The homebrew crashing, is that a new thing since the 5.5.2 update?
 

Lacius

Well-Known Member
Member
Joined
May 11, 2008
Messages
18,100
Trophies
3
XP
18,324
Country
United States
Thanks, i'm going to be installing disc-based games actually.

Good to hear that it works then.

The homebrew crashing, is that a new thing since the 5.5.2 update?
Yes, the 5.5.2 browser exploit is unreliable and crashes a lot. On 5.5.1, it has a near 100% success rate.

I didn't mention it in my above post, but you should follow this guide to block future system updates, just in case.
 
  • Like
Reactions: Acryex

Site & Scene News

Popular threads in this forum

General chit-chat
Help Users
  • No one is chatting at the moment.
    Psionic Roshambo @ Psionic Roshambo: It's all good still a few nurses that are not pregnant yet lol +1