Is it safe to update my system firmware after using a Sky3DS ?

Discussion in '3DS - Flashcards & Custom Firmwares' started by Genjutsuhh, Aug 8, 2015.

  1. Genjutsuhh
    OP

    Genjutsuhh Advanced Member

    Newcomer
    95
    9
    Aug 8, 2015
    Pakistan
    The reason I want to do this is mainly to access the eShop, and why I want to do that is because there are a few games which I'd like to play online (Mario Kart 7, Super Smash Bros., Pokemon Y etc.) which require updates to be downloaded from the eShop to do so. Everytime I attempt to access the eShop it tells me to update to the latest firmware so I want to know if doing so is safe.

    For additional info, I have a New Nintendo 3DS XL with firmware 9.0.0-20U. Have played a few games using a Sky3DS on it but none online (am using a custom template with private headers though) and have also attempted the Ninjhax 2.0 exploit.
    Any and all help is appreciated, Thank you.
     


  2. migles

    migles Mei the sexiest bae

    Member
    GBAtemp Patron
    migles is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    6,795
    4,556
    Sep 19, 2013
    Saint Kitts and Nevis
    my dad works for nintendo.
    yes it is safe to update... sky3ds works on any firmware
    however you own a 9.0 console, don't upgrade it you could hack it.... and do lots of stuff...
     
  3. Genjutsuhh
    OP

    Genjutsuhh Advanced Member

    Newcomer
    95
    9
    Aug 8, 2015
    Pakistan
    You have managed to pique my interest... I am aware of the fact that many of the hacks work up till 9.2 (I managed to get lucky at getting a 9.0 console considering that I just bought it yesterday) but other than extracting and injecting headers as far as the Sky3DS is concerned are there even any notable and useful hacks that would require 9.0 ?
     
  4. migles

    migles Mei the sexiest bae

    Member
    GBAtemp Patron
    migles is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    6,795
    4,556
    Sep 19, 2013
    Saint Kitts and Nevis
    my dad works for nintendo.
    i didnt followed much the scene between 4.5 and 9.2 but i guess you can install emunand or use ninjax to downgrade or something... i don't know if you need a gateway for all that stuff...
    i would search around on what you can do...
    either way, i know you can downgrade it\install gateway, and emunand... however i don't know if you really require a gateway or you can do it with the ninjax\OOT

    want my advice, don't update it, search around, or wait for someone who can tell you more info here..
    if you really want to use the ESHOP, there was a way of spoofing the firmware... or use emunand.. whatever..
     
  5. Genjutsuhh
    OP

    Genjutsuhh Advanced Member

    Newcomer
    95
    9
    Aug 8, 2015
    Pakistan
    Guess I'll wait around until I get some more answers on this thread. Will dig around a bit too.
    Thanks for the help.
     
  6. metaljay

    metaljay GBAtemp Regular

    Member
    172
    46
    Jan 10, 2012
    Back up your NAND with a hard mod or through CFW, then update as you see fit
    That way you always have a way back if you decide to come back
     
  7. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,050
    3,367
    Nov 13, 2014
    United States
    Dont do this, stay on 9.0 when rxTools supports the New 3DS which it will soon after bugs get fixed you can use your sky3ds card to load Ninjhax through Cubic ninja and use rxTools.
     
  8. usernametaken

    usernametaken GBAtemp Maniac

    Member
    1,249
    345
    May 13, 2015
    United States
    +1 Do not update.

    You currently have an exploitable system. You can use CFW, you can use the eshop (with an app), you can play backed up games from your sky3ds or install them on your system using the cfw.

    Ninjhax 2.0 is a severe downgrade from what you currently have access to.
     
    Genjutsuhh and Xenon Hacks like this.
  9. Genjutsuhh
    OP

    Genjutsuhh Advanced Member

    Newcomer
    95
    9
    Aug 8, 2015
    Pakistan
    Thanks for the info. Could I get more insight on CFW ? I'm not familiar with what that is so could someone explain ?
     
  10. metaljay

    metaljay GBAtemp Regular

    Member
    172
    46
    Jan 10, 2012
    I'm guessing you didn't read OP, he said he wanted to play online?
    You can't do that with ANY of the hacks for N3DS...

    So yes, do what I wrote above.
     
  11. bache

    bache GBAtemp Advanced Fan

    Member
    694
    292
    Sep 28, 2009
    Uh, yes you can.
     
  12. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,790
    4,976
    Mar 17, 2010
    Norway
    Alola
    Uh, he can play online just fine. All he needs is the latest game update, which he can get by using Free Multi Patcher to enable eShop access in any CFW, or by installing a CIA file in any CFW.
    There is literally nothing that requires updating. Besides, updating will also make him unable to play Fire Emblem If or the new Animal Crossing or likely any other upcoming games on his Sky3DS, since games are coming out that have AP that blocks the Sky3DS cart, those games can still work by installing them as a CIA file though.
     
    Xenon Hacks likes this.
  13. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,050
    3,367
    Nov 13, 2014
    United States
    Please learn more before "trying" to help people he would have taken a perfectly good 9.0 unit and ruined it.
     
    osaka35 likes this.
  14. Genjutsuhh
    OP

    Genjutsuhh Advanced Member

    Newcomer
    95
    9
    Aug 8, 2015
    Pakistan
    Ok so to clear up some misunderstandings, what I mainly want is a way to update my games so that I can play them online.

    As far as the whole CFW thing goes, I have no knowledge on that and if there is a way to access the eShop OR update games without accessing eShop both without having to update my console's system firmware then that would be absolutely fantastic.
     
  15. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,050
    3,367
    Nov 13, 2014
    United States
    You can use your sky3ds to load Ninjhax 1.1b http://smealum.net/ninjhax/ through cubic ninja
    then run pasta CFW https://gbatemp.net/threads/pasta-c...d-on-old-and-new-3ds-required-ninjhax.388925/ so you can install CIA's to your Sysnand using FBI https://gbatemp.net/threads/release-fbi-open-source-cia-installer.386433/
    THEN run this https://gbatemp.net/threads/release-free-multi-patcher.391945/ CIA while in Pasta mode so you can access the eShop while on 9.0.
     
    osaka35 likes this.
  16. Genjutsuhh
    OP

    Genjutsuhh Advanced Member

    Newcomer
    95
    9
    Aug 8, 2015
    Pakistan
    Does this method pose any problems while downloading software ? (which in my case would be the game updates) other than that, what if I chose to use Ninjhax 2.0 instead since I already have that configured on my N3DS or is it necessary to use 1.1 ?
     
  17. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,050
    3,367
    Nov 13, 2014
    United States
    You need to use 1.1b, 2.0 blocks libkhax which most apps use. Smealum has yet to fix or address this.
     
  18. Genjutsuhh
    OP

    Genjutsuhh Advanced Member

    Newcomer
    95
    9
    Aug 8, 2015
    Pakistan
    If I remember correct, the regionfree launcher was introduced with Ninjhax 2.0 so since I'll be using 1.1 for this exploit, is there still any way to run out of region games ?
     
  19. usernametaken

    usernametaken GBAtemp Maniac

    Member
    1,249
    345
    May 13, 2015
    United States
    You can use RegionFour with Ninjhax 1.1 - With cfw and region patch, you should be able to use your Sky3ds out of region games without it though(?)

    Edit: RegionFree with Ninjhax2.0 is just a bit cleaner, you can see which game you're changing to as opposed to blinding switching to the game after the initial launch of RegionFour on Ninjhax1.1
     
  20. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,050
    3,367
    Nov 13, 2014
    United States
    freemultipatcher (the one that lets you get on the eShop) has a region spoofer built in.