Is it safe to re-run SysUpdater on what appears to be a frankenfireware N3DS?

Discussion in '3DS - Flashcards & Custom Firmwares' started by Click This, Feb 24, 2016.

  1. Click This
    OP

    Click This Surgite!

    Member
    531
    112
    Feb 18, 2012
    United States
    New York, New York
    Long story short, I ran SysUpdater on my new FE N3DS on 10.3 via Menuhax after using Ninjhax and got a system error in the middle of the downgrade. The console reboots fine and the system settings indicate I'm on 9.2, and I was able to reinstall Ninjhax and Menuhax. I'm fairly sure it's frankenfirmware since the titles sucessfully installed were less than with was when I downgraded my o3DS, but I have no other way to check. Right now, I'm all the way back up to SysUpdater via Ninjhax (SysUpdater won't load on Menuhax), but I'm hesitant to press (Y) again.

    Question is, can I re-run sysUpdater on "9.2" to try downgrading to 9.2 again, or is this a no-no? If I can't, what other course of action can I take?
     
    Last edited by Click This, Feb 24, 2016


  2. hobbledehoy899

    hobbledehoy899 Conniption Master

    Member
    2,630
    4,229
    Nov 13, 2015
    United States
    Kernel Version: Linux 4.13.2-1-zen
    You can do it.
     
  3. Click This
    OP

    Click This Surgite!

    Member
    531
    112
    Feb 18, 2012
    United States
    New York, New York
    Alright, I'll give it another try.
     
  4. hobbledehoy899

    hobbledehoy899 Conniption Master

    Member
    2,630
    4,229
    Nov 13, 2015
    United States
    Kernel Version: Linux 4.13.2-1-zen
    You'll be happy with the results.
     
  5. Click This
    OP

    Click This Surgite!

    Member
    531
    112
    Feb 18, 2012
    United States
    New York, New York
    I seem be consistently getting "Failed to get CIA file info!" unfortunately. :(
     
  6. hobbledehoy899

    hobbledehoy899 Conniption Master

    Member
    2,630
    4,229
    Nov 13, 2015
    United States
    Kernel Version: Linux 4.13.2-1-zen
    Shit... I'd just keep trying at this point.
     
  7. gunner007

    gunner007 GBAtemp Advanced Maniac

    Member
    1,506
    368
    Dec 31, 2013
    United States
    Use the downgrader checker if you're able to run ninjiahx. On phone, so just look at my recent post history and you'll find a post with it attached. Run that and find what titles are missing. If you're on a 9.2 firm though, you can just do something like use Pasta and FBI to install regular sysupdater to sysNAND and then just use pasta mode again to downgrade those titles.
     
  8. Click This
    OP

    Click This Surgite!

    Member
    531
    112
    Feb 18, 2012
    United States
    New York, New York
    Yep, came up with a shitton of mismatched versions, native_firm comes up in that list. If I had to do the latter, how would I go about that? Been a while since I've used FBI and I've never used Pasta.
     
  9. gunner007

    gunner007 GBAtemp Advanced Maniac

    Member
    1,506
    368
    Dec 31, 2013
    United States
    Kind of confused, can you post the logfile (or attach it)? You say SysUpdater, do you mean SafeSysUpdater? As far as I knew, sysupdater hadn't implemented memchunkhax2.

    Edit: Unless you're talking about the earlier juliaan/tuxsh.
     
    Last edited by gunner007, Feb 24, 2016
  10. FenrirWolf

    FenrirWolf GBAtemp Psycho!

    Member
    4,347
    329
    Nov 19, 2008
    United States
    Sandy, UT
    That's totally what he's talking about.
     
    hobbledehoy899 likes this.
  11. Click This
    OP

    Click This Surgite!

    Member
    531
    112
    Feb 18, 2012
    United States
    New York, New York
    Attached the file. I'm pretty sure I used the juliaan version.
     

    Attached Files:

  12. gunner007

    gunner007 GBAtemp Advanced Maniac

    Member
    1,506
    368
    Dec 31, 2013
    United States
    Yea, it's still on a 10.2 native firm, Pasta probably won't work then. You can try the downgrade again, but not sure if it would work. Just delete the files and copy them back onto the SD and try again. (the downside to safesysupdater is if it errors out, you need OOT/CN since it installs NATIVE_FIRM early on in the process)
     
  13. Click This
    OP

    Click This Surgite!

    Member
    531
    112
    Feb 18, 2012
    United States
    New York, New York
    Yep. I've overwritten the .cia files on the SD card and tried again several times, but I continue to get that darned failed to get.cia info error. Should I try out safesysupdater? I've got an OOT cart and CN via an old Sky3ds, but I've heard bad things about SSU.
     
    Last edited by Click This, Feb 24, 2016
  14. gunner007

    gunner007 GBAtemp Advanced Maniac

    Member
    1,506
    368
    Dec 31, 2013
    United States
    SSU has a bad habit of crashing in the middle of the downgrade, but it tends to install NATIVE FIRM early in the process whcih requires OOT/CN to fix up with Pasta. You could try if you have no luck with the other.
     
  15. Click This
    OP

    Click This Surgite!

    Member
    531
    112
    Feb 18, 2012
    United States
    New York, New York
    At this junction, I'm not at any further risk of bricking the device, right? But if does install the NATIVE_FIRM, what exactly is the fix required and what for?

    Edit: Yeah, really just keep getting the cia file error. I'll try SSU.
     
    Last edited by Click This, Feb 24, 2016
  16. DarkKaine

    DarkKaine GBAtemp Regular

    Member
    272
    293
    Dec 1, 2014
    Netherlands
    Can you get into emuNAND? The arm9loaderhax tutorial downgrades the emuNAND for safety using sysupdater to 2.1 which is then flashed to sysNAND with Decrypt9. I assume you can do a similar thing with frankenfirmware emuNAND, to avoid writing to sysNAND too much.
     
  17. Click This
    OP

    Click This Surgite!

    Member
    531
    112
    Feb 18, 2012
    United States
    New York, New York
    Haven't installed emuNAND yet, just pulled the thing fresh out of the box.
     
  18. gunner007

    gunner007 GBAtemp Advanced Maniac

    Member
    1,506
    368
    Dec 31, 2013
    United States
    Pretty sure he's coming down from 10.3 so he hasn't even set up an emuNAND, much less CFW.

    If it bombs out midway (but at least installs NATIVE_FIRM) you can do the following.

    1. Boot the console into your Frankenfirm (may need to remove the SD)
    2. Boot Ninjihax (you may need to adjust your payload (if you're on say 9.2.0-20U get that payload, or if it says something like 9.2.0-26U you'll need that.
    3. Launch miniPasta
    4. When console reboots, launch Ninjihax again, and choose FBI
    5. Use FBI to install sysupdater CIA to sysNAND (regular sysupdater, not memchunkhax2)
    6. Shutdown console
    7. Boot again into Ninjihax, and choose Pasta once more.
    8. Run sysupdater.cia and choose downgrade. Should get you where you want to go

    Edit: One option you can try once sky3ds updates their info is that the special edition fates game comes with a 10.3 firmware update. You could try using that to update the system back to 10.3 and try again.
     
    Last edited by gunner007, Feb 24, 2016
  19. Click This
    OP

    Click This Surgite!

    Member
    531
    112
    Feb 18, 2012
    United States
    New York, New York
    Heh, I happen to have the physical cart for that.

    In anycase, I used SSU and it downgraded neat and clean, although I had to manually reboot. Using downgradechecker, almost all of the mismatches were cleared up, but surprisngly, GPIO system-moldule, DSP-system-module, and amiibo settings still have a mismatch. Not sure if that's normal or not.
     
    gunner007 likes this.
  20. gunner007

    gunner007 GBAtemp Advanced Maniac

    Member
    1,506
    368
    Dec 31, 2013
    United States
    Awesome to hear! Yea those 2 are normal (most downgrade packs omitted them, I can PM them to you if you care) and won't affect anything. The amiibo title can be deleted/left alone as it never existed on 9.2

    Anyways, good luck and glad to hear you got it working!