Is it possible to manually update Browser -12u to -20u

Discussion in '3DS - Flashcards & Custom Firmwares' started by Kyle Ziemke, Aug 5, 2016.

  1. Kyle Ziemke
    OP

    Kyle Ziemke Advanced Member

    Newcomer
    51
    6
    Jul 24, 2016
    United States
    Title.

    I am currently on 9.2.0-12u and Browserhax and ninjahax both versions do not work for me.

    Second part to question if i have a hardmod can i just write 9.2.0-12u firmware to it or is that not possible.

    Thanks in advance guys
     


  2. Lacius

    Lacius GBAtemp Guru

    Member
    5,594
    2,102
    May 11, 2008
    United States
    Yes, I believe you can. You can use the spider exploit to run CFW and install a newer browser.

    Edit: Follow this guide, but you only need to install the browser instead of the entire update package.
     
    Last edited by Lacius, Aug 5, 2016
  3. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,445
    4,761
    Mar 17, 2010
    Norway
    Alola
    Have you tried Ninjhax 2? It should work with 9.2.0-12U (the lowest browser version in the drop down box is 7)
    https://smealum.github.io/ninjhax2/
     
  4. Quantumcat

    Quantumcat Dead and alive

    Member
    9,842
    5,144
    Nov 23, 2014
    Australia
    Canberra, Australia
    As Jdbye said Ninjhax2 will definitely work as it doesn't use the browser at all. Just set the drop downs to 9.2.0 and put anything for the browser number (don't worry if -12 is not available), use the QR code it gives you and it will work.

    Edit: sounds like -12 is available but it won't matter what you put.
     
    Last edited by Quantumcat, Aug 5, 2016
  5. MelonGx

    MelonGx GBAtemp Advanced Maniac

    Member
    1,630
    438
    Jan 8, 2009
    China
    Do not just upgrade the browser. Always keep the browser version fitting for your main version.
    Otherwise it will destroy Spider-hack-related entrypoints, such as web-boot rxTools, web-boot Decrypt9, etc.

    For I know, both CakeHax and rxTools 2.X web entrypoint SUCK on supporting specific frankenfirmwares which have unmatched browser.
    And you need them (in some cases they're the ONLY OPTION) to upgrade SysNAND to 9.2.0.
     
    Last edited by MelonGx, Aug 5, 2016
  6. Kyle Ziemke
    OP

    Kyle Ziemke Advanced Member

    Newcomer
    51
    6
    Jul 24, 2016
    United States
    This is the problem I'm having. I had mismatched spider versions when I was back on 6.2 I did a cart upgrade with ssb to 9.2 thinking it would let the browser sprouts start working again. But the still don't even worse is that not even ninjhax 1 or 2 will work. I really need some help figuring out why no matter what I do I can't run any exploit.

    I believe my main issue is the browser as nothing browser related works. And ninjhax gets to loading ropbin than crashes.
     
  7. Lacius

    Lacius GBAtemp Guru

    Member
    5,594
    2,102
    May 11, 2008
    United States
    Did you follow this guide exactly? What about this one?
     
    Last edited by Lacius, Aug 5, 2016
  8. Quantumcat

    Quantumcat Dead and alive

    Member
    9,842
    5,144
    Nov 23, 2014
    Australia
    Canberra, Australia
    What exacty are you doing for Ninjhax 2? Are you sure you're not making a mistake? It should work no matter your browser version.
     
  9. Selver

    Selver 13,5,1,14,9,14,7,12,5,19,19

    Member
    199
    276
    Dec 22, 2015
    Questions I would consider important:
    1. Do you already have the XORPADs for your console's FIRM and system partitions?
    2. Do you already have a hardmod?
    3. Do you have a NAND dump? (optional if you already have a hardmod)
    These answers can determine the options available to you, other than the "standard" guide options.

    For example, if the system's fragmentation caused trouble (as some claim, although I've not seen technical writeup supporting it), you could offline-defrag:
    (e.g., XOR the system partition, mount it on a PC, defragment it, re-XOR it, and then write the defragmented version back to your NAND)

    Please confirm what options you currently have available? (e.g., which homebrew entry points you "should" have access to, such as CN or OoT carts, powersaves dongle, etc.)
     
  10. olec04

    olec04 Working on Project Heaven!

    Banned
    851
    142
    Apr 10, 2015
    United States
    Trying to downgrade on 11.0 via AM services
    1. No
    2. Maybe
    3. No
     
  11. Kyle Ziemke
    OP

    Kyle Ziemke Advanced Member

    Newcomer
    51
    6
    Jul 24, 2016
    United States
    I have access to rxtools cubic ninja and browser but all entry methods have failed. Rxtools the bottom screen pukes random colored pixels browser freezes on orange creen and ninja just says error occured.
    Edit - I also have access to be able to hardmod it. havent done anything with it yet.

    Lacius
    yes copied both sets of guides verbatim cannot get into hbl.

    Quantumcat
    I am sure im not making any mistakes. Load the ninjahax webpage put in your firmware and push update qr code than scan it with the qr code in cubic ninja lol.

    What boggles my mind about this whole thing the most is not a single thing ive tried has worked without crashing my system. Why is that?
     
    Last edited by Kyle Ziemke, Aug 5, 2016
  12. olec04

    olec04 Working on Project Heaven!

    Banned
    851
    142
    Apr 10, 2015
    United States
    Trying to downgrade on 11.0 via AM services
    i thought you were gonna hardmod?!
     
  13. Lacius

    Lacius GBAtemp Guru

    Member
    5,594
    2,102
    May 11, 2008
    United States
    This guide doesn't use rxTools. Have you even tried it?
     
    Quantumcat likes this.
  14. Quantumcat

    Quantumcat Dead and alive

    Member
    9,842
    5,144
    Nov 23, 2014
    Australia
    Canberra, Australia
    Definitely putting the correct region and Old/New? That is weird because I have used Ninjhax 2 on about 5 systems updated with a cart (9.2.0-4 and 9.2.0-6) and they all worked.
     
  15. olec04

    olec04 Working on Project Heaven!

    Banned
    851
    142
    Apr 10, 2015
    United States
    Trying to downgrade on 11.0 via AM services
    yes i gave it to him correctly
     
  16. Kyle Ziemke
    OP

    Kyle Ziemke Advanced Member

    Newcomer
    51
    6
    Jul 24, 2016
    United States
    Sorry I was speaking as a generality yes I used the updated version and it crashes to home after the orange screen and with the first guide it just crashes with error occured
     
  17. Lacius

    Lacius GBAtemp Guru

    Member
    5,594
    2,102
    May 11, 2008
    United States
    At which step?
     
  18. olec04

    olec04 Working on Project Heaven!

    Banned
    851
    142
    Apr 10, 2015
    United States
    Trying to downgrade on 11.0 via AM services
    k ill leave now :/
     
  19. Kyle Ziemke
    OP

    Kyle Ziemke Advanced Member

    Newcomer
    51
    6
    Jul 24, 2016
    United States
    It seems like it should be foolproof but something keeps causing it to crash. If I get to the ctual loading it gets to 40 than goes to browser and freezes.
     
  20. Quantumcat

    Quantumcat Dead and alive

    Member
    9,842
    5,144
    Nov 23, 2014
    Australia
    Canberra, Australia
    I think there's something seriously wrong with your system. If you end up installing a hardmod, if everything fails you can still try an internet update to 11.0 and then using the hardmod to downgrade (install the hardmod first and backup the NAND you have now, though).