1. RyuShinobi500

    OP RyuShinobi500 C0D3 N1Nj4
    Member

    Joined:
    Oct 25, 2019
    Messages:
    556
    Country:
    United States
    Okay thank you

    — Posts automatically merged - Please don't double post! —

    Yes I am running OpenGL 2.1 but my PC was made in 2002 so this is all it supports:(
     
  2. SagaP

    SagaP Advanced Member
    Newcomer

    Joined:
    Nov 3, 2015
    Messages:
    57
    Country:
    Venezuela
    This is not the same thing, but you can apply software render directly to incompatible applications without a VM

    Just:
    Code:
    $ LIBGL_ALWAYS_SOFTWARE=1 "your aplication"
    With that you can force software rendering in any application you want allowing you to run software that requires higher level API

    my laptop's graphics card can only render software up to opengl 2.1 so i use it for some games :P

    Your problem can also be due to this https://gitlab.com/beelzy/kame-editor#issues but i'm not sure since i haven't try kame-editor so i just hope any of this helps
     
    Deleted-236924 and RyuShinobi500 like this.
  3. smf

    smf GBAtemp Psycho!
    Member

    Joined:
    Feb 23, 2009
    Messages:
    3,755
    Country:
    United Kingdom
    What games? How playable is it?
     
  4. SagaP

    SagaP Advanced Member
    Newcomer

    Joined:
    Nov 3, 2015
    Messages:
    57
    Country:
    Venezuela
    Mostly 2D games or light 3D games, Enter the Gungeon, Return of the Obra Dinn, Moonlighter and Cultist Simulator, i have to lower the resolution and they get to around 26 ~ 30 fps, Except for Cultist simulator that game ran very well at native resolution 1366x768 with graphics set to basic.

    I have and i5 1st generation (i5 M250)
     
  5. RyuShinobi500

    OP RyuShinobi500 C0D3 N1Nj4
    Member

    Joined:
    Oct 25, 2019
    Messages:
    556
    Country:
    United States
    Thank you so much for the help this worked I ran the command

    Code:
    LIBGL_ALWAYS_SOFTWARE=1 kame-editor
    and it works! :bow: many thanks sir
     
    SagaP and MythicalData like this.
  6. CMDreamer

    CMDreamer GBAtemp Advanced Fan
    Member

    Joined:
    Oct 29, 2014
    Messages:
    683
    Country:
    Mexico
    From the error mesage we can see this:

    "QOpenGLShader::compile(Fragment): 0:1(10): error: GLSL 3.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES"

    Your hardware doesn't support OpenGL 3.30, and there's no way for it to support it.

    But you can "force" an application to work on a specific OpenGL version, at least on Linux.

    Edit: Oh OK, you managed to do it, great!
     
    Last edited: Jan 19, 2020
    MythicalData and RyuShinobi500 like this.
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - possible, outdated, version