Is it ok to update 3ds to Ver. 7.1.0?

Discussion in '3DS - Flashcards & Custom Firmwares' started by S4L, May 1, 2016.

  1. S4L
    OP

    S4L Newbie

    Newcomer
    7
    1
    Apr 9, 2016
    United States
    I have 3ds version lower than 4.0, and I just got a sky3ds+.
    I wanted to keep 3ds to the lowest version but Majora's Mask shows a message 'A system update is required to use this software. Update to Ver. 7.1.0-6U'.
    I'm using sky3ds+ so updating to the newest version wouldn't matter but I wanted to keep my 3ds lowest version possible just in case.
    Should I update 3ds since I'm using sky3ds+? or will I be better to keep it lowest version?
     


  2. ihaveamac

    ihaveamac GBAtemp Guru

    Member
    5,389
    5,833
    Apr 20, 2015
    United States
    Tigard, OR
    astronautlevel likes this.
  3. S4L
    OP

    S4L Newbie

    Newcomer
    7
    1
    Apr 9, 2016
    United States
    It seems like lots of steps....Will I have to update to 9.2 using your instruction?
    or Can I just update 3ds to the newest version and use sky3ds+? or Your instruction is required to play Majora's Mask using sky3ds+ on my 3ds?
     
  4. astronautlevel

    astronautlevel Trying to Find My Way

    Member
    4,025
    4,962
    Jan 26, 2016
    United States
    That Nightly Site™
    You can update to the newest version and use sky3ds+ as a cubic ninja cart and downgrade to 9.2, which may be easier than using rxTools to update to 9.2.
     
    TheKawaiiDesu likes this.
  5. CrispyYoshi

    CrispyYoshi GBAtemp Advanced Maniac

    Member
    1,516
    502
    Mar 20, 2010
    United States
    You should update to 9.2 if you want to play the game, follow the rest of the guide if you want a permanent hack solution (You can update your system!), or update to the latest firmware if you think Nintendo won't block Sky3DS+
     
  6. astronautlevel

    astronautlevel Trying to Find My Way

    Member
    4,025
    4,962
    Jan 26, 2016
    United States
    That Nightly Site™
    Because the sky3ds+ works like an actual game cart and loads official ncch stuff and signatures from the roms it's highly unlikely Nintendo will be able to block sky3ds+ without a hardware revision. That being said CFW may be better anyway because it's permanent and doesn't require private headers.
     
    CrispyYoshi likes this.
  7. CrispyYoshi

    CrispyYoshi GBAtemp Advanced Maniac

    Member
    1,516
    502
    Mar 20, 2010
    United States
    Is this specifically the Sky3DS+? The Sky3DS is update-able now too, right? (It sounds a lot like how the DSTWO got around 3DS blocking)
     
  8. hobbledehoy899

    hobbledehoy899 Conniption Master

    Member
    2,632
    4,239
    Nov 13, 2015
    United States
    Kernel Version: Linux 4.13.2-1-zen
    2.1.0-4?
    That would be the simplest option and the one that I would go with in if I was in his situation.
     
  9. astronautlevel

    astronautlevel Trying to Find My Way

    Member
    4,025
    4,962
    Jan 26, 2016
    United States
    That Nightly Site™
    Sky3DS does work on the latest firmware but it can't load newer games with new anti-piracy.
     
    Last edited by astronautlevel, May 1, 2016
  10. CrispyYoshi

    CrispyYoshi GBAtemp Advanced Maniac

    Member
    1,516
    502
    Mar 20, 2010
    United States
    Oh I see! That's actually pretty bad haha...

    Do you think that any of the game-based entrypoints can ever get patched?

    EDIT: Another question, this also means that region-free on latest firm via Sky3DS+ isn't possible too, right? I hope this isn't hijacking the thread, although I think this does clarify some of the pros/cons of the flashcart.
     
    Last edited by CrispyYoshi, May 1, 2016
  11. astronautlevel

    astronautlevel Trying to Find My Way

    Member
    4,025
    4,962
    Jan 26, 2016
    United States
    That Nightly Site™
    I highly doubt oothax will be patched given that the release nintendo selects version wasn't patched.

    Ninjhax cannot be patched as the game studio went under so no one has the source code or the license to develop the game

    SMDHax may be patchable given that it's a newer game, but I highly doubt Nintendo will pursue secondary exploits. As Shiny Quagsire said in his technical writeup for (v*)hax:

    There's so many potential secondary exploits that there's really no point in Nintendo trying to patch them.
     
    CrispyYoshi likes this.
  12. hobbledehoy899

    hobbledehoy899 Conniption Master

    Member
    2,632
    4,239
    Nov 13, 2015
    United States
    Kernel Version: Linux 4.13.2-1-zen
    Cubic Ninja would have to be completely blocked from running on the console to patch Ninjhax, Ocarina Of Time would need a patch that would only fix the save exploit (same for Super Mystery Dungeon,) and Ironhax is already dead (good riddance.)
     
    CrispyYoshi likes this.
  13. CrispyYoshi

    CrispyYoshi GBAtemp Advanced Maniac

    Member
    1,516
    502
    Mar 20, 2010
    United States
    So basically that means Nintendo can't do anything about Ninjhax and will probably be too lazy to patch the others? Really interesting, I'll have to modify my recommendation to OP, then!

    @S4L: You should update to 9.2 if you want to play Majora's Mask. You can spend about $70 to get a Sky3DS+ if you want a quick solution to playing games on the latest firmware. At any point before or after you get your Sky3DS+, you can follow the 3-5 hour Plailect Wiki Guide if you want a free alternative to the Sky3DS/more control over your system to be able to do things such as play games that came out requiring 9.6+ firmware (it seems being on latest firmware isn't good enough to resolve this issue, but I'm not sure), easier access to homebrew, and home-menu game management. I'm not sure if I'm missing anything else (Themes/out of region games, maybe?), but I think Sky3DS+ might be the way to go, if you're willing to pay for it.
     
    hobbledehoy899 likes this.
  14. Hking0036

    Hking0036 GBAtemp Fan

    Member
    397
    194
    Sep 15, 2015
    United States
    Smash has 9.2 on it, too, if they used it they could update directly to the right version.
     
    CrispyYoshi likes this.
  15. astronautlevel

    astronautlevel Trying to Find My Way

    Member
    4,025
    4,962
    Jan 26, 2016
    United States
    That Nightly Site™
    True, but Sm4sh is the only cart that allows you to go to 9.2 and iirc only some revisions of the game have it.
     
    Hking0036 and CrispyYoshi like this.
  16. CrispyYoshi

    CrispyYoshi GBAtemp Advanced Maniac

    Member
    1,516
    502
    Mar 20, 2010
    United States
    Only some copies of Smash! Normally I wouldn't recommend doing this unless you have the web browser, but if you have a Sky3DS emulating the Rev01 version of Smash, the lack of a browser shouldn't be an issue anyway.
     
    hobbledehoy899 and Hking0036 like this.
  17. S4L
    OP

    S4L Newbie

    Newcomer
    7
    1
    Apr 9, 2016
    United States
    Yes. I bought 3ds when they first came out and have not touched since then.
     
  18. hobbledehoy899

    hobbledehoy899 Conniption Master

    Member
    2,632
    4,239
    Nov 13, 2015
    United States
    Kernel Version: Linux 4.13.2-1-zen
    What is the exact firmware?
     
  19. Hking0036

    Hking0036 GBAtemp Fan

    Member
    397
    194
    Sep 15, 2015
    United States
  20. astronautlevel

    astronautlevel Trying to Find My Way

    Member
    4,025
    4,962
    Jan 26, 2016
    United States
    That Nightly Site™
    Hking0036 likes this.