Is it me or does GBA support suck on G6L?

Discussion in 'Other Flashing Hardware & Software' started by nunofgs, Aug 28, 2006.

  1. nunofgs
    OP

    nunofgs GBAtemp Regular

    Member
    185
    0
    Mar 16, 2006
    I used to have an M3 and I've never had a problem with a single GBA or NDS game. With my new G6 Lite, half of my GBA games keep saying "The game will not run on this hardware".

    Also, pretty much all of my NDS games don't work with download play. When I try to play a single-cart download play game, my girlfriend's FLASHED DS just white-screens right after downloading the game. The only game I've managed to get working is Tetris.

    *sigh* I should have waited for the M3 Lite...
     


  2. Golds

    Golds Old Member

    Member
    373
    0
    Dec 2, 2004
    United States
    i have not had any problems with GBA support.
    And I bet the M3 will have the same single cart download issues.
     
  3. Drucifer

    Drucifer Member

    Newcomer
    47
    0
    Jul 7, 2006
    Canada
    Can you name a few GBA games that you are having issues with? I have yet to encounter any problematic GBA games.
     
  4. ds6220

    ds6220 GBAtemp Fan

    Member
    393
    0
    Jul 10, 2006
    United States
    Yeah, I would be interested to find out what GBA games you are having problems with because right now you just sound like a h8ter. [​IMG] I would be happy to test out some GBA games if you can name some, but right now all I have is Boktai 2 on my G6 Lite.
     
  5. RyuKakashi

    RyuKakashi GBAtemp Fan

    Member
    450
    0
    Mar 18, 2006
    United States
    G6 Lite is much better in the GBA department than it is in the NDS but both are relatively perfect.

    GBA I haven't had a single problem with, and you got tons of nice features with the ingame menu too.

    If that menu only existed for NDS....
     
  6. doodad

    doodad Member

    Newcomer
    24
    0
    Jul 27, 2006
    Are you sure you're not just trying to jam a piece of cheese into the DS console? It sounds like that might be the case.

    I had that problem for a while until I received my G6 Lite. GBA games won't work on a piece of cheese.
     
  7. nunofgs
    OP

    nunofgs GBAtemp Regular

    Member
    185
    0
    Mar 16, 2006
    Ok, I've done some more research and it seems the problem is with a few games that detect the save game type and freak out. There are IPS patches out there, but not for all the games I'd like to play [​IMG]
     
  8. mthrnite

    mthrnite So it goes.

    Former Staff
    4,529
    944
    Jun 30, 2006
    United States
    th' south
    Try any of the Bit Generations games. I upgraded to 4.3 and flashme'd my DS at about the same time. Now my fave "Orbital" won't work, just white screens. [​IMG]
    I don't know if it's the upgrade or the new firmware, but something's wacky.
     
  9. Zap

    Zap GBAtemp Regular

    Member
    216
    0
    Mar 29, 2003
    United States
    Hmm. You are a little vague as to how you loaded the game onto the cart and which games they are. I have yet to run into any nds or gba problems. In fact, I play animal crossing with a friend from another state through WIFI just fine.(he, of course, does not have a flashed DS nor a flash kit)

    FYI, dragging and dropping the .gba or .nds files into their respective folder will most likely not work. You must use the software provided.(and that's a good thing too since you can patch for soft reset and such)

    EDIT: spelling/grammar
     
  10. mthrnite

    mthrnite So it goes.

    Former Staff
    4,529
    944
    Jun 30, 2006
    United States
    th' south
    Ok, my mistake [​IMG]
    I was trying to run orbital by going through the DS menu (My Card) and not by holding select and booting into the GBA menu.
    Orbital works fine now, so does Dotstream [​IMG]
    Sorry for the confusion.
     
  11. Falkentyne

    Falkentyne GBAtemp Regular

    Member
    193
    0
    Jul 11, 2006
    United States
    The only games that don't work on the G6 Lite are the NES classic series. And that's not the G6L's fault--they won't work on Visualboy Advance, either, unless you IPS patch them or use a custom ini file.

    GBA compatibility (besides games that don't work on emulators anyway) is 99% at least.
     
  12. nunofgs
    OP

    nunofgs GBAtemp Regular

    Member
    185
    0
    Mar 16, 2006
    Ok, I'll be a little more specific. The GBA games that are not running are basicly every DBZ rpg for GBA. As I have said, I have discovered that you need to patch these specific games. Every other game (zelda games for instance) seem fine.

    About the NDS games I have tried to play New Super Mario, Big Brain Academy, Meteos and a few others unsucessfully (by local wireless single card play, not wifi). All of them white-screen right after the nintendo logo. The only one I got to work was tetris DS. Like I said, all of these games worked with my old M3.

    Don't get me wrong, I'm loving my G6 Lite (I don't really want to be a hater), it's just that I'm a bit disappointed since I had zero problems with my old M3 :/
     
  13. Vidnez

    Vidnez Advanced Member

    Newcomer
    54
    0
    Jul 31, 2006
    Racing Gears Advance don't work for me , that sucks because is one of my favorites games.
     
  14. nunofgs
    OP

    nunofgs GBAtemp Regular

    Member
    185
    0
    Mar 16, 2006
    I just tried Racing Gears Advance and I can confirm that it does NOT work. It just white-screens [​IMG]
     
  15. ds6220

    ds6220 GBAtemp Fan

    Member
    393
    0
    Jul 10, 2006
    United States
    This is just confusing. Works fine for me. I just grabbed it to see and put it on with no special patch or anything. Is it that it does not save? What was the problem here? I would love to dispel this evil myth about the G6 right now. There is something very fundamental that you guys must be doing wrong. [​IMG]

    I repeat. Racing Gears Advance DOES work on my G6 Lite.
     
  16. Zap

    Zap GBAtemp Regular

    Member
    216
    0
    Mar 29, 2003
    United States
    What loader version is everyone using?

    That maybe the problem. I have not personally tried, but have heard that 4.2 seems to be giving problems.

    I'm using the latest 4.3 and everything is in place.
     
  17. ds6220

    ds6220 GBAtemp Fan

    Member
    393
    0
    Jul 10, 2006
    United States
    yes, I am using 4.3a U-disk and 4.3 FW and Racing Gears Advance DOES work with that set up.
     
  18. Vidnez

    Vidnez Advanced Member

    Newcomer
    54
    0
    Jul 31, 2006
    When I tried to run it I got a white screen. I was using the Loader and Manager V4.3, then I installed the new version 4.3a and I have the same problem.
     
  19. ds6220

    ds6220 GBAtemp Fan

    Member
    393
    0
    Jul 10, 2006
    United States
    is your DS flashed? I would not think that makes a difference but after the 534 and 535 fiasco (not really a big deal but interesting so I say fiasco) we may need to ask that.
     
  20. Zap

    Zap GBAtemp Regular

    Member
    216
    0
    Mar 29, 2003
    United States
    Hmm, that's rather wierd. How are you loading games onto your flash card?

    I did get white screens as well when I just drag and drop the .nds files onto the flash card. However, using the software included to load the exact same file onto the flash card works flawlessly.