Is it IMPOSSIBLE to install .cia with ninjahax 2.0 (9.8 firmware)

Discussion in '3DS - Homebrew Development and Emulators' started by Wizardkoer, Aug 8, 2015.

  1. Wizardkoer
    OP

    Wizardkoer Wii Veteran

    Member
    429
    82
    Jul 14, 2015
    Australia
  2. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,124
    3,422
    Nov 13, 2014
    United States
    No just update to 9.9 you can run basic homebrew like Emulators/extDATA editing/Apps/ but never any thing that would modify the system. So to sum things up no you cant install CIA's on any 3DS above 9.2 unless you have Gateway/rxTools and you're using Emunand (which requires you to be on 9.2 and below).
     
  3. ifrit05

    ifrit05 Advanced Member

    Newcomer
    68
    55
    Aug 11, 2014
    United States
    AFAIK only ninjahax 1.0 supports CIA installation. Nintendo patched am access (Application Managment Services, i.e. CIA utilities) and other stuff after ninjahax 1.0 was released, hence 2.0 doesn't support FBI.
    Now the cool thing about ironhax exploit is in the video smea posted on vine/twitter showed some am:u logging so the consensus is that it will again be possible to use FBI. So just go ahead and update to 9.9 and download IronFall asap before it's taken down.

    Feel free to correct me if i'm wrong anyone.

    EDIT: Yup, seems I'm a little wrong but still, get IronFall asap.
     
  4. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,124
    3,422
    Nov 13, 2014
    United States
    Also would you happen to have a NAND backup and what firmware would that backup be?

    — Posts automatically merged - Please don't double post! —

    No even with Ninjhax/Ironhax 2.0 FBI is out of the question if you are over 9.2.
     
    ifrit05 likes this.
  5. ifrit05

    ifrit05 Advanced Member

    Newcomer
    68
    55
    Aug 11, 2014
    United States
    Thanks for the correction on my part.
    PS: Love your sig. :P
     
  6. Psi-hate

    Psi-hate GBATemp's Official Psi-Hater

    Member
    1,666
    1,060
    Dec 14, 2014
    United States
    Houston
    You could install clean Cias without kernel access with the am service, but nintendo patched gspwn in 9.3. But actually, Smea may have found a new exploit for that, because we see him calling the am:init() in the HB menu a few weeks ago. If he managed to find a new exlpoit to call AM services, then we'd be able to downgrade by installing legit 9.2> cias.
     
    Xenon Hacks likes this.
  7. Wizardkoer
    OP

    Wizardkoer Wii Veteran

    Member
    429
    82
    Jul 14, 2015
    Australia
    Wait you've got me interested. What do you mean by am:init()? sorry im a noob at 3ds hacking im only good with wii homebrew lol. Please explain how it is possible to downgrade to 9.2??
     
  8. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,124
    3,422
    Nov 13, 2014
    United States
    We don't know what service he calls or how he uses it we will see a release soon and everyone will tinker like last time and make use of it.
     
  9. Psi-hate

    Psi-hate GBATemp's Official Psi-Hater

    Member
    1,666
    1,060
    Dec 14, 2014
    United States
    Houston
    am:init() is the service call for Application Manager. AM deals with installing Cias. gspwn in 9.3 was patched, and gspwn was used to get those service calls. If you look in the HBmenu on Smealum's github, you can see that he recently added am:init() in there, hinting that he found a new exploit to gain said calls. If we find out how to use said exploit, we would be able to run a cia installer and install the 9.2 cias over sysnand. Obviously if said theory is true, then we can downgrade, but it is risky and people with hardmods would have to test it out a bunch to make sure it works.
     
    leerpsp likes this.
  10. Wizardkoer
    OP

    Wizardkoer Wii Veteran

    Member
    429
    82
    Jul 14, 2015
    Australia
    So if this exploit is released, we will be able to use a 9.2 .cia to downgrade our 3ds. So then we can install the gateway ultra to downgrade to 4.5 and install emunand and we would have kernel access?
     
  11. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,124
    3,422
    Nov 13, 2014
    United States
    Yes but that's a long stretch and also there is no longer any benefit to downgrade to 4.5 as of now 9.2 is the sweet spot for compatability.
     
  12. Psi-hate

    Psi-hate GBATemp's Official Psi-Hater

    Member
    1,666
    1,060
    Dec 14, 2014
    United States
    Houston
    Pretty much. I'm sure there's more to it but basically we just need to find a way to call am services and this little mystery about am:init() is giving us something to hope for.
     
  13. Nintendo Fanboy

    Nintendo Fanboy GBAtemp Maniac

    Member
    1,031
    399
    Mar 6, 2015
    United States
    In Los Santos, GTA: San Andreas.
    It could be possible, if someone manages to find another explot. But not anytime soon.
     
  14. del_delly

    del_delly GBAtemp Regular

    Member
    136
    15
    Sep 21, 2013
    Norway
    There isn't really any point to that.
    What we need is that the hack allows a full system breach, so we can install a proper Custom Firmware, to avoid having to start a application to run Homebrew.
    That said, most of the homebrew devs are butthurt over the fact Custom Firmware will mean the core priority is loading ESHOP games, normal games, and a live injector to the emulators. And emulators is a priority after that.

    The butthurt stems from the fact, we know from earlier homebrew scenes(Wii, PSP) that once Piracy is working properly, the demo apps people make will be ignored, because their quality is questionable(most of them). And whoever is making homebrew games is eiter over their head(writing custom engine), has no understanding of deving(no content creation tools, just convertors and .txt files), gets no recruitment due rare skills, bad at making progress, feature hell, or any other reason.
     
  15. Nintendo Fanboy

    Nintendo Fanboy GBAtemp Maniac

    Member
    1,031
    399
    Mar 6, 2015
    United States
    In Los Santos, GTA: San Andreas.
    I think you CAN downgrade your system from the latest firmware, buuuut that requires a hardmod...
     
  16. Psi-hate

    Psi-hate GBATemp's Official Psi-Hater

    Member
    1,666
    1,060
    Dec 14, 2014
    United States
    Houston
    Read my posts and all will be explained, yo
     
    Nintendo Fanboy likes this.
  17. Intronaut

    Intronaut An star maker

    Member
    726
    434
    Nov 18, 2014
    Cote d'Ivoire
    AFAIK You can't downgrade NATIVE_FIRM. It seems Gateway, with the downgrading feature, injects pre-load firm0.bin and firm1.bin files.

    And there is a lot of different kinds of AM services. For CIA installation we need AM:NET, and according to @motezazer, only NIM has access to it :(
     
  18. Psi-hate

    Psi-hate GBATemp's Official Psi-Hater

    Member
    1,666
    1,060
    Dec 14, 2014
    United States
    Houston
    Ah, you're right. If there's no way around that, then a kernel exploit is needed.
     
  19. Intronaut

    Intronaut An star maker

    Member
    726
    434
    Nov 18, 2014
    Cote d'Ivoire
    Yeah, it's sad, but maybe someone can find a workaround :)
     
  20. leerpsp

    leerpsp GBAtemp Maniac

    Member
    1,022
    229
    Feb 22, 2014
    United States
    I don't have a hard mod but I can do one and i got a 9.2 backup from gateway and a 4.5 back up as well so I will test it out if my 3ds bricks i will hard mod.