Is it Gateway or emuNAND that breaks DS Mode in emuNAND?

Discussion in '3DS - Flashcards & Custom Firmwares' started by TidusWulf, May 20, 2015.

  1. TidusWulf
    OP

    TidusWulf Real Aloha

    Member
    600
    233
    Jul 27, 2007
    United States
    Hawaii
    I mean, if I entered emuNAND with something like rxTools (or even Gateway classic mode), can I still run a DS game? I don't have any DS games to try out (I only have a blocked flashcard) but I'm wondering about what's really happening when people keep saying "Gateway doesn't work with DS Mode" because that doesn't really specify where the problem is happening.

    Has anyone tried launching a DS Game using rxTools or classic mode emuNAND, or some other method that doesn't involve a Gateway cartridge?
     
  2. Lucifer666

    Lucifer666 all the world needs is me

    Member
    1,495
    732
    Apr 22, 2011
    The Fourth Dimension
    It doesn't work, it'll just crash

    Because of Gateway's reliance on the MSET exploit back in the 4.X days, which launching DS mode resets

    I don't know about rxtools though. It's a good question
     
  3. thorasgar

    thorasgar Checkout my evil Soon-in-atorâ„¢

    Member
    3,405
    1,844
    Jul 3, 2010
    United States
    Margen67 likes this.
  4. Apache Thunder

    Apache Thunder I have cameras in your head!

    Member
    4,112
    4,063
    Oct 7, 2007
    United States
    Levelland, Texas
    DS/DSi stuff doesn't work with Gateway because of some of the things they patch out in NATIVE_FIRM when Gateway/Classic mode is booted. It's not quite emunand alone that is the reason otherwise you'd be able to boot that stuff if you booted Gateway without emunand. DSiWare (and by extension DS carts as well) work with PastaCFW from what I've heard, so it's really a matter of something silly Gateway has done that prevents it from working. It's not really related to MSET. People just assumed it was back in the day when that was the only entry point. Today even with the web browser entry point, TWL_FIRM/AGB_FIRM stuff won't boot in Gateway mode even if booted without emunand.

    I recall hearing from someone why exactly this is the case but I have long forgotten. So I wouldn't be the one to give you the technical details on that. :P
     
    Margen67 likes this.
  5. Margen67

    Margen67 Dirty entited pirate

    Banned
    1,100
    4,589
    Nov 3, 2014
    United States
    Isn't it because the FIRMs aren't redirected?
     
  6. Duo8

    Duo8 I don't like video games

    Member
    3,444
    1,144
    Jul 16, 2013
    IIRC GW mode breaks firm relaunch or something making DS/i/GBA mode not work.
     
    Margen67 likes this.