Is it dangerous to update my Wii now?

Discussion in 'Wii - Console and Game Discussions' started by cooleothman, Mar 15, 2009.

  1. cooleothman
    OP

    cooleothman Member

    Newcomer
    25
    0
    Dec 7, 2008
    Netherlands
    Hello guys, [​IMG]

    I've got a 3.1E firmware with CIOS and Wii Shop Installer[IOS50] installed.

    I want to update it to 3.4E. [​IMG]

    My question is;

    Will it damage my Wii or something else? [​IMG]
     
  2. paul3100

    paul3100 GBAtemp Advanced Fan

    Member
    510
    1
    Oct 15, 2007
    scotland
    It won't damage your wii but you will need to install a couple things again!

    Also from what iv read the best update to go to is 3.2 as its the best for softmodded wii's because the next update after that causes some homebrew/apps whatever to stop working!

    Anyone else?

    paul
     
  3. Draganta

    Draganta Member

    Newcomer
    44
    0
    Apr 5, 2007
    Gambia, The
    Germany
    if you don´t have anything else installed, it won´t damage your wii.

    i´m on 3.3v1 and i don´t think there are homebrew apps that stopped working, but 3.3v2 stops some things and 3.4 some other things from working.
     
  4. timishu

    timishu GBAtemp Regular

    Member
    286
    0
    Jan 26, 2009
    United States
    Scatland
    For whatever reason you want to update your Wii, I would reconsider it because after updating to 3.4 it will be kind of a pain to downgrade back down to 3.2. Keep in mind that hardly any Homebrew will work on 3.4.
     
  5. isaac52

    isaac52 GBAtemp Regular

    Member
    277
    37
    Sep 22, 2008
    United States
    MD, USA
    Why do you need 3.4?
    There are no real advantages to doing so, only disadvantages, and dangers.
    3.2E is best for you.
     
  6. TheGreatNeko

    TheGreatNeko GBAtemp Regular

    Member
    105
    2
    Jan 11, 2009
    United States
    Exactly there's really no reason to update now, so I wouldn't do it.
     
  7. elfsander

    elfsander GBAtemp Fan

    Member
    463
    0
    Jun 1, 2007
    Netherlands
    Netherlands
    I have 3.4 and I am fully able to use the HBC, play DVDs, load emulators, watch video, play homebrew games...

    I'm, however, not able to load backup copies, but I really don't care since I don't WANT to. Real homebrew works 100% fine with 3.4.

    Pirate-shit (sorry) doesn't.