Is it advisable to stay on 1.00 FW ??

Discussion in 'Switch - Hacking & Homebrew' started by alepman90, Mar 14, 2017.

  1. alepman90
    OP

    alepman90 GBAtemp Regular

    Member
    178
    89
    Oct 10, 2014
    Like anyone i love me some capable handheld to play emulators and other advantages done
    through CFW,I got mine today and it seems on 1.00 there's a 2.00fw is out day one (and another one coming later this month).should i update or stay on the original fw?
     


  2. CitizenSnips

    CitizenSnips a seldom-used crab named Lucky

    Member
    613
    526
    Mar 10, 2015
    United States
    I mean, its always good to stay on the lowest version possible, but i don't think any potential exploits have been patched yet. You never know though, so its totally up to you
     
  3. Soluble

    Soluble Member

    Newcomer
    14
    1
    Mar 12, 2017
    1.0 cant connect to a network. Given everything done so far requires the hidden web browser... upgrade to 2.0. You can then access the eshop and buy snipperclips ;)
     
  4. alepman90
    OP

    alepman90 GBAtemp Regular

    Member
    178
    89
    Oct 10, 2014
    Man i'm in decision buying another one sell the accessories for 140 on ebay and keep the Tablet just for this cause
     
  5. Lilith Valentine

    Lilith Valentine GBATemp's Wolfdog™ I drool on my knife

    Member
    19,349
    19,665
    Sep 13, 2009
    Antarctica
    Between insane and insecure
    Not really, you spent money on that system and should actually try enjoying it instead of just having it sit around waiting for more hacks.
     
  6. alepman90
    OP

    alepman90 GBAtemp Regular

    Member
    178
    89
    Oct 10, 2014
    Pretty sure there's more stuff is coming from the hacking within this year,and so far other than BOTW,Mario odyssey(which at the end of this year) there are not a lot of worthy titles
     
  7. Shining Greninja

    Shining Greninja GBAtemp Regular

    Member
    271
    124
    Feb 9, 2015
    United States
    In the shadows
    I mean you probably can update since Ninty wouldn't know what to patch
     
  8. Lilith Valentine

    Lilith Valentine GBATemp's Wolfdog™ I drool on my knife

    Member
    19,349
    19,665
    Sep 13, 2009
    Antarctica
    Between insane and insecure
    And I highly doubt they will release an exploit if it only works on 1.0. Most of the time when an exploit is found, they actually attempt to find it on the most recent OFW. If there was an exploit found on 1.0, chances are this early in the game, it will still on 2.0 or until Nintendo finds it first (which is often a shot in the dark.)
    Basically you are wasting your time, time that could be spent actually enjoying your system :P
     
    Last edited by Lilith Valentine, Mar 14, 2017
  9. alepman90
    OP

    alepman90 GBAtemp Regular

    Member
    178
    89
    Oct 10, 2014
    Remember the 3.5FW to be able to hack 3ds,and how difficult it was to obtain an old firmware(even though the 3DS sold millions by that time and more easier to find)?
    it took the hacking community couple years to be able to downgrade
     
    Last edited by alepman90, Mar 14, 2017
  10. Lilith Valentine

    Lilith Valentine GBATemp's Wolfdog™ I drool on my knife

    Member
    19,349
    19,665
    Sep 13, 2009
    Antarctica
    Between insane and insecure
    Now picture you sitting on your system waiting potentially years for an actual exploit to be found. While the rest of world enjoys the soon to be greatest game ever, Splatoon 2.
     
    jpx86, souler92, Zacchi4k and 7 others like this.
  11. McWhiters9511

    McWhiters9511 That's Rad Bro

    Member
    1,144
    567
    Mar 28, 2016
    United States
    Space
    do the first update. any exploits will require it anyways
     
  12. alepman90
    OP

    alepman90 GBAtemp Regular

    Member
    178
    89
    Oct 10, 2014
    I'm thinking of buying another one then selling the accessories and keep the tablet (it'll costs me roughly 180-160)worth the investment imo,
    and like all Nintendo products if it's not that promising i can always sell it for min to non loss (hell i sold my 3DS with old FW for 400 back in 2013)
     
    eskinner3742 likes this.
  13. Jao Chu

    Jao Chu GBAtemp Advanced Maniac

    Member
    1,917
    1,210
    Aug 20, 2013
    straya m8
    In this day and age of console security, its always better to never update. And it will stay that way for the next 200 years. No need to start these threads for every new console/handheld that is launched :)
     
  14. alepman90
    OP

    alepman90 GBAtemp Regular

    Member
    178
    89
    Oct 10, 2014
    I have Switch in my hands atm,and i'm no way a hack savvy i can tell this system is rushed on March for many purposes (to please Nintendo's shareholders mainly)
    the OS is seriously flawed,i woke the other day to find mine overheated after shutting it off at night and turned by it self in the pouch....the next update to fix the wifi (which is even worse than 3ds)
     
  15. Jao Chu

    Jao Chu GBAtemp Advanced Maniac

    Member
    1,917
    1,210
    Aug 20, 2013
    straya m8
    It's nice to see a nintendo-fan critiquing their Switch console objectively for a change!

    I don't own one yet, but enjoy your your purchase :)
     
  16. Bladexdsl

    Bladexdsl ZOMG my posts...it's over 9000!!!

    Member
    15,980
    3,673
    Nov 17, 2008
    Australia
    Queensland
    upgrade to 2.0 than
    [​IMG]
     
    eskinner3742 and alepman90 like this.
  17. squall14716

    squall14716 GBAtemp Maniac

    Member
    1,080
    596
    May 16, 2011
    United States
    Didn't 2.0 add the support for captive portals that is currently used to exploit the browser?
     
    alepman90 likes this.
  18. kingraa777

    kingraa777 boom!

    Member
    1,034
    265
    Apr 17, 2015
    yes 2.0 did
     
  19. 2Hack

    2Hack HYPiavelli

    Member
    2,158
    4,872
    Nov 26, 2014
    Canada
    Underground
    When that happened, there was a warning by gateway. They gave everybody a chance to either stay on 3.5 or forget the exploit and move on. Those that couldn't wait, felt the pain. This happened even with Gateway ultra and the 9.2 exploit.

    If there is any hack, the devs would usually issue a warning saying to stay on a specific fw. We don't have that warning.

    If you look at the wiiU hacking scene, same thing happened; they were all warned to stay on 5.3.2. Some did, some didn't. So those with 5.3.2 had their patience rewarded sooner than those that couldn't wait.

    There isn't much reason to stay on such a low fw right now
     
  20. padder123

    padder123 Member

    Newcomer
    16
    1
    Jan 21, 2017
    United States
    I was wondering if anyone knows if the upgrade process to 2.0 is something you could do, after 2.1 is released and 2.0 is removed from eshop/upgrade servers.

    Put it another way, does the switch use ssl pinning, to stop you fake hosting the upgrade content?
    And/or
    Does the upgrade require a unique per device signed keyfile (ticket) to boot it, this can be ruled out if only CDN servers are used during the upgrade.