IOS60 questions

Discussion in 'Wii - Hacking' started by sfjuocekr, Jun 25, 2009.

Jun 25, 2009

IOS60 questions by sfjuocekr at 8:33 AM (1,617 Views / 0 Likes) 4 replies

  1. sfjuocekr
    OP

    Newcomer sfjuocekr Advanced Member

    Joined:
    Jun 23, 2009
    Messages:
    64
    Country:
    Netherlands
    Im looking for some clarification about IOS60.


    There is a wad going around "IOS60Patched.wad" and there are numerous IOS60 and IOS61 installers using PatchMii.


    What exactly does the IOS60Patched.wad fix? Is it truncha patched?
    Do the IOS60/61 installers using PatchMii install a truncha patched version?
    Is the IOS60 from IOS60Patched.wad the same as when installed with an installer or do they have the same result?

    Also Preloader patches IOS60, but this is simply to make Preloader able of booting System Menu and not truncha patching it?


    I know that the patched version and from the installers should allow VC/WiiWare to be ran from SD, but I don't have these issues on my Wii ... :s


    In short: what is the deal about IOS60?
     
  2. Jacobeian

    Member Jacobeian GBAtemp Advanced Maniac

    Joined:
    May 15, 2008
    Messages:
    1,879
    Country:
    Cuba
    It re-enables the "Trucha Bug" in IOS60. Afaik, the patch used is the same in ALL patcher, it's the one released in Patchmii. Preloader do also the same patch so be careful if you install Preloader with an already patched IOS60, I don't think those patchers are very safely designed...

    IOS60 being the IOS used by Sytem Menu 4.0, this basically let you launch fakesigned channels from the new SDCARD menu (which obviously check the signature of installed channels before copying or launching them). Wthout this, it's impossible to ran fakesigned stuff from SD.

    IOS61 patcher is useless in my opinion since this IOS is only used by the Shop Channel (why would you require the trucha bug for that ???)
    It can also be used by HBC launched applications but most applications requiring the Trucha Bug generally reload a "patched" or "custom" IOS for that so this is absolutely not required to patch "all " IOS.
     
  3. sfjuocekr
    OP

    Newcomer sfjuocekr Advanced Member

    Joined:
    Jun 23, 2009
    Messages:
    64
    Country:
    Netherlands
    That also explains to me why my stuff from SD runs normally, they are simply not truncha patched.


    Woudln't all the truncha patching be useless (for someone that just wants SoftChip and NeoGamma) if you just install cIOS rev13b? Or do they need the truncha bug too to load pirated *cough* backup games?
     
  4. Scarfish

    Member Scarfish GBAtemp Regular

    Joined:
    Jan 5, 2009
    Messages:
    101
    Country:
    Netherlands
    The patch Preloader applies is NOT the trucha bug patch. It's an ES_Identify patch.
    You don't need a trucha patched IOS to use SoftChip and NeoGamma but you need a cIOS like you said.
     
  5. sfjuocekr
    OP

    Newcomer sfjuocekr Advanced Member

    Joined:
    Jun 23, 2009
    Messages:
    64
    Country:
    Netherlands
    I figured this out alreayd, thanks anyway [​IMG]


    This way using NeoGamma and SoftChip on a LU64+ is pretty straight forward.
     

Share This Page