IOS 58 deleted, homebrew channel crashes

Discussion in 'Wii - Hacking' started by Armar, Dec 21, 2010.

Dec 21, 2010
  1. Armar
    OP

    Newcomer Armar Newbie

    Joined:
    Dec 21, 2010
    Messages:
    6
    Country:
    Belgium
    I had a similar problem to this guy: http://gbatemp.net/t245287-ios-58-installa...iled?&st=15
    The WiiMC channel installer wouldn't work because of the IOS 58 that came with Darkcorp
    So I used AnyTitle Deleter to get rid of that IOS and had the installer for the official one ready but my homebrew channel crashes to a black screen [​IMG]
    I hope I don't have to update my wii and reinstall everything
     
  2. XFlak

    Member XFlak Wiitired but still kicking

    Joined:
    Sep 12, 2009
    Messages:
    9,122
    Location:
    Ontario
    Country:
    Canada
    download ModMii (see my signature), from the main menu, enter "H" to begin the hackmii solutions process, then just follow the guide.

    basically it will get u to use an exploit to launch MMM, then to use its wad manager to install a clean IOS58, then reinstall the HBC (u probably wont need to reinstall the HBC, since its already installed to use IOS58)
     
  3. Armar
    OP

    Newcomer Armar Newbie

    Joined:
    Dec 21, 2010
    Messages:
    6
    Country:
    Belgium
    Will try, thanks for the fast reply !
    Awesome program you made btw [​IMG]

    EDIT: So far a succes, at first the homebrew channel was flipped upside down (WTF xD) but I reinstalled that and now that's working again.
    Now for the WiiMC channel
     
  4. Armar
    OP

    Newcomer Armar Newbie

    Joined:
    Dec 21, 2010
    Messages:
    6
    Country:
    Belgium
    FAIL [​IMG]
    WiiMC still sais it's missing IOS 58 but it is showing up in MMM
    Maybe the wrong version...?
     
  5. XFlak

    Member XFlak Wiitired but still kicking

    Joined:
    Sep 12, 2009
    Messages:
    9,122
    Location:
    Ontario
    Country:
    Canada
    The only IOS58 ModMii downloads is the correct version... r u sure u installed it successfully?

    When exactly are u getting the error? Are u launching WiiMC from the HBC or from a forwarder channel? Or are u launching the WiiMC Channel Installer from the HBC?
     
  6. Armar
    OP

    Newcomer Armar Newbie

    Joined:
    Dec 21, 2010
    Messages:
    6
    Country:
    Belgium
    MMM and Anytitle deleter both show that IOS58 is installed it was v6176
    And I'm trying to launch the WiiMC Channel Installer from the HBC, WiiMC itself works but I can't get the channel to install.
     
  7. XFlak

    Member XFlak Wiitired but still kicking

    Joined:
    Sep 12, 2009
    Messages:
    9,122
    Location:
    Ontario
    Country:
    Canada
    it sounds like it's either the HBC init. bug causing apps with "no_ios_reload" in the meta.xml to fail when no internet connection is set up... or, it's a bug in the installer, I remember reading about ppl having problems getting the installer to work

    try installing my WiiMC forwarder channel, its looks exactly the same as the official WiiMC channel, the forwarder dol has some subtle differences, but my version is in wad form, so u can install it using a wad manager

    http://gbatemp.net/t205622-x-flak-s-top-wii-channels

    edit: if u can get WiiMC to launch properly from the HBC, then I doubt its the HBC init bug.
     
  8. Armar
    OP

    Newcomer Armar Newbie

    Joined:
    Dec 21, 2010
    Messages:
    6
    Country:
    Belgium
    Ok I got it to work with your WAD [​IMG]
    But when after starting WiiMC from the channel it gives me a warning that I didn't get before.
    The error preppy much sais I have a modified IOS and that might affect performance.
    It doesn't say what IOS :s and it comes back every time (I could ignore it otherwise [​IMG] )
    Thanks for your great help so far [​IMG]
     
  9. XFlak

    Member XFlak Wiitired but still kicking

    Joined:
    Sep 12, 2009
    Messages:
    9,122
    Location:
    Ontario
    Country:
    Canada
    weird problem to have considering u installed a non-fakesigned IOS58... I think darkcorp is somehow affecting it. I recommend using ModMii to download and install all active IOSs. You can do this by using the ModMii wizard... if u just want active IOSs and nothing else, tell it that it is not a virgin and say no to all the other downloads (alternatively u can just download all the active IOSs from download page 1), if u want to rehack your Wii and update all your softmods, tell the ModMii Wizard that your Wii is a virgin.

    I personally tested my WiiMC forwarder out on my Wii yesterday, running off of a clean IOS58 and using the latest WiiMC. I was even able to load a dvd, proving that the forwarder provides direct hardware access. The only difference between our set ups are our other IOSs (u likely still have a bunch installed from DarkCorp)... but those IOSs shouldn't be accessed... so like I said, it's a weird problem to have... I mean, it's possible Tantric added a check so that WiiMC will give ppl a warning if it detects any corped IOS on your Wii... but that would be weird.
     
  10. Armar
    OP

    Newcomer Armar Newbie

    Joined:
    Dec 21, 2010
    Messages:
    6
    Country:
    Belgium
    I'll do that tomorrow, it's getting late (I live in europe)
    Darkcorp was helpfull at first but new games and homebrew have problems with my pretty old install of it [​IMG]
    Thanks [​IMG]
     
  11. fattest

    Member fattest GBAtemp Fan

    Joined:
    Aug 8, 2009
    Messages:
    308
    Country:
    United States
    download a clean ios58 using NUS downloader, (re)install it, then reinstall hbc
     
  12. XFlak

    Member XFlak Wiitired but still kicking

    Joined:
    Sep 12, 2009
    Messages:
    9,122
    Location:
    Ontario
    Country:
    Canada
    he did that already, except he used the cmd line nus downloader via ModMii
     

Share This Page