"Invalid Signature" when installing .cia files - 10.4 Downgrade

Discussion in '3DS - Homebrew Development and Emulators' started by luvas66, Mar 10, 2016.

  1. luvas66
    OP

    luvas66 Newbie

    Newcomer
    7
    0
    Mar 10, 2016
    Brazil
    Hi guys,

    im new in this forum, and have a question to do here.
    Yesterday I made the downgrade my old 3DS XL in firmware version 10.4 following the tutorial video below:



    Everything went without any error , I did everything in my Kingston micro SD card 32GB.
    After completing the tutorial , I downloaded several .cias files related to games, created a " Games" folder at the root of the card, and copied the files on it .
    When I started the 3DS , and accessed the FBI application to install the files , I entered the "Games " folder I had created , but had no file inside the same .
    I returned to the computer and open the folder , and the file .cia really was gone.
    After this fact , I tried to copy the .cia file in the root of the card, and started the 3DS again to see if I could find the file in the FBI application. This time I could find it, and start the installation, but literally all .cia files that I tried to install , the following error appears :

    Install failed!
    Super Street Fighter IV - 3D Edition (U)...
    Source: SOURCE_FSFILE_WRITE (0X1c)
    Module: MODULE_NN_AM (0x20)
    Level: LEVEL_PERMANENT (0X1B)
    Summary: SUMMARY_INVALID_ARGUMENT (0x7)
    Description: DESCRIPTION_INVALID_SIGNATURE (0x6a)

    Please guys, help me!
    If I need to format the SD card, how I can do the whole process again , to be able to install the .cia files again ?
    Excuse me , I 'm really new in all this.
    And sorry for my bad english.

    Thank you guys, in advance.
     


  2. MassExplosion213

    MassExplosion213 .

    Member
    1,409
    953
    Feb 15, 2015
    United States
    The signature is literally invalid. DG to 9.2 and use a CFW to patch signature checks.
     
  3. Joom

    Joom  ❤❤❤

    Member
    3,719
    2,490
    Jan 8, 2016
    United States
    You have to be running custom firmware before you can install CIAs. Check the tutorial section.
     
  4. Townsperson

    Townsperson GBAtemp Fan

    Member
    398
    272
    Dec 7, 2015
    United States
    So, you successfully downgraded to 9.2, correct? If so, you need to use a CFW to patch out signature checks. Check out one of the CFW threads (ReiNand, Cakes, RxTools, etc.).
     
  5. luvas66
    OP

    luvas66 Newbie

    Newcomer
    7
    0
    Mar 10, 2016
    Brazil
    I 'm running CFW through RxTools , according to the video I posted . It automatically starts as I turn on my 3DS , displaying the " FBI" menu to access the files .cia . This is not the CFW ?

    — Posts automatically merged - Please don't double post! —

    I have performed the downgrade to 9.2 , and I'm already running CFW through RxTools that starts automatically when I turn on my 3DS , as is being done at the end of the video.
     
  6. Joom

    Joom  ❤❤❤

    Member
    3,719
    2,490
    Jan 8, 2016
    United States
    Then the CIA you're trying to install may be corrupt.
     
  7. MassExplosion213

    MassExplosion213 .

    Member
    1,409
    953
    Feb 15, 2015
    United States
    That or an incomplete downgrade.
     
  8. luvas66
    OP

    luvas66 Newbie

    Newcomer
    7
    0
    Mar 10, 2016
    Brazil
    I think this is not possible as well , because I've tried 3 different files, and all give the same type of error when I try to install them.

    — Posts automatically merged - Please don't double post! —

    What is the correct procedure I have to follow after format my SD card with the 3DS already downgrade in version 9.2 ?
     
  9. Bros.Life

    Bros.Life GBAtemp Regular

    Member
    181
    20
    Apr 12, 2015
    United States
    Setup a emunand. After that you install a CFW.
     
  10. luvas66
    OP

    luvas66 Newbie

    Newcomer
    7
    0
    Mar 10, 2016
    Brazil
    Anyone else? :(
     
  11. LarBob

    LarBob GBAtemp Fan

    Member
    344
    157
    Dec 29, 2013
    United States
    You need to install a custom firmware to bypass signature checks, such as AuReiNand or rxTools.
     
  12. luvas66
    OP

    luvas66 Newbie

    Newcomer
    7
    0
    Mar 10, 2016
    Brazil
    But I use a custom firmware on my 3DS , the RxTools , which starts automatically when I turn on the 3DS . After the initialization of this custom firware through RxTools , the FBI menu appears on my console menu.
     
  13. DrCrygor07

    DrCrygor07 Italian Wario Ware bootleg©

    Member
    1,682
    621
    Sep 4, 2014
    Italy
    FBI IS NOT A CFW!
     
  14. jefffisher

    jefffisher GBAtemp Maniac

    Member
    1,349
    211
    Dec 17, 2006
    United States
    it sounds almost as if you're just autobooting fbi through menuhax?
     
  15. luvas66
    OP

    luvas66 Newbie

    Newcomer
    7
    0
    Mar 10, 2016
    Brazil
    Does anyone have any good tutorial for me to perform the installation of a good CFW from my 3DS in version 9.2 ? Something like this video that I posted.
    I would like to follow step by step to give nothing wrong. Sorry for the ignorance but I am new in this.
     
  16. simbin

    simbin GBAtemp Regular

    Member
    185
    17
    Jul 28, 2015
    United States
    I'm having the same problem, in addition to some other issues. I'm starting to suspect 10.6 downgrade.

    Anyway, I'm on ReiNand emuNand 9.2.

    FBI was injected to Health & Safety

    I used it to install FBI.cia

    Installing Legit CIA of Fire Emblem I had gave same error as Op.
     
  17. TheLegendaryJame

    TheLegendaryJame Member

    Newcomer
    29
    2
    May 15, 2010
    United States
  18. simbin

    simbin GBAtemp Regular

    Member
    185
    17
    Jul 28, 2015
    United States
    Thank you I was just looking for that

    — Posts automatically merged - Please don't double post! —

    Here's my log:

    Title ID 0x0004009b00010602
    Expected version 0x0002
    Installed version 0x0400
    Title ID 0x0004003000009e02
    Extra title
    Title ID 0x0004013000001b02
    Expected version 0x0800
    Installed version 0x0c01
    Title ID 0x0004013000001a02
    Expected version 0x1400
    Installed version 0x1801
     
  19. MlgPro

    MlgPro Yeah... I dont even know why YOU stopped by

    Member
    216
    64
    Mar 10, 2016
    United States
    EARTH
    Did you go to system setting to check the system info it should says something like RX-9.2-0.20U

    — Posts automatically merged - Please don't double post! —

    — Posts automatically merged - Please don't double post! —

    It should look like this 9.jpg

    — Posts automatically merged - Please don't double post! —

    Oh and how come you didn't wait for the release of the soft mod it came out two days ago and it works.
     
  20. simbin

    simbin GBAtemp Regular

    Member
    185
    17
    Jul 28, 2015
    United States
    Yes but it's Rei

    I also just tried Cakes with signature checking off and RedNand boot (same issue)

    Also, I think these titles are just leftovers from newer than 9.2 firmware?

    Title ID 0x0004009b00010602
    Expected version 0x0002
    Installed version 0x0400
    Title ID 0x0004003000009e02
    Extra title
    Title ID 0x0004013000001b02
    Expected version 0x0800
    Installed version 0x0c01
    Title ID 0x0004013000001a02
    Expected version 0x1400
    Installed version 0x1801

    — Posts automatically merged - Please don't double post! —

    I had no idea... Do you mean arm9loaderhax? I was planning on doing that next.
     
    Last edited by simbin, Mar 11, 2016