Internal modchip - SAMD21 (Trinket M0, Gemma M0, ItsyBitsy M0 Express) Guide, Files & Support

Discussion in 'Switch - Tutorials' started by mattytrog, Jun 20, 2018.

  1. darkovo

    darkovo Member

    Newcomer
    3
    Aug 5, 2006
    Nothing, I'll check those solder points. Thanks again for your help.
     
  2. mattytrog
    OP

    mattytrog You don`t want to listen to anything I say.

    Member
    12
    Apr 27, 2018
    United Kingdom
    No worries. Let us know how u get on.
     
    darkovo likes this.
  3. khpda

    khpda Member

    Newcomer
    3
    Jul 2, 2015
    United States
    I don’t have heat gun, so this only option i have (method 1).
     

    Attached Files:

  4. mattytrog
    OP

    mattytrog You don`t want to listen to anything I say.

    Member
    12
    Apr 27, 2018
    United Kingdom
    Fair enough!

    Though you will have a bulge in back case, possibly holding down reset button. If this is a problem, you can cut the shield with scissors and mount on top of the RAM shielding.
     
  5. khpda

    khpda Member

    Newcomer
    3
    Jul 2, 2015
    United States
    It not hold down reset, yet i still can click it by push down back.


    Sent from my iPhone using Tapatalk
     
  6. mattytrog
    OP

    mattytrog You don`t want to listen to anything I say.

    Member
    12
    Apr 27, 2018
    United Kingdom
    Good good. As long as its working for you mate! Well done. :)
     
  7. khpda

    khpda Member

    Newcomer
    3
    Jul 2, 2015
    United States
    I may cut shield on top of RAM shield as you mentioned, thz u.


    Sent from my iPhone using Tapatalk
     
    mattytrog likes this.
  8. kuze

    kuze Member

    Newcomer
    2
    Jul 16, 2018
    United States
    You can't boot into normal switch OS with software auto RCM already enabled.

    With the SwitchMe installed I wasn't able to interface RCM or the SwitchMe to flash it, so no way to boot into Horizon.

    Only fix I thought of was disconnecting SwitchMe from USB bus, booting into Horizon, then soldering the D+ and D- wires back with the system booted. This worked and I was able to flash the SwitchMe successfully then.

    It doesn't say anywhere in the guide to disable software auto RCM before proceeding with the install, but maybe that should be noted if you don't plan to flash the SwitchMe first?

    If I was to do it again I'd just flash the SwitchMe before doing the install.
     
  9. mattytrog
    OP

    mattytrog You don`t want to listen to anything I say.

    Member
    12
    Apr 27, 2018
    United Kingdom
    Yes you can. Use TegraRCMsmash.Send any payload that will get you booted into switch os Horizon.
     
  10. kuze

    kuze Member

    Newcomer
    2
    Jul 16, 2018
    United States
    I tried that, it didn't detect RCM mode. Windows also complained that the device was acting faulty and didn't know what to do with it.

    Anyhow, just my experience. /shrug
     
  11. StevenMattera

    StevenMattera GBAtemp Regular

    Member
    4
    May 6, 2018
    United States
    Durham, NC
    This is happening to me too. My SwitchMe is just flashing red. I've disconnected it completely from the switch and just have a USB cable hooked up. (Red - 5v) (Black - Gnd) (Green - D+) (White - D-) I'm still not seeing anything on my computer and Arduino IDE isn't seeing it either.
     
  12. kuze

    kuze Member

    Newcomer
    2
    Jul 16, 2018
    United States
    Sounds like a different issue if you disconnected it completely from the Switch and your PC still isn't seeing it.

    It is normal for the SwitchMe to continuously flash red until it has been flashed the first time so that's not a problem.
     
  13. darkovo

    darkovo Member

    Newcomer
    3
    Aug 5, 2006
    Whoop Whoop! It's working, resoldered D- & D+ on Switchme and still same issue, then resolder to the Switch D- & D+ points and Windows detects the USB drive.
    Data LED changed to pulsing red.

    Thanks again mattytrog :)
     
    mattytrog likes this.
  14. StevenMattera

    StevenMattera GBAtemp Regular

    Member
    4
    May 6, 2018
    United States
    Durham, NC
    I figured it out. Shit soldering job. Bunch of pins on the micro controllers were shorting with each other. Simple drag of the soldering iron sorted it out.
     
  15. evilsperm

    evilsperm Advanced Member

    Newcomer
    3
    May 29, 2018
    United States
    Yeah I should have stated that if you already have auto RCM it should have been turned off for first boot with SwitchME.
    Or just pre flash the SwitchME by soldering on a usb cable to 5v D+ D- Gnd and just plug it in and drop whatever uf2 you like on it.
    Also your emmc wasn't glued down (its only double sided taped to the shield), you could have just lifted it from the front by the clip and popped the shield up with it.
    It comes off super easy.
     
    Last edited by evilsperm, Sep 21, 2018
    kuze and ModderFokker619 like this.
  16. reapers_ed1t1on

    reapers_ed1t1on Newbie

    Newcomer
    1
    Apr 30, 2018
    Australia
    is there anybody in australia selling the rebug switchme boards
     
  17. evilsperm

    evilsperm Advanced Member

    Newcomer
    3
    May 29, 2018
    United States
    I sent a few big orders there, so there might be.
    But from what I have seen the big orders aren't even reselling them. They are using them for installs only ;(
     
  18. mattytrog
    OP

    mattytrog You don`t want to listen to anything I say.

    Member
    12
    Apr 27, 2018
    United Kingdom
    Should I shaft them by offering a free install service?
     
    evilsperm and reapers_ed1t1on like this.
  19. kuze

    kuze Member

    Newcomer
    2
    Jul 16, 2018
    United States
    Thanks for the confirmation. B-)

    Yeah I separated it from the rectangular shield, may have been double sided tape with a strong adhesive but it was like a glob of glue underneath the eMMC daughterboard when it came off.

    Didn't realize the shield would detach easily though.
     
  20. reapers_ed1t1on

    reapers_ed1t1on Newbie

    Newcomer
    1
    Apr 30, 2018
    Australia
    great looks like im out of luck cant even find one on ebay
     
Loading...