1. dzdncfsd

    dzdncfsd Member
    Newcomer

    Joined:
    Jul 8, 2016
    Messages:
    29
    Country:
    Australia
    This has happened again today. Both times the issue presented itself after I had the Switch charging for some period of time, though I can't say for sure that it has any relevance. Any suggestions what the problem might be? Is it possible this is some kind of software or power/battery issue where the Switch isn't thinking it needs to turn on the backlight?
     
  2. Maikaeli

    Maikaeli Newbie
    Newcomer

    Joined:
    May 29, 2020
    Messages:
    1
    Country:
    United States
    So I just attempted this mod and tried to do the original 3.3v connection, but bridged it with the point right above where you're supposed to solder (I've linked a picture of what I did). I freaked out, and tried to boot my switch after I noticed the bridge. It didn't turn on.

    Since I messed up, I decided "I already messed up this board, let's keep connecting" so I soldered up all the wires just in-case I come back to this switch and fix it one day. Well, after I soldered all 7 wires I wanted to use, and a new 3.3v point (I used the one under the eMMC module), I decided "hey lets try to turn on the system" and what do you know, it booted!

    The only problem that I'm getting is that once I turn on the console, it works, but if I turn it off and boot into RCM, it won't boot CFW/be recognized by a computer. I've tested for a couple hours and came to the conclusion that I've having the same problem as this:

    I can only turn on my Switch after being powered off after I disconnect the battery cable in the switch. Do I need to unbridge this connection? Is it safe to continue using my switch with this bridged? (I've ordered flux to help desolder the bridged connection already). Thanks for the help in advanced!
     

    Attached Files:

  3. dzdncfsd

    dzdncfsd Member
    Newcomer

    Joined:
    Jul 8, 2016
    Messages:
    29
    Country:
    Australia
    Potential differences with my setup are that:
    • I did six wires (I didn't attach the Vol+ strap)
    • I didn't even attempt the typical 3.3V connection to the tiny capacitor, I have connected it to the EMMC from the get go. For what it's worth, I'm convinced the 3.3V connection works because even with the switch off, if I press the Trinket's button through the back case, I see it light up.
    • My Switch is turning on, the screen's backlight is not though. I can see the menus etc if I shine a flashlight directly onto the screen, and I can hear the UI response sounds when moving the sticks or pressing buttons.
    The weird thing for me is that twice now it's behaved as I'd expect, and then 5-6 days later, the backlight no longer works. I'm planning to open the back again this weekend and disconnect the battery for a while to see if it comes back again. But, it'd be nice to know if there's anything else I can do to try and rectify this
     
    Maikaeli likes this.
  4. dzdncfsd

    dzdncfsd Member
    Newcomer

    Joined:
    Jul 8, 2016
    Messages:
    29
    Country:
    Australia
    Left the switch battery unplugged overnight, No luck getting the backlight lit. Spent some time today checking solder points. They all seemed okay but I re-did a few anyway. I also tested connections and it seems they are working. Still not getting the backlight back :(. One more thing I've noticed - when the Switch is on, and I can hear the UI sounds generally with the volume turned up, I don't hear a disconnect or connect sound play with the right joy-con, like I do with the left. The right joy con does work though, both connected and wirelessly. Is that expected?

    Any other suggestions as to what I might do to try and fix this? (thanks if you are around @mattytrog or @pyorin for any suggestions).

    SOLVED! Thanks to a youtube video relating to a Switch with a backlight problem, I realised one of the two ribbon cables near the joy con strap is what gives the backlight power. I disconnected it and gave it a bit of a clean, and we're back in business!

    backlight.png
     
    Last edited by dzdncfsd, May 30, 2020
    pure3d2 and Maikaeli like this.
  5. Magic009

    Magic009 Member
    Newcomer

    Joined:
    Mar 1, 2019
    Messages:
    15
    Country:
    United States
    How can i install rcmloader into my switch? I have solderind station.
     

    Attached Files:

  6. Magic009

    Magic009 Member
    Newcomer

    Joined:
    Mar 1, 2019
    Messages:
    15
    Country:
    United States
    What you think guys?
    1-The blue give 0.12 in both (i think are D+ and D-).
    2-The black give 0.00 and 0.01(i think that is GND).
    3-The red give 3.31 (i think that is vdd).
     

    Attached Files:

    Last edited by Magic009, Jul 3, 2020
  7. Hayato213

    Hayato213 GBAtemp Guru
    Member

    Joined:
    Dec 26, 2015
    Messages:
    9,482
    Country:
    United States
    Use one of the chip on the list, like a trinket m0.
     
  8. Magic009

    Magic009 Member
    Newcomer

    Joined:
    Mar 1, 2019
    Messages:
    15
    Country:
    United States
    Yes, but, i think, this can run without problem, the sxpro dongle internal install.
     
    Last edited by Magic009, Jul 3, 2020
  9. Hayato213

    Hayato213 GBAtemp Guru
    Member

    Joined:
    Dec 26, 2015
    Messages:
    9,482
    Country:
    United States
    Except you don't have a pin layout that is the problem. We are not responsible if you bricked
     
  10. Magic009

    Magic009 Member
    Newcomer

    Joined:
    Mar 1, 2019
    Messages:
    15
    Country:
    United States
    I know, but sxpro dongle have pin layout?
     
  11. Hayato213

    Hayato213 GBAtemp Guru
    Member

    Joined:
    Dec 26, 2015
    Messages:
    9,482
    Country:
    United States
    Not on this thread this thread is specifically for the SAMD 21 Chipset. I know the SX OS dongle is doable but you need the correct pin layout, if you don't know, or can't source it. Use one of the chip from the opening post.
     
  12. Magic009

    Magic009 Member
    Newcomer

    Joined:
    Mar 1, 2019
    Messages:
    15
    Country:
    United States
    Where can i buy it?
     
  13. Hayato213

    Hayato213 GBAtemp Guru
    Member

    Joined:
    Dec 26, 2015
    Messages:
    9,482
    Country:
    United States
    You can get the trinket m0 on Amazon
     
  14. chronoss

    chronoss GBAtemp Addict
    Member

    Joined:
    May 26, 2015
    Messages:
    2,526
    Country:
    Congo, Republic of the
    Hi !

    Someone can tell me what'is the last file that i used with my Trinket ?
     
  15. Daddy_Daycare

    Daddy_Daycare Member
    Newcomer

    Joined:
    Jul 11, 2020
    Messages:
    16
    Country:
    United States
    Need a little help if possible. Long story short the solder pads for the joy on strap got pulled up on my switch. So now the right joy on is not connecting when in the joy on rail. It still work but only via blue tooth. This also means I can't enter rcm.
    Does anyone know another point on the board that I could use a jumper with that would solve my issue and get my joycon/rcm working again?
    Thanks

    — Posts automatically merged - Please don't double post! —

    Sorry it's the joycon strap pads. Phone autocorrected.
     
  16. HarmonyUnited

    HarmonyUnited Member
    Newcomer

    Joined:
    Mar 27, 2019
    Messages:
    12
    Country:
    United States
    Hello friends, I have just spent the better part of a day researching how to get my Trinket M0 hard-modded Switch to power back on after accidentally allowing it to discharge fully. I have tried leaving it charging over night in dock and just with official psu direct. I have tried all manner of button combinations on start up. This is all happening after many many months of smooth trinket mo injecting :)e

    Here is the behavior: I left it emulating mario 64 and put into standby, next day realized battery died. Plugged in over night... next day i go to turn on, hold volume up and hit power, payload light on trinket blinks and goes green as in a successful injection but the screen does not light up or boot. The trinket mo will stay on as when i press vol button the red light shines. Sometimes i can get the backlight to flicker but nothing past that. No bootloader menu... I do have auto RCM enabled on the machine. Not sure if my issue is the same as all the others on the forums out there...

    Ive double checked wiring is all good... Any ideas would be so super appreciated!

    Thanks for any help! :)
     
  17. pure3d2

    pure3d2 Member
    Newcomer

    Joined:
    Dec 30, 2016
    Messages:
    43
    Country:
    United States
    Is it sitting in the dock or have the USB cable/charger plugged into the Switch? If so, take it out of the dock or unplug the USB cable from the Switch.

    If the Switch is fully off and you plug the USB cable/charger in, it will power up in RCM mode (black screen) and continue to be on there until the USB cable is unplugged.
     
  18. Daddy_Daycare

    Daddy_Daycare Member
    Newcomer

    Joined:
    Jul 11, 2020
    Messages:
    16
    Country:
    United States
    Gemma Install
    Stuck and could use some help

    I am doing a gemma install. When I turn it on it goes into rcm but the screen just stays black. The gemma flashes yellow a few times then red then there is a slight pause followed by 1 last red flash. There is nothing on the screen. Sx loader is on my sd named payload.bin

    Here is what I've done so far
    Connected gemma to PC. Pressed reset 2 times and then copied the 2 uf2 files from the link in the instructions.
    Then I connected all my straps using the guide. I have all of them connected vol +, joycon etc.
    I have checked my USB connections multiple times.
    I have no clue what I am missing.
    My 4 year old broke the USB c port on my switch by yanking out the cord. It still charges but I can't boot into cfw that way any longer so I was hoping this would allow me to get back into cfw.
    Thanks in advance.
     
  19. edwardsalazar97

    edwardsalazar97 Advanced Member
    Newcomer

    Joined:
    Jul 11, 2019
    Messages:
    60
    Country:
    Colombia
    first as a tip try atmosphere, second attach a high resolution image of your installation to see what we have
     
  20. Daddy_Daycare

    Daddy_Daycare Member
    Newcomer

    Joined:
    Jul 11, 2020
    Messages:
    16
    Country:
    United States
    Ok I will as soon as I get home
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - ItsyBitsy, Internal, (Trinket