1. Dolphin678

    Dolphin678 Member
    Newcomer

    Joined:
    Jan 3, 2020
    Messages:
    28
    Country:
    United States
    Okay, I don't have noclean flux, and I'm not exactly sure how to do all this, as I'm new to it. May I ask how much you would charge to fix it for me and install a trinket?
    EDIT: Or could you give more detailed instructions or tutorials for what you want me to do?
     
    Last edited by Dolphin678, Feb 29, 2020
  2. mattytrog

    OP mattytrog You don`t want to listen to anything I say.
    Member

    Joined:
    Apr 27, 2018
    Messages:
    3,708
    Country:
    United Kingdom
    Im in UK. Trying to wind down doing them to be honest.

    But can squeeze some more in. Send me a PM
     
  3. pyorin

    pyorin Advanced Member
    Newcomer

    Joined:
    Mar 13, 2013
    Messages:
    71
    Country:
    United States
    I'm in the US; I can take this one off your hands if you like matty :P
     
  4. mattytrog

    OP mattytrog You don`t want to listen to anything I say.
    Member

    Joined:
    Apr 27, 2018
    Messages:
    3,708
    Country:
    United Kingdom
    Feel free sir if you like! No complaints here.
     
  5. Dolphin678

    Dolphin678 Member
    Newcomer

    Joined:
    Jan 3, 2020
    Messages:
    28
    Country:
    United States
    While I wait, here's a better picture of the affected area in case anyone can figure out what happened
     

    Attached Files:

  6. mattytrog

    OP mattytrog You don`t want to listen to anything I say.
    Member

    Joined:
    Apr 27, 2018
    Messages:
    3,708
    Country:
    United Kingdom
    Without testing., it is just a guess based on that pic. Not ideal way to diagnose problems!

    Joints on pin 5 capacitor look dry to me. You need some flux.
     
  7. pyorin

    pyorin Advanced Member
    Newcomer

    Joined:
    Mar 13, 2013
    Messages:
    71
    Country:
    United States
    yeah, that area could do with some cleanup for sure. as far as flux goes, this is what I use for the liquid stuff; not this dude's cheapest listing but it is far and away his best value by volume. never hurts to have more flux :) a drop of that on the iffy solder joints, then briefly touch them with a cleaned iron tip, and repeat until the joints look smooth and are free of excess solder.
     
  8. Dolphin678

    Dolphin678 Member
    Newcomer

    Joined:
    Jan 3, 2020
    Messages:
    28
    Country:
    United States
    Thanks, I might try that if I can figure out what was causing the battery drain and no charging issue
     
  9. gamesquest1

    gamesquest1 Nabnut
    Moderator

    Joined:
    Sep 23, 2013
    Messages:
    14,983
    finally got around to installing a trinket m0, ordered them ages ago but never got around to it but ended up doing so for a friend as they were getting annoyed with the RCM setup steps, have to say this is a really cool setup, unfortunately I only just found out the other trinket I ordered seems to be dead, bit to late to return it now though so I can't do my own unless I buy another chip
     
  10. mattytrog

    OP mattytrog You don`t want to listen to anything I say.
    Member

    Joined:
    Apr 27, 2018
    Messages:
    3,708
    Country:
    United Kingdom
    Thankyou for the kind words!

    I recommend Fusee Suite for your chip if you haven`t flashed it already

    — Posts automatically merged - Please don't double post! —

    TK85 is a good flux as well. Cheap. Polish, so it fulfills my requirements for "The more poisonous something is, the better it is".
     
  11. gamesquest1

    gamesquest1 Nabnut
    Moderator

    Joined:
    Sep 23, 2013
    Messages:
    14,983
    ok seems im having a similar issue, battery draining super fast and charging is very slow, I did notice when the switch is plugged into the USB on my computer it seems to be repeatedly connecting and disconnecting so im assuming the chip is just reboot looping or something

    I just re-read the OP and seen that your supposed to remove the LED from the trinket m0, might that be the cause of these issues? I was supposed to be dropping this off to my friend today and only just noticed as I left it on charge overnight (granted on a normal 5v charger not switch charger) but when I checked it was still on 4% battery after being on all night, I plugged it into the switch charger for an hour or so and it went up 1%
     
    Last edited by gamesquest1, Mar 1, 2020
  12. mattytrog

    OP mattytrog You don`t want to listen to anything I say.
    Member

    Joined:
    Apr 27, 2018
    Messages:
    3,708
    Country:
    United Kingdom
    If the chip is bootlooping, that indicates a poor charger or poor regulation in the charger. If you look in the Fusee thread (I think it was) someone had a similar issue.

    Those poor chargers pop ICs. I can EASILY fix it in code, but I think it should remain as it really could save your ICs. The Trinket takes the hit, rather than M92T36.

    If you are still getting problems on the Switch dock, then thats a different kettle of fish and needs to be remedied.
     
  13. gamesquest1

    gamesquest1 Nabnut
    Moderator

    Joined:
    Sep 23, 2013
    Messages:
    14,983
    well it connects to HDMI fine in the dock, it just seems it doesn't want to charge up at all and the usb repeatedly connecting a new device makes me think the chips not going to sleep after successfully booting, I will remove the chip shortly just to verify that its not the USB port or anything , I did try to see in the device manager if it was the switch and trinket fighting over what the device was but it was connecting and disconnecting to fast for m to see what was being detected
     
  14. mattytrog

    OP mattytrog You don`t want to listen to anything I say.
    Member

    Joined:
    Apr 27, 2018
    Messages:
    3,708
    Country:
    United Kingdom
    Just try removing the USB strap and reflash Fusee Suite. Both parts.

    Part 1 is different to the old Switchboot part 1. Flash both parts.
     
  15. Dolphin678

    Dolphin678 Member
    Newcomer

    Joined:
    Jan 3, 2020
    Messages:
    28
    Country:
    United States
    Ah, I think this was my problem. Question: how do I flash the chip if the USB straps are disconnected? Or do I remove the USB disconnect strap?
     
  16. mattytrog

    OP mattytrog You don`t want to listen to anything I say.
    Member

    Joined:
    Apr 27, 2018
    Messages:
    3,708
    Country:
    United Kingdom
    You need to get into uf2 mode. Send the update payload from fusee suite op, bis tegrarcmsmash , then double press reset
     
    Dolphin678 likes this.
  17. Dolphin678

    Dolphin678 Member
    Newcomer

    Joined:
    Jan 3, 2020
    Messages:
    28
    Country:
    United States
    Okay, thanks. Just to double check, I have all the straps in place except the USB straps and then do what you said, correct?
     
  18. mattytrog

    OP mattytrog You don`t want to listen to anything I say.
    Member

    Joined:
    Apr 27, 2018
    Messages:
    3,708
    Country:
    United Kingdom
    Yes. If all goes to plan, refit usb strap if desired
     
  19. Dolphin678

    Dolphin678 Member
    Newcomer

    Joined:
    Jan 3, 2020
    Messages:
    28
    Country:
    United States
    Thank you very much, I really appreciate all your help
     
    mattytrog likes this.
  20. gamesquest1

    gamesquest1 Nabnut
    Moderator

    Joined:
    Sep 23, 2013
    Messages:
    14,983
    hmmm, ok so I disconnected the USB disconnect strap and now the console actually charges and the battery drain i'm not too sure about, seems like its not as bad as it was previously but i'm assuming this means the chip remains on so its probably draining to some degree, but unfortunately its still doing the connected/disconnected stuff, is there a payload that functions for a set cycle of injections, then disconnects, im thinking this would probably be acceptable to my friend, going to see how long the battery lasts to make sure the battery drain isn't too bad, just means they won't be able to use the USB install feature on tinfoil etc as basically the USB port is non functional in the state its in now, but at least its charging properly now

    PS I reflashed the trinket and had the same results in regard to the usb constantly reconnecting, I did at least see that at least once the new device being picked up by the computer was the Nintendo Switch as opposed to the trinket, but i'm assuming they are basically both trying to initialise and fighting with the PC over what device it thinks is connected, as in uf2 mode in the fusee suite it just showed up as the UF2 drive for flashing without any random disconnects, same when I disconnected the 3V lead, the switch showed up as the APX device as normal
     
    Last edited by gamesquest1, Mar 2, 2020
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - ItsyBitsy, Internal, (Trinket