installing cIOS Rev9 on a 4.0 firmware

Discussion in 'Wii - Hacking' started by atomikramp, May 22, 2009.

May 22, 2009
  1. atomikramp
    OP

    Member atomikramp GBAtemp Regular

    Joined:
    Jun 22, 2008
    Messages:
    247
    Country:
    Italy
    Hello everybody, i've just made my way installing the HBC 1.02 and bootmii and such on my wii,
    it's working flowlessly except that when i tried to install the cIOS rev 9 it gave me an error while installing tickets

    is there a particular procedure to install the cIOS? thnx [​IMG]
     
  2. FenrirWolf

    Member FenrirWolf GBAtemp Psycho!

    Joined:
    Nov 19, 2008
    Messages:
    4,343
    Location:
    Beaverton, OR
    Country:
    United States
    There is. You have to downgrade IOS35 to get it to work. Search for some 4.0 downgrade guides.
     
  3. atomikramp
    OP

    Member atomikramp GBAtemp Regular

    Joined:
    Jun 22, 2008
    Messages:
    247
    Country:
    Italy
    thnx a lot for the help, i found the guide on this board, everything worked like a charm [​IMG]
     
  4. KiiWii

    Member KiiWii GBAtemp Psycho!

    Joined:
    Nov 17, 2008
    Messages:
    3,164
    Country:
    United Kingdom
    shared2clean (nand clean etc) and removing cioscorp folder didnt work for me (I decided just to format instead which fixed it).

    Though my wii is done and dusted (working awesomly I might add) My question is: is there a modified version or an alternative to CMDVDX35 for offline downgrade that doesnt give you the pirate error, and just carries on and downgrades IOS35 anyway?
     
  5. FenrirWolf

    Member FenrirWolf GBAtemp Psycho!

    Joined:
    Nov 19, 2008
    Messages:
    4,343
    Location:
    Beaverton, OR
    Country:
    United States
    Unfortunately there isn't because the exploit it uses is closed-source. Someone else will have to find and release the bug, or at least an application that uses it without being dumb like Comex's installer.
     
  6. fogbank

    Member fogbank GBAtemp Fan

    Joined:
    Oct 28, 2008
    Messages:
    413
    Country:
    United States
    Yes, and if that happens it may provide a "fix" for the LU64 4.0 problem (in my opinion).

    It seems that the problematic LU64+ Wii's cannot run older IOS versions, except IOS16 for some reason. If the stub IOS16 on a 4.0 LU64+ Wii could be modified to have a lower title version, it could be overwritten with IOS16 v257. That could then be used to install the "LU64+ fix" (cIOS rev11) on any 4.0 system, including problem LU64+ systems.

    Speculating of course... [​IMG]
     
  7. FenrirWolf

    Member FenrirWolf GBAtemp Psycho!

    Joined:
    Nov 19, 2008
    Messages:
    4,343
    Location:
    Beaverton, OR
    Country:
    United States
    The reason the LU64's can run IOS16 is because, until Firmware 4.0 came out, IOS16 was never installed onto any Wii (except if the factory repair disc was used on it). You can install it on a virgin 3.4 when other wads don't work is because it's properly signed by Nintendo and there isn't an existing IOS in slot 16 to block its install.

    The 4.0 update contains a new IOS16 v512 to keep you from installing v257 because unmodified IOS's don't let you install old versions on top of new ones.
     
  8. atomikramp
    OP

    Member atomikramp GBAtemp Regular

    Joined:
    Jun 22, 2008
    Messages:
    247
    Country:
    Italy
    now i've installed bootmii, i have a firmware 4.0 and all the stuff needed to run backup loaders.
    but the question is, except bootmii, is there a way to revert to a virgin firmware 4.0E console?
    without anything installed?, like it just came out of the box?

    like a format or so?
    it would be cool couse that way i can make a nand dump of my virgin console and have it ready in case something goes wrong.

    EDIT: i know that i can perform a nand dump of the console in the actual state, but dumping it in a compeletely clean state would prevent me from having problems in the future if i wanted to install new firmwares and revert it to original.
     
  9. KiiWii

    Member KiiWii GBAtemp Psycho!

    Joined:
    Nov 17, 2008
    Messages:
    3,164
    Country:
    United Kingdom
    I guess if you just update ur wii with 4.0e from nintys servers, and then format, that would be factory fresh.
     
  10. atomikramp
    OP

    Member atomikramp GBAtemp Regular

    Joined:
    Jun 22, 2008
    Messages:
    247
    Country:
    Italy
    it's already 4.0E
     
  11. manias

    Member manias GBAtemp Maniac

    Joined:
    Aug 7, 2007
    Messages:
    1,258
    Country:
    Netherlands
    format? i've only heard that will brick you if you have CIOS installed.
    But why would you want to " virginize " your wii again? it's all working great now, right? so why not make a backup of that
     
  12. KiiWii

    Member KiiWii GBAtemp Psycho!

    Joined:
    Nov 17, 2008
    Messages:
    3,164
    Country:
    United Kingdom
    NO.

    If you update officially over any update used in any guide (im guessing atomikramp used the guide with preloader etc) then it will overwrite all the modifications.

    Formatting after this will virginise your wii from a cosmetic p.o.v.

    Any higher up installed IOS's might not be removed, but they will not function.

    I have done this a number of times on 3.2 upto 4 with cioscorp 1 and v2 without bricking.
     
  13. fogbank

    Member fogbank GBAtemp Fan

    Joined:
    Oct 28, 2008
    Messages:
    413
    Country:
    United States
    Yes I know all of that. I think you missed my point.

    My point is that the problem with LU64+ Wii's seems to be that they don't run older IOS versions, so their IOS'es cannot be downgraded. If you install an older IOS35 on an LU64+ Wii (as you normally would when hacking a 4.0 system) it will not function. That's why older cIOS versions (like cios_fix) caused black screens with apps that used it.

    But all along these "problem" LU64+ Wii's have been able to run IOS16 v257.

    If an application similar to Comex's DVDX installer was capable of modifying the existing IOS16 on a 4.0 system to lower its title version, the older IOS16 could be installed over it, thus re-enabling the trucha bug on the system.
     
  14. atomikramp
    OP

    Member atomikramp GBAtemp Regular

    Joined:
    Jun 22, 2008
    Messages:
    247
    Country:
    Italy
    i didn't follow the preloader guide
    i took my virgin 4.0 wii and installed the homebrew channel + bootmii + dvdx using the hackmii + bannerbomber
    then i followed a guide for downgrading the IOS35
    and then i installed the cIOS Rev9 to use the USB backup loader.

    i simply would like to know if it's possible to completely rollback mi wii to a virgin 4.0 firmware like it was before all of this started.
    not only by a p.o.v. but exactly the same [​IMG]
     
  15. KiiWii

    Member KiiWii GBAtemp Psycho!

    Joined:
    Nov 17, 2008
    Messages:
    3,164
    Country:
    United Kingdom
    wadman to over write ios35 DONT REMOVE IT just incase.

    ATD to remove CIOS rev9.

    Banner bomb to hackmii installer to remove HBC and DVDx.

    Format to remove game saves.

    Done.
     
  16. atomikramp
    OP

    Member atomikramp GBAtemp Regular

    Joined:
    Jun 22, 2008
    Messages:
    247
    Country:
    Italy
    thnx a lot
     
  17. atomikramp
    OP

    Member atomikramp GBAtemp Regular

    Joined:
    Jun 22, 2008
    Messages:
    247
    Country:
    Italy
    or maybe i can just install the bootmii, then perform a nand dump, and then start to install all the other things..
    in that way i have a clean dump of my nand to rollback to it's original state...
    mmhhh sounds good.
     

Share This Page