Installing a9lh on o3ds xl with 5.1.0-6E

Discussion in '3DS - Flashcards & Custom Firmwares' started by Kiesel, May 30, 2016.

  1. Kiesel
    OP

    Kiesel Member

    Newcomer
    20
    0
    Apr 7, 2016
    Gambia, The
    Hi,

    I am trying to install a9lh (as per plailects guide) on an o3dsXL with firmware version 5.1.0-6E.
    According to this, the firmware update to 9.2 doesn't work for me. I did my own research but I could need some help on deciding what I should try first and what has the lowest risk of bricking.

    1. I can do a cartridge update to 6.x and restart the guide.
    2. I think I can do a downgrade to 4.x using gateway (which I don't have)
    3. I can upgrade to 9.x using a cartridge and then downgrade using another cartridge (my least favourite option due to the costs). This was a recommendation I got on reddit though I am curious why I would need to downgrade if I am on let's say 9.2, I thought that was the point of the whole upgrade part of the guide?
    4. I got the 3ds used with a "R4" card that has www.r4ultra.com printed on it, unfortunately the page doesn't exist anymore. Can I use that card somehow?

    So what should I do? I think the easiest and cheapest option is option number 1, is that correct? According to this list, Zelda a link between worlds has a 6.2 firmware.
    As far as I have read I need to disable wifi while updating via cartridge. The 3ds told me yesterday that it downloaded a firmware update (which I didn't install of course), could that be a problem?

    Thanks for your help and sorry for the wall of text!
     


  2. Ev1lbl0w

    Ev1lbl0w GBAtemp Regular

    Member
    236
    55
    Dec 19, 2014
    If you can upgrade to 9.2, then just follow the guide from part 3.

    Also, there's no need to buy another cartridge as you say, because you can use sysUpdater from 9.2, using browserhax/menuhax.
     
  3. azublazer

    azublazer GBAtemp Regular

    Member
    149
    58
    Feb 3, 2015
    United States
    Yes, upgrade using a cart then follow the guide from there. If I'm not mistaken there should be part of the guide which tells you how to get rid of the update nag you're having.
     
  4. Jiro2

    Jiro2 GBAtemp Advanced Fan

    Member
    757
    184
    Mar 28, 2011
    United States
    This is bad advice. Upgrading to 9.2 with a cart will not leave him with a useful browser for browserhax.
     
  5. Ev1lbl0w

    Ev1lbl0w GBAtemp Regular

    Member
    236
    55
    Dec 19, 2014
    Oh, didn't know that. Thanks.
     
  6. solress

    solress Not a dev

    Member
    579
    306
    May 12, 2016
    Netherlands
    Between here and there
    A game card isn't designed to need a certain browser version as it never accesses it, that's why it only updates the system version. For example: an 10.2 card will only update the first 2 numbers in the firmware version. This will just become 10.2.0-X. X only gets updated by downgrading/updating.
     
  7. Kiesel
    OP

    Kiesel Member

    Newcomer
    20
    0
    Apr 7, 2016
    Gambia, The
    I am trying to use sysUpdater to update the firmware as the guide describes but I get stuck at 29/30. The 3ds just freezes when click on devmode in rxTools 2.5.2.
    (Source)

    If a cart update isn't the answer, is there another way to start sysUpdater?
     
  8. MelonGx

    MelonGx GBAtemp Advanced Maniac

    Member
    1,630
    438
    Jan 8, 2009
    China
    Do you mean that you upgraded 5.1.0-6E to 6.X.0-6E then failed booting rx 2.5.2 Devmenu?
    Or hadn't upgraded to 6.X, just failed on 5.1.0-6E booting rx 2.5.2 Devmenu?
     
    Last edited by MelonGx, May 31, 2016
  9. Akira

    Akira I'm not a SHRIMP!!!!

    Member
    920
    315
    Apr 28, 2013
    Last edited by Akira, May 31, 2016
  10. Kiesel
    OP

    Kiesel Member

    Newcomer
    20
    0
    Apr 7, 2016
    Gambia, The
    @MelonGx
    I am on 5.1.0-6E and booting to devmenu fails.

    @Akira
    "using MSET exploit": do you mean starting rxTools 3.x pasta mode via the MSET (profile?) exploit?
     
  11. Akira

    Akira I'm not a SHRIMP!!!!

    Member
    920
    315
    Apr 28, 2013
    Quantumcat and Kiesel like this.
  12. MelonGx

    MelonGx GBAtemp Advanced Maniac

    Member
    1,630
    438
    Jan 8, 2009
    China
    Then try to upgrade to 6.X.0-6E first. One person reported that 6.X boots rx 2.5.2 Devmode successfully.
    If failed then you still can use MSET on 6.X, both rx 2.X (using Roxas75 original booting method) and rx 3.X (using CakeHax) support MSET 6.X.

    The most popular cartridge to upgrade to 6.X is Pokemon X/Y (6.2.0) I think.
     
    Last edited by MelonGx, May 31, 2016
  13. Kiesel
    OP

    Kiesel Member

    Newcomer
    20
    0
    Apr 7, 2016
    Gambia, The
    @MelonGx
    Is there a reason I should update to 6.x first? Because for that I would need to buy a game. If all I need rxTools for is to boot sysUpdater I would like to avoid that.
     
  14. MelonGx

    MelonGx GBAtemp Advanced Maniac

    Member
    1,630
    438
    Jan 8, 2009
    China
    If there was any other workable method, I would have already written it on that issue page.
    So you have to upgrade it to 6.X or 8.X or 9.0-10.7 first.
    For 6.X or 8.X, it should be available to continue booting rx 2.5.2 Devmode.
    For 9.0-10.7, see the guide's Part 2 Downgrade.
    You can borrow one instead of buy one if available.
     
    Last edited by MelonGx, May 31, 2016
  15. Kiesel
    OP

    Kiesel Member

    Newcomer
    20
    0
    Apr 7, 2016
    Gambia, The
    I am a bit confused now. Akira says I can also use the MSET exploit. Not trying to start a discussion or anything I am just trying to understand the differences and what I am actually doing.
     
  16. Akira

    Akira I'm not a SHRIMP!!!!

    Member
    920
    315
    Apr 28, 2013
    If you haven't tried MSET yet than i say go ahead and try it. Don't get confused, I'm just trying my best(As far as my knowledge goes) to help you with what I know. I've used MSET on a 4.x o3ds console so I just assume(And the guide using MSET exploit says it can be used on a 5.x console) it will work on you too. Correct me If I am wrong anyone. But I mean, no harm on trying. You have an R4 at your disposal so all I can say is go ahead and try.
     
  17. astronautlevel

    astronautlevel But he's a guy

    Member
    3,935
    4,679
    Jan 26, 2016
    United States
    That Nightly Siteā„¢
    If you can use mset you can boot rxTools pasta mode and use sysupdater to get to 9.2.0. This will also get you a workable browser.
     
  18. Kiesel
    OP

    Kiesel Member

    Newcomer
    20
    0
    Apr 7, 2016
    Gambia, The
    Setting up mset didn't work with my R4 card for some reason so I ordered Zelda: A link between worlds to upgrade.
     
  19. wormdood

    wormdood pirate booty inspector

    Member
    3,114
    1,287
    Jan 3, 2014
    United States
    behind a parental advisory sticker
    umm . . . mset is only exploitable in 4.x and 6.x that is why they need you in 6.x instead of 5.x
     
  20. Drake008

    Drake008 Advanced Member

    Newcomer
    85
    16
    Feb 2, 2008
    Gambia, The
    Can I get the otp when I'm at 4.5.0-8E or do I have to UPGRADE to 9.2???