Hacking "Initialising SD card failed," then "Error: SD card i/o failure" -- GM9


New Member
Jun 10, 2020
United States
This might be a long one, so please bear with me. I also don't know where exactly to post this, because the problem might actually have something to do with the hardware. This entire thing is a huge mess.

Some background: about a year ago, my o3DS's circle pad started to disintegrate. Ordered a replacement off Amazon, looked at the iFixit instructions, and gave up at the part where you had to take out the motherboard. Dunno why that was a step, but at that point I decided it was too cumbersome and left it. In the process of doing so, though, I broke one of the ribbon cables to the shoulder buttons.

Fast forward to a few days ago. I wanted to play some 3DS games, so I ordered the replacement ribbon and reassembled it. It worked OK, but I wanted to fulfill the original purpose of the disassembly in the first place: replacing the circle pad. I ordered another one and got to following the same iFixit instructions (including taking out the motherboard). Two other things broke during the process, of course, and those were 1) the metal plate below the SD board and 2) the clasp holding the circle pad's ribbon in place. The solder holding it to the board was broken off, so to reassemble it I just screwed it in with the SD board like nothing happened. As far as I know, that hasn't actually affected anything, fortunately. The clasp problem, however, proved much more daunting, especially if you have horrible coordination like me. Many times I must have put the cable down in the wrong place, because when I put the end of the cable directly on top of the entire connection thingy, I inadvertently caused the circle pad to go AWOL on the home screen when I booted it up (with my SD card completely working, despite the broken metal plate), and then stop until I rebooted the 3DS. Obviously by now I know I put it in the wrong place, but at this point I don't know what's right anymore.

Now, the problem at hand. After taking a short break, I resumed my attempt to get the 3DS working again. I had a glue gun this time, and it's a lot better at providing pressure and stability than cardboard and electrical tape. I placed it in what I perceived to be the correct spot (just behind where the clasp originally was, on the part that drops down), put a bit of glue on it, then pressed on it while it dried. Not too hard, of course. After successfully screwing in the actual joystick thing, I closed it up and put the SD card (that had been previously working, mind you) back in the slot.

Black screen, blue light blinking once.

I looked online for a solution, but I couldn't find a topic that pertained to my specific situation. Then I did a potentially stupid thing: formatting the card. The issue persisted.* And without the SD card in, it got the "Failed to apply 1 FIRM patch(es)" error as normal. I tried formatting the card again with the SD Association's formatter, then tried an overwrite format in the same program. All in FAT32, and still there's nothing.

Between these formats, I put the SD card in when booted into GodMode9 and got the "Initialising SD card failed" error. When I tried to format the card within GM9, it came up with "Error: SD card i/o failure".

Are there any ideas as to how to resolve this? Sorry for the long-winded question, I just want to make sure I got everything. What a chronicle.

*Might have been because the card was missing the Luma directory and boot.firm. Though I still encounter this problem after putting the necessary files back on the card.

Edit: I have a feeling that this is just the result of a bad SD card. I’ll swap it out later.
Last edited by giant_steps,
General chit-chat
Help Users
    Ophelia_Later @ Ophelia_Later: thnx selever