In your opinion, what is the best CFW to have?

Discussion in 'PSP - Games & Content' started by drewww75, Aug 4, 2010.

  1. drewww75
    OP

    drewww75 Member

    Newcomer
    19
    0
    Jun 26, 2010
    United States
    Detroit
    I'm a noob and just have 4.01 M33-2. Only few of my iso's work on it or even show up. What CFW should i upgrade to in your opinion? Also i wanna be able to use gpsp [​IMG]. Any help will be greatly appreciated!
     
  2. oneesli

    oneesli Member

    Newcomer
    24
    0
    Jun 1, 2010
    Netherlands
    5.03 GEN C (FULL) is great [​IMG]
     
  3. LegendarySkitch

    LegendarySkitch Advanced Member

    Newcomer
    65
    0
    May 17, 2009
    United States
    I have Prometheus but at this point the best to me is whatever can play ToP:NDX first
     
  4. drewww75
    OP

    drewww75 Member

    Newcomer
    19
    0
    Jun 26, 2010
    United States
    Detroit
    What are the differences between those two? also i heard that one of those you cant play older games :/.
     
  5. KevFan

    KevFan GBAtemp Fan

    Member
    331
    6
    Apr 17, 2010
    prometheus can play the latest psp games without patching the iso
     
  6. drewww75
    OP

    drewww75 Member

    Newcomer
    19
    0
    Jun 26, 2010
    United States
    Detroit
    ok I will upgrade to that one than.
    Do you know if you are able to run gpsp on it?
    i have a psp 1000 btw
     
  7. Nobunaga

    Nobunaga Empty

    Member
    2,063
    220
    Apr 19, 2010
    Greece
    for me is 5.50 prom i can play all the games without patch em
     
  8. Jolan

    Jolan Unlimited Bear Works

    Member
    1,385
    7
    Mar 20, 2010
    Netherlands, currently
    Update to 5.50 GEN-D3 with the direct updater and use the latest ISO Tool to patch the newer games because apparently prometheus CFW has a flaw with running some of the even newer games, or so I heard.
     
  9. demonicstrife

    demonicstrife *INSERTGENERICTITLE*

    Member
    769
    77
    May 22, 2008
    United States
    Somewhere in the middle
    Well, honestly, it depends on what you plan to use it for. The two most common firmwares are 5.00 M33-6 and 5.50 GEN-D3/Prometheus v4. 5.00 is compatible with virtually all homebrew, while 5.50 has slightly less homebrew compatibility, but better ISO support thanks to the ability to run 6.20 games without a patch or plugin. And its POPS is more compatible with games like Metal Gear Solid and Final Fantasy VII.
     
  10. I2aven's_Sag

    I2aven's_Sag GBATemp Otaku

    Member
    726
    6
    Sep 13, 2009
    United States
    Northern Virginia
    +1
     
  11. oneesli

    oneesli Member

    Newcomer
    24
    0
    Jun 1, 2010
    Netherlands
    yes it works on both [​IMG]
     
  12. overslept

    overslept WALLY WALLY WALLY WALLY WALLY WALLY WALLY WORLD

    Member
    706
    4
    Mar 22, 2009
    United States
    California
    5.50 prometheus is working great for me. All games and homebrews that I've tried have worked so far (including gpsp kai)
     
  13. Leamonde.Halcyon

    Leamonde.Halcyon 6x9=42

    Member
    736
    0
    Apr 16, 2008
    United States
    6x9=42
    Another vote for 5.50 GEN-D3 with Prometheus. Haven't had a problem yet. It's run everything beautifully.
     
  14. 754boy

    754boy :D

    Banned
    3,469
    1
    Oct 24, 2002
    United States
    Mississippi
    5.00m33!!!!!!!!!!!!
     
  15. megawalk

    megawalk The Legendary SRW Addict

    Member
    1,067
    1
    Jun 14, 2008
    Netherlands
    Netherlands
    i would say 5.50 gen d3 and 5.50 Prometheus...
    they are full hacks >.>