Im on firmware 3.4 - any reason to change it?

Discussion in 'Wii - Hardware, Devices and Utilities' started by mouthrush, Aug 8, 2010.

  1. mouthrush
    OP

    Newcomer mouthrush Newbie

    Joined:
    Aug 8, 2010
    Messages:
    2
    Country:
    United Kingdom
    I've recently bought a 2nd hand wii, and it has firmware 3.4. I'm a complete noob to the wii, but not to modding/hacking hardware.
    I've ordered a Wode for the kids to use and have been reading anything and everything I come across on this site that might help.
    My question that I havent found an answer for is:-
    Is there an optimum firmware to have installed? I see that 4.2 or less is considered fine. Is there any benefit to the wii to having a higher one than my 3.4? Any bug fixes that are crucial? Any games need a higher one to work?

    If there is a higher one that you recommend - is there a particular game that includes it that I should borrow?
    Or should I simply connect the Wode and relax? :-)

    Thanks!
     
  2. Sicklyboy

    Global Moderator Sicklyboy Resident Mechanical Keyboard Addict

    Joined:
    Jul 15, 2009
    Messages:
    5,620
    Location:
    [̲̅$̲̅(̲̅ ͡° ͜ʖ ͡°̲̅)̲̅$̲̅]
    Country:
    United States
    Main advantage to having 4.0-4.2 is the addition of the SD card menu. Other than that, there isnt much of a benefit AFAIK.

    But a WODE, damn those things do sound nice [​IMG] have fun with that thing lol.
     
  3. wyndcrosser

    Member wyndcrosser GBAtemp Advanced Fan

    Joined:
    May 28, 2009
    Messages:
    720
    Country:
    United States
    Search button?

    I'm not being rude, but there's TONS of these already on the forum, look around.

    Update to 4.2 wak updater, WODE isn't worth the money.

    I haven't touched my wii since march of 2010, and I can still play 99% of games.

    Wynd
     
  4. d3monsting

    Member d3monsting GBAtemp Regular

    Joined:
    May 9, 2010
    Messages:
    119
    Location:
    What's this box for
    Country:
    United States
    Isn't there something about SDHC support after 4.0?
     
  5. mouthrush
    OP

    Newcomer mouthrush Newbie

    Joined:
    Aug 8, 2010
    Messages:
    2
    Country:
    United Kingdom
    Thanks for the tips, I'll investigate going from 3.4 to 4.0 then.
     
  6. t^2

    Newcomer t^2 Member

    Joined:
    Jul 24, 2010
    Messages:
    35
    Location:
    IOS36
    Country:
    Canada
    I'm on 4.1 and have no problems with it. It includes a fix for Wii Sports Resort, so if you want to play that game, you'll want to update to 4.1. It's the last firmware update that was actually worth something more than trying to block out homebrew.
     

Share This Page