I'm considering upgrading to 4.0 now that I have bootmii

Discussion in 'Wii - Hacking' started by Shinigami Kiba, May 14, 2009.

  1. Shinigami Kiba
    OP

    Member Shinigami Kiba GBAtemp Advanced Fan

    Joined:
    Oct 28, 2007
    Messages:
    606
    Country:
    Macedonia, The Former Yugoslav Republic of
    My current setup works perfectly, I hate the way Nintendo installs WiiWare/VC every time you run a new game to the Wii's NAND and all that, but I'm still ONLY considering for now upgrading to 4.0 mainly because I can safely do it now with bootmii.

    My current system specs:
    - 3.2E
    - IOS37,38,53 and 55 installed, everything seems to be running off of IOS55, at least HBC seems to be using it because it says IOS55 in the "Home" HBC Menu
    - cIOS36 rev10
    - HBC 1.0.2 - reads both my SDHC cards
    - Starfall
    - Bootmii on boot2
    - WiiKey 1.9s
    (Starfall and the WiiKey conflict with blocking updates it seems, but everything else works including all region WiiWare and WADs)

    I don't have an internet connection on my Wii and can't get it online cause my internet isn't wireless, so everything I do on it I do it offline.

    If I upgrade to 4.0 I assume I'll have to install preloader too to get the system to play WiiWare and WADs from all regions like it can now thanks to Starfall.
    I understand Bootmii and Preloader can coexist, but, can I install preloader OVER bootmii? Also, if I mess up and lose the HBC in the process I take it Bootmii is still going to run since it's set to Boot2 so I could just install my 3.2E NAND with HBC on.

    So guys, is there a safe Offline way to do all this and do I run any risk of losing the ability to play WiiWare from all regions and all that stuff.
    Any issues I should know about and so on?

    I don't really need to do this, i just want to give it a shot maybe in the next few days, see if it works, but i dunno, I'm comfortable with just 3.2, bootmi and all my emulators and HBC, USB Loader and everything.
     


  2. cojiro

    Member cojiro GBAtemp Regular

    Joined:
    Apr 1, 2009
    Messages:
    152
    Location:
    Boston, MA
    Country:
    United States
    bootmii installs as boot2 (or an IOS, but that is only for those with newer boot1)
    preloader installs as systemmenu, so they cannot overwrite each other. You are safe.,
     
  3. Shinigami Kiba
    OP

    Member Shinigami Kiba GBAtemp Advanced Fan

    Joined:
    Oct 28, 2007
    Messages:
    606
    Country:
    Macedonia, The Former Yugoslav Republic of
    I know all about bootmii, but nothing about preloader.
    I see, so preloader installs as system menu, thanks for the info man.

    So all i need now is for someone to link me to a detailed guide on how to upgrade everything offline.
     
  4. FenrirWolf

    Member FenrirWolf GBAtemp Psycho!

    Joined:
    Nov 19, 2008
    Messages:
    4,343
    Location:
    Beaverton, OR
    Country:
    United States
    If you get up t 4.0 I suggest using StartPatch instead of preloader. It lets you disable disc updates and other Starfall hacks but doesn't have Preloader's "preloaddiness."
     
  5. Shinigami Kiba
    OP

    Member Shinigami Kiba GBAtemp Advanced Fan

    Joined:
    Oct 28, 2007
    Messages:
    606
    Country:
    Macedonia, The Former Yugoslav Republic of
    I kinda want preloader so I can try messing with the system menu, make some custom themes or maybe download a custom color theme and health screen.
     
  6. FenrirWolf

    Member FenrirWolf GBAtemp Psycho!

    Joined:
    Nov 19, 2008
    Messages:
    4,343
    Location:
    Beaverton, OR
    Country:
    United States
    Ah. I'm just going to wait for people to write system menus that run off of bootmii.
     
  7. TrickyTony

    Member TrickyTony GBAtemp Fan

    Joined:
    Oct 8, 2008
    Messages:
    372
    Country:
    United States
    Let me know how that goes. I tried it last night and the SD menu just froze every time I tried opening it. So I went back to 3.2 hah.
     
  8. Shinigami Kiba
    OP

    Member Shinigami Kiba GBAtemp Advanced Fan

    Joined:
    Oct 28, 2007
    Messages:
    606
    Country:
    Macedonia, The Former Yugoslav Republic of
    ^ I'm very reluctant to trying new things with my systems, man, so chances are I won't do this any time soon unless I feel 100% safe and have a good, clean and easy to understand and follow guide on how to do it all offline and of course if someone provides me with tested, non malicious WADs for all the things since i'm no big on extracting WADs myself.
     
  9. arose1980

    Newcomer arose1980 Member

    Joined:
    Apr 18, 2009
    Messages:
    11
    Country:
    United States
    Question. I have bootmii installed on boot2. I am now on 4.0. I really would like to be able to play wad files from other regions but don't know what I need to do so. Please advise?
     
  10. Shinigami Kiba
    OP

    Member Shinigami Kiba GBAtemp Advanced Fan

    Joined:
    Oct 28, 2007
    Messages:
    606
    Country:
    Macedonia, The Former Yugoslav Republic of
    Wolf said to use StarPatch, which is probably just like StarFall, a console like program where you select a bunch of hacks and install them, so give that a try.
     
  11. FenrirWolf

    Member FenrirWolf GBAtemp Psycho!

    Joined:
    Nov 19, 2008
    Messages:
    4,343
    Location:
    Beaverton, OR
    Country:
    United States
    I think StartPatch has a regin free wad option. I'll bet Preloader does as well.
     
  12. arose1980

    Newcomer arose1980 Member

    Joined:
    Apr 18, 2009
    Messages:
    11
    Country:
    United States
    I just tried installing star patch 4.02 but I receive an error of

    ES_Identify (As SU) -1017
    Is there anything else that I can install for a 4.0 Wii for region free wads?
     
  13. syst3merror

    Member syst3merror GBAtemp Regular

    Joined:
    Nov 10, 2008
    Messages:
    248
    Location:
    Indiana
    Country:
    United States
    only thing that preloader does that I don't think StartPatch does is disable the BG music from the main menu....but I could be wrong! That is the one reason I haven't switched
     
  14. FenrirWolf

    Member FenrirWolf GBAtemp Psycho!

    Joined:
    Nov 19, 2008
    Messages:
    4,343
    Location:
    Beaverton, OR
    Country:
    United States
    You used the right version for your system menu, right?

    And SP does disable the background music.
     
  15. arose1980

    Newcomer arose1980 Member

    Joined:
    Apr 18, 2009
    Messages:
    11
    Country:
    United States
    Yup. I used the 4.02 for the USA version. I am trying to install through HBC, I changed the file to boot.dol but I get the error.
     
  16. FenrirWolf

    Member FenrirWolf GBAtemp Psycho!

    Joined:
    Nov 19, 2008
    Messages:
    4,343
    Location:
    Beaverton, OR
    Country:
    United States
    I did waninkoko's 4.0 update. I don't know if that makes a difference.
     
  17. arose1980

    Newcomer arose1980 Member

    Joined:
    Apr 18, 2009
    Messages:
    11
    Country:
    United States
    Hmm, I updated through system update. Is it possible to downgrade to 3.2, keep the features of 4.0? If so, how would I do that since then I would just install starfall.
     
  18. fiddlefaddle22

    Member fiddlefaddle22 GBAtemp Regular

    Joined:
    Nov 24, 2008
    Messages:
    201
    Country:
    United Kingdom
    I had the same error as you so i restored back to 3.2e with bootmii and i used the Pal version of Starpatch
     
  19. SpAM_CAN

    Member SpAM_CAN GBAtemp Regular

    Joined:
    Apr 5, 2009
    Messages:
    279
    Location:
    UK
    Country:
    United Kingdom
    Error was probably because you had preloader installed... yes?
     
  20. fiddlefaddle22

    Member fiddlefaddle22 GBAtemp Regular

    Joined:
    Nov 24, 2008
    Messages:
    201
    Country:
    United Kingdom
    No i had starfall. but i removed the hacks before upgrading to 4.0E
     

Share This Page