Hacking illegal Wad channels disappeared

Tetsuo Shima

Well-Known Member
OP
Member
Joined
Oct 29, 2008
Messages
1,685
Trophies
1
Age
43
XP
3,440
Country
Italy
Yesterday a strange thing happened. I was installing some Japanese VC Arcade wads through Wadmanager (Golden axe and Splatterhouse, both region freed with Freethewads). After discovering that Splatterhouse didn't work I rebooted my Wii holding the Reset button to check if Preloader's hacks were all enabled.
All was fine, so I clicked Systemmenu to exit from Preloader...and then... Bam!
All my previously installed VC wads were gone! Not only those 2 VC Arcade games, EVERY illegal wad (some installed months ago). The only things left were legally purchased VC games, forwarders channels and 1 VC injected game.
I restored my Wii's NAND with BootMii and everything went back to normal.
The question is: why has this happened? I don't have any clue and I've never heard of a similar problem happening to anyone...
I have a PAL Wii (3.2E) with MiiWii, Preloader, WC24 disabled, no modchip.
 

s3phir0th115

Well-Known Member
Member
Joined
Dec 31, 2008
Messages
728
Trophies
0
XP
803
Country
United States
Hmm. I've never heard of a documented reason for this happening, or of it happening at all for that matter.

Perhaps newer wiiware has a copy protection of some sort for this sort of thing?
 

WalkerOfTheDay

Well-Known Member
Member
Joined
Oct 10, 2008
Messages
848
Trophies
0
XP
54
Country
Netherlands
Bootmii ey ?
biggrin.gif
biggrin.gif
biggrin.gif


ios cat iz in ur wiiz watchin ur isoz

Kiddin' stange happenings though...
 

s3phir0th115

Well-Known Member
Member
Joined
Dec 31, 2008
Messages
728
Trophies
0
XP
803
Country
United States
I'm sure there will be a loader or some other kind of workaround created. Copy protection never lasts long without being dealt with.
 

spotanjo3

Well-Known Member
Member
Joined
Nov 6, 2002
Messages
10,951
Trophies
1
XP
5,407
Country
United States
Nah.. nothing to do with anything.. Sometime neogamma disappear too but I have to delete some unwant in sd card and its work. If you have 2gb.. maybe you need to increase to 4gb or more.
smile.gif
 

wrettcaughn

Well-Known Member
Member
Joined
Mar 14, 2009
Messages
3,819
Trophies
0
XP
1,492
Country
United States
This same thing happened to me about six months ago. It was before bootmii though so I had to format and start from scratch. I've not touched WW/VC wads since.
 

Tetsuo Shima

Well-Known Member
OP
Member
Joined
Oct 29, 2008
Messages
1,685
Trophies
1
Age
43
XP
3,440
Country
Italy
RockmanForte said:
Nah.. nothing to do with anything.. Sometime neogamma disappear too but I have to delete some unwant in sd card and its work. If you have 2gb.. maybe you need to increase to 4gb or more.
smile.gif
Are you saying that I've lost my channels because my SD was full? I have a 4gb SDHC and it's almost full, indeed.
I think you could be right, I reinstalled Golden Axe and nothing disappeared since yesterday.
 

ppc_gba

Well-Known Member
Member
Joined
Apr 16, 2006
Messages
198
Trophies
0
XP
258
Country
United States
Some people have claimed that channels were deleted before, around the time the 4.0 update came out. Some people have even said that they were on 3.3 and had channels deleted.

It could be a bug in the Wad Manager or IOS that removes corrupt channels or removes channels when it thinks a certain threshold of space has been used up, to prevent entirely filling the Wii's nand.
 

yabel

Well-Known Member
Newcomer
Joined
Feb 9, 2009
Messages
82
Trophies
0
XP
65
Country
United States
This happened to me BEFORE the 4.0 update and I thought I was pegged by Big N. But after postign many places and a few other people experiencing it I felt it was a Preloader issue. All people that posted had preloader .28 (since .29 wasnt out yet) and had went into it. Not sure if they made hack changes or not but I know I was looking in it and enabling crazyintro again. When my Wii booted back up MOST not all of my wad channels and their saves were GONE. My Sd card was less then 40% full so it wasnt a card issue. Same thing happened to a friends Wii a coule weeks later and he also has same setup as me since I did it for him.
It hasnt happened since even after moving to 4.0u from 3.2u. I think its a bug in Preloader thats not a real big so it dont happen enough to draw big attention.
People posted on my thread "You must have dont something or messed with something". But Im very careful with things I mess with on the Wii since its the familys console not just mine. Plus I read alot of threads and tut before ever changing things.
So I wouldnt sweat it.. But I would like to know what triggers the bug.
 

carbonyle

Well-Known Member
Member
Joined
Jan 9, 2009
Messages
360
Trophies
0
Age
38
Location
Switzerland
Website
Visit site
XP
96
Country
Swaziland
it can be preloader .28 related: crediar doesn't like piracy and he's a funny guy: remember his april fool.
I find "normal" that some people try to trick pirates: it's the game, we can loose and we have to admin it
(but most of the time we're happy: DVD backup, USB backup, pirated VC / WW, and so on...)
 

imapterodactyl

Well-Known Member
Member
Joined
Jan 20, 2009
Messages
424
Trophies
0
XP
55
Country
United States
carbonyle said:
it can be preloader .28 related: crediar doesn't like piracy and he's a funny guy: remember his april fool.
I find "normal" that some people try to trick pirates: it's the game, we can loose and we have to admin it
(but most of the time we're happy: DVD backup, USB backup, pirated VC / WW, and so on...)

I don't know about the OP's case, but it most definitely IS sometimes Preloader related, and there have been posts regarding it here (I'm too lazy to search for a specific thread now, though). This has happened to me twice upon installing Preloader. The second time it happened I was actually watching for it, and it was directly after installing in that case. Several VC/Wiiware channels go missing, but the tickets are left behind. It's minor, as you can certainly just reinstall them easily enough (and there are no reported cases of HBC being deleted), but it does happen. Definitely worth it for the Preloader hacks and banner brick protection, though.
 

ppc_gba

Well-Known Member
Member
Joined
Apr 16, 2006
Messages
198
Trophies
0
XP
258
Country
United States
Well I guess it makes a little more sense now, but it still seems like a bit of a jerk move by crediar, if it is true.
I had assumed he put some kind of anti-pirate protection into wadimport, but I guess he figures that people will just use Wad manager instead.
I wonder how he checks if a channel is "pirated". He probably just looks to see if it fails a signature check (trucha signed), but then this means he might end up deleting homebrew channels as well.

Has anyone who experienced this lost any homebrew channels (disregarding HBC since he may have put a check in place for that)?
 

imapterodactyl

Well-Known Member
Member
Joined
Jan 20, 2009
Messages
424
Trophies
0
XP
55
Country
United States
ppc_gba said:
Well I guess it makes a little more sense now, but it still seems like a bit of a jerk move by crediar, if it is true.
I had assumed he put some kind of anti-pirate protection into wadimport, but I guess he figures that people will just use Wad manager instead.
I wonder how he checks if a channel is "pirated". He probably just looks to see if it fails a signature check (trucha signed), but then this means he might end up deleting homebrew channels as well.

Has anyone who experienced this lost any homebrew channels (disregarding HBC since he may have put a check in place for that)?

Nah, I don't think any of this is accurate. I would guess that it's a bug of sorts; I doubt crediar is sneaking in a Trojan Horse.
 
General chit-chat
Help Users
    Peepa @ Peepa: but... im peepa....