If I were to update to 4.1...?

Discussion in 'Wii - Hacking' started by ayojoe, Aug 5, 2009.

Aug 5, 2009
  1. ayojoe
    OP

    Newcomer ayojoe Advanced Member

    Joined:
    May 15, 2009
    Messages:
    71
    Country:
    United States
    Right now, I see no point in updating to System Menu 4.1 as I don't plan on owning Wii Sports Resort. Right Now I'm currently on 4.0 and it looks I stay there unless I get some answers on 4.1

    All my info of what was done on my Wii is in my sig, if someone could please tell me what I would lose if I were to update to 4.1, that would help.

    Basically I don't want to lose my System Menu patches from StartPatch 4.0.4 USA-MOD which are: Region Free Games, Region Free Channels/SD Menu, Remove Copy Flags on Game Saves, and Skip Disc Channel Updates.

    Would I have to use StartPatch again to uninstall those, then update to 4.1 and use the StartPatch 4.1? What about my CIOS, trucha bugged IOS35 and IOS36, patched IOS60, and so on..?
     
  2. oxMUDxo

    Member oxMUDxo GBAtemp Fan

    Joined:
    Apr 12, 2009
    Messages:
    494
    Location:
    Missouri - USA
    Country:
    United States
    I want to know the same stuff too.
    My Wii is 4.0U I here Pre-Loader dose not work on 4.1 or the hacks don't work..

    What dose work on a 4.1 Wii and what doesn't?
     
  3. Tux'

    Member Tux' GBAtemp Advanced Fan

    Joined:
    Feb 8, 2009
    Messages:
    723
    Location:
    The flat lands.
    Country:
    Canada
    Mostly everything except themes. Preloader ha hacks for 4.1 and you can use Startpatch also.
     
  4. xDlmaoxD

    Member xDlmaoxD GBAtemp Fan

    Joined:
    Jan 12, 2009
    Messages:
    362
    Country:
    United States
    Updating using Waninkoko's 4.1 Updater is the simplest way to update to 4.1 with the truga bugs etc.
    Updates everything but the patches Nintendo made to block HBC, or installing it and such.
    I would suggest you unistall everything that relates with the System menu because if you update and you have it on it will
    most likely brick that goes for preloader also.
    Uninstall it and then when you are in 4.1 install it again i read a few threads about working 4.1 preloader codes
    but I don't know if the old 4.0 preloader still works on 4.1
    I don't really use anything aside from the basic stuff because using useless stuff just increases the bricking possibility even tho preloader is nice to have but complicated to uninstall sometimes.
     
  5. xbman

    Member xbman GBAtemp Regular

    Joined:
    Feb 8, 2006
    Messages:
    130
    Country:
    Hopefully this may help a bit. I went from 3.2U to 4.1U. Preloader .29 works just fine with 4.1 and there are hacks for it. From everything I read 4.1 really only has the fix for Wii Sports Resort. So if you are on 4.0 and don't plan on playing it, probably not needed. At the same time, I don't believe it causes any other issues, but would recommend wanin's updater if you decide to go that route.

    The ultimate 4.0 upgrade guide (title still says 4.0 but it now reflects 4.1) works just fine. However if you did not have 4.0 previously installed, at least in my case, ios60 was never installed, thus the 4.1 upgraded failed with a -1036 (this can also relate to not enough free blocks). So the first thing I would recommend is installing that first, then follow the guide from the beginning.

    I did run into a problam with system corrupt files when preloader used ios60, but I may have it sorted out now (basically removed all preloader hacks and created a new ini file with just the two hacks I am using, then went to HBC through bootmii, reinstalled iso60 with the sig hash check, rebooted (which WILL cause a system files corrupt if you had preloader previously installed), launched HBC again through bootmii, reinstalled preloader, enabled my hacks and seems to be fine now.

    Of course, this should go without saying, before doing anything, make sure you have bootmii installed and create a nand dump. This way if something does go wrong, you can always revert back to your prior settings.
     
  6. ayojoe
    OP

    Newcomer ayojoe Advanced Member

    Joined:
    May 15, 2009
    Messages:
    71
    Country:
    United States
    So all I have to do is remove my StartPatch patches, and reinstall them with the 4.1 installer if I do update? Well what did Nintendo include in 4.1? I thought it was harmless. Will it stop my trucha-patched IOS35/IOS36/IOS60 from working and ability to install WADs.
     
  7. xDlmaoxD

    Member xDlmaoxD GBAtemp Fan

    Joined:
    Jan 12, 2009
    Messages:
    362
    Country:
    United States
    If you use the nintendo official update it will probably will.
    http://www.teknoconsolas.es/blog/waninkoko...ware-updater-41
    Use that instead, but be warn that it can stop half way into installing or downloading.
    Downloading is not a problem cause you can just restart it but if it stops half way installing and doesn't install the
    System Menu you will have a brick.
    Just unistall the startpatch etc and anything that requires the firmware you have.
    I never used startpatch so you'll have to wait for someone to guide you on installing one that works on 4.1 unless the
    one you have already does.
    I have a limited understanding on such things I just use my wii to load games and nothing else.

    btw, if you use waninkoko's 4.1 updater all your ios will still be trucha bugged.
    They only get patched if you use a official nintendo update not a modified one like waninkokos.
     
  8. ayojoe
    OP

    Newcomer ayojoe Advanced Member

    Joined:
    May 15, 2009
    Messages:
    71
    Country:
    United States
    I don't like using Waninkoko's updaters. Isn't 4.1 free of IOS installations, meaning nothing will happen to my current ones?
     

Share This Page