I want to DOWNGRADE to 1.0.2

Discussion in 'Wii - Hacking' started by leafbarrett, Jul 6, 2009.

Jul 6, 2009
  1. leafbarrett
    OP

    Newcomer leafbarrett Member

    Joined:
    Jul 6, 2009
    Messages:
    13
    Country:
    United States
    Recently (as in yesterday), Gecko OS 1.9, 1.9.0.1, and 1.9.1 all stopped working on my HBC (1.0.3) as DOL files. [​IMG] 1.0.7 works fine (I download it as a DOL and don't have to convert it from ELF), but it can't handle nearly enough codes to use Brawl+ with. [​IMG] I know that HBC 1.0.2 works with ELF files, and since converting ELF files doesn't help, I was hoping to downgrade so that I could use ELF files as they are without changing them. Is there a way to downgrade the HBC? Or if it can't be downgraded, can someone help me install 1.0.2? (I don't even know where to find it at this point, everything's 1.0.3.) 1.0.3 was the first version I got, so I only know how to use the BootMii install.
    The error I'm getting is "This is not a valid Wii application." Boot.dol, the icon, and the meta file are all in the GeckoOS1.9 folder, which is in the apps folder. Maybe someone could tell me why Gecko OS 1.9 won't work anymore, even when I redownload it? I even tried downloading it from the HB Browser, and that one didn't work either...
    I'm really desperate here, and I'd be forever grateful if someone could help me out.

    EDIT: Wait, what does the HackMii installer install? 1.0.3 or Beta9? I mighta ctually have Beta9 >
     
  2. Unfortune

    Member Unfortune GBAtemp Fan

    Joined:
    May 10, 2009
    Messages:
    342
    Location:
    Alberta, Canada
    Country:
    Pakistan
    here is a homebrew channel beta 9 installer:

    http://dl.qj.net/Homebrew-Channel-Beta-9-W...24524/catid/526


    It wont work if you have system menu 4.0

    the reason i give you beta 9 is because im not sure if hbc 1.0.2 can handle elf files. but i KNOW FOR SURE beta 9 can.

    just load the .dol with the homebrew channel just as you would with any other application.
     
  3. tj_cool

    Supervisor tj_cool Stuff

    Joined:
    Jan 7, 2009
    Messages:
    9,941
    Location:
    This planet
    Country:
    Belgium
    all HBC versions can handle elf files as long as they are 'correct' elf files (like Hackmii installer or USB loader GX). All incorrect ones give the 'Invalid wii app' error

    Beta8 should be the last version to load incorrect .elf files. But if Unfortune says beta9 can load them too, he probably tried it, so why would I doubt his saying.
     
  4. leafbarrett
    OP

    Newcomer leafbarrett Member

    Joined:
    Jul 6, 2009
    Messages:
    13
    Country:
    United States
    [​IMG] Thanks~ Here's hoping it works.
    That's what I'm doing.
     
  5. leafbarrett
    OP

    Newcomer leafbarrett Member

    Joined:
    Jul 6, 2009
    Messages:
    13
    Country:
    United States
    Well, just in case Beta9 doesn't work for me, can you provide a link to Beta8?
     
  6. leafbarrett
    OP

    Newcomer leafbarrett Member

    Joined:
    Jul 6, 2009
    Messages:
    13
    Country:
    United States
    Yeah, like tj_cool said, it can't use incorrect ELF files. >
     
  7. tj_cool

    Supervisor tj_cool Stuff

    Joined:
    Jan 7, 2009
    Messages:
    9,941
    Location:
    This planet
    Country:
    Belgium
  8. leafbarrett
    OP

    Newcomer leafbarrett Member

    Joined:
    Jul 6, 2009
    Messages:
    13
    Country:
    United States
    I'm fine with RAR :3
    Thanks~ [​IMG]
     
  9. leafbarrett
    OP

    Newcomer leafbarrett Member

    Joined:
    Jul 6, 2009
    Messages:
    13
    Country:
    United States
    Ticket error: -2011
    ...I know I've seen that one before, somewhere here (I think)... *goes off to search*
     
  10. FenrirWolf

    Member FenrirWolf GBAtemp Psycho!

    Joined:
    Nov 19, 2008
    Messages:
    4,343
    Location:
    Beaverton, OR
    Country:
    United States
    GeckoOS is a recent app, so why would the elf file be improperly compiled?
     
  11. Jacobeian

    Member Jacobeian GBAtemp Advanced Maniac

    Joined:
    May 15, 2008
    Messages:
    1,879
    Country:
    Cuba
    Sure it works... just downloaded it from hbb and launched it in hbc 1.0.3...

    sorry mate but reinstalling old versions of hbc won't change anything, the problem is on your side (most probably corrupted dol/elf files)
     
  12. pm_41

    Member pm_41 GBAtemp Regular

    Joined:
    Jul 1, 2009
    Messages:
    204
    Location:
    Lurking in my Wii's NAND
    Country:
    United States
    I think LoadMii can load those kinds of .ELF files. [​IMG]
     
  13. Slowking

    Member Slowking GBAtemp Maniac

    Joined:
    Dec 31, 2006
    Messages:
    1,396
    Country:
    Germany
    Just convert those elfs to dols. Where is the problem?

    btw. GeckoOS is a recent App and it works in the newest homebrewchannel. You are doing something wrong if it doesn't work for you.
     

Share This Page