I just purchased a PSP GO. What cool Hombrew can i add onto it? :)

Discussion in 'PSP - Hacking & Homebrew' started by SushiKing, Feb 15, 2017.

  1. SushiKing
    OP

    SushiKing GBAtemp Fan

    Member
    425
    74
    Apr 24, 2013
    Australia
    ALSO do all PS1 and N64 games work on the psp go? Or do they lag/run slow?
     
  2. Arecaidian Fox

    Arecaidian Fox Pink Foxi

    Member
    934
    1,015
    Sep 5, 2013
    United States
    Snohomish, WA
    Last edited by Arecaidian Fox, Feb 15, 2017
    lordkaos likes this.
  3. kumikochan

    kumikochan GBAtemp Maniac

    Member
    1,150
    506
    Feb 4, 2015
    Belgium
    Tongeren
    Start by installing permacfw
     
  4. Arecaidian Fox

    Arecaidian Fox Pink Foxi

    Member
    934
    1,015
    Sep 5, 2013
    United States
    Snohomish, WA
    Only way to do permaCFW on a Go is Infinity.
     
  5. SushiKing
    OP

    SushiKing GBAtemp Fan

    Member
    425
    74
    Apr 24, 2013
    Australia
    I thought PermaCFW Was the most unsafe way to hack the PSP GO :s

    — Posts automatically merged - Please don't double post! —

    I don't think im experienced enough to try that haha. Can't you just buy a s2 Memory card and insert that for more space?
     
  6. Arecaidian Fox

    Arecaidian Fox Pink Foxi

    Member
    934
    1,015
    Sep 5, 2013
    United States
    Snohomish, WA
    PermaCFW isn't possible on the Go, if I remember correctly. The only way to do it is with Infinity 6.61 CFW, and you'll want the "6.60 plugins on 6.61" plugin or else a lot of stuff from older homebrew and plugins won't work.

    — Posts automatically merged - Please don't double post! —

    The M2 cards are all set to go, yes. But they're pricey and lack storage space.
     
  7. Sonic Angel Knight

    Sonic Angel Knight GBAtemp Legend

    Member
    10,509
    5,376
    May 27, 2016
    United States
    New York
    Dosen't infinity have bugs? I mean i can't even keep a custom theme on there without it resetting every time the system power cycles. I been using Pro with quick boot for years, it works i guess, if only i can figure out that online multiplayer thing, i be a bit happier. :P

    Wish someone can help with it. Anyway, N64 emu suck, on like almost all consoles, psp isn't gonna be any better. But you can convert PS1 games to PSP, although some games already do exist in PSP form like breath of fire 3 or whatever. Just remember if you have any psx classics you bought on playstation store, you can install them with ps3. Less work, but for the ANY GAME YOU WANT THING, i would think compatibility depends on game, there is a reason why not all games are available, maybe is not limited to licensing issues to make them purchasable, but limitations of the PSX emulation itself.

    As for my own recommendations, Get some emulators, GPSP kai 3.4 for GBA games, Pico drive 1.51 for Sega genesis and CD, Master boy for Master system Game gear and everything up to gameboy color, Nester j for NES and a not so very great emulator maybe either snestyl 0.42 or whatever is called or another one called snes euphoria. Either way some my suggestions. There is another homebrew i wish would work called the fusa game pad. supposed to allow your psp to work like HID on PC to use as controller, (ALSO FOR PS3) by usb, but it never works on my PSP for some reason. You also may wanna get PSPfiler, for file management (maybe a ftp progam) As well as some kind of homebrew app store just in case you wanna try some homebrew you wouldn't come up with to find. :)
     
    SushiKing likes this.
  8. SushiKing
    OP

    SushiKing GBAtemp Fan

    Member
    425
    74
    Apr 24, 2013
    Australia
    Awesome, sounds really good! The ps1 Games alone is the best part for me haha :)

    — Posts automatically merged - Please don't double post! —

    Is there any guides or youtube videos for a tutorial?
     
  9. rg

    rg GBAtemp Regular

    Member
    180
    48
    Jan 13, 2012
    Please go to this website for PSP CFW
     
  10. Sonic Angel Knight

    Sonic Angel Knight GBAtemp Legend

    Member
    10,509
    5,376
    May 27, 2016
    United States
    New York
  11. BORTZ

    BORTZ You get a hat, and YOU get a hat!

    Supervisor
    GBAtemp Patron
    BORTZ is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,758
    14,909
    Dec 2, 2007
    United States
    Pittsburgh
    I have been out of the PSP scene for a while, but most if not all PS1 games work pretty damn well on the PSP. Its the only way I was able to make it through FF7.
     
    SushiKing likes this.
  12. SushiKing
    OP

    SushiKing GBAtemp Fan

    Member
    425
    74
    Apr 24, 2013
    Australia
    My PSP Go Arrived todaay, it's on version 6.31, what do i do?
     
  13. hyprskllz

    hyprskllz Gashatto!!

    Member
    544
    175
    Apr 19, 2016
    Indonesia
    Auldrant
    Last edited by hyprskllz, Feb 23, 2017
  14. SushiKing
    OP

    SushiKing GBAtemp Fan

    Member
    425
    74
    Apr 24, 2013
    Australia
    Thanks! So do i update system before i start, or leave it on 6.31? Also what is the chances it will brick? ;o

    — Posts automatically merged - Please don't double post! —

    Oh and do i choose the LIME-2.3 or the PRO-C2
     
  15. codezer0

    codezer0 Gaming keeps me sane

    Member
    2,492
    417
    Jul 14, 2009
    United States
    The Magic School Bus
    I had previously suggested doing that because of the go having only m2 card slot and the miserably small sizes of available cards, for ridiculous prices. Since everyone insisted this mod didn't exist, I buckled down to spend the $40 for a 16gb m2 card for it, but even then it still wasn't enough because of the requisite duplication of files. So... It is possible now? And what size would it recognize?
     
  16. Arecaidian Fox

    Arecaidian Fox Pink Foxi

    Member
    934
    1,015
    Sep 5, 2013
    United States
    Snohomish, WA
    The mod does exist, I've seen a few different pictures of people getting microSD to work, though getting it all to fit in the case is difficult. Sadly, I cannot confirm for the skeptics, as there was an accident while I was soldering the last couple wires, and my PSP Go's logic board was damaged. I have another logic board arriving sometime next month, so I'll be able to try again. As far as size, it should be able to recognize the same size amounts that a PSP 1000/2000/3000 would recognize with a MSDUO-microSD adapter, 256GB+. I'd suggest not going above 128GB, though, as the PSP starts to have difficulty parsing all that space once you hit 128GB. If you don't mind a bit of lag on your XMB, then a 128GB microSD is fine, or, if you don't need that much space and want a faster XMB, a 64GB card is a good choice.
     
  17. Alex658

    Alex658 GBAtemp Maniac

    Member
    1,153
    342
    Jun 4, 2010
    Venezuela
    Venezuela
    Just go for the PRO or L-ME Light Custom Firmwares, the only "hassle" is having to run FAST RECOVERY ONCE when you fully turn off your psp (sleep mode doesn't count as a full shutdown). Infinity can be risky on GO's and it's incompatible with Street.


    I can have my psp on sleep mode for almost 3 weeks with a single charge. So... I rarely have to re-run the hack unless the PSP crashes.
     
  18. SushiKing
    OP

    SushiKing GBAtemp Fan

    Member
    425
    74
    Apr 24, 2013
    Australia
    Yeah thanks, i was thinking about doing that instead of a permanent one. But im still confused on what to do, Do i update my psp?
     
  19. Alex658

    Alex658 GBAtemp Maniac

    Member
    1,153
    342
    Jun 4, 2010
    Venezuela
    Venezuela
    What version does it have?
    Note that 6.60 and 6.61 have NO DIFFERENCE between each other, game compatibility wise. All 6.61 added was changing the PSN protocols due to the massive hack there was back then. But you lose certain homebrew/plugins when you update to 6.61. So... If it's 6.60 leave it there.
     
  20. SushiKing
    OP

    SushiKing GBAtemp Fan

    Member
    425
    74
    Apr 24, 2013
    Australia
    Nope, it's 6.31 Is there a way to update it to 6.60 or should i just update it as it is then?