RELEASE I heard that you guys need some sweet patches for atmosphere

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by The-4n, Oct 18, 2018.

  1. Manurocker95

    Manurocker95 Game Developer & Pokémon Master

    Member
    5
    May 29, 2016
    Spain
    Madrid
    Dunno why after replacing the files, the nsp that didn't work before, they do now so... thanks buddy.

    Bayonetta and Octopath are working for me.
     
    lordelan likes this.
  2. Eredhel

    Eredhel Member

    Newcomer
    3
    Dec 15, 2015
    Brazil
    Wich sigpatches are you using?
     
  3. Manurocker95

    Manurocker95 Game Developer & Pokémon Master

    Member
    5
    May 29, 2016
    Spain
    Madrid
    the ones you can download here with atmosphere 0.8.1
     
    Eredhel likes this.
  4. Eredhel

    Eredhel Member

    Newcomer
    3
    Dec 15, 2015
    Brazil
    Still no luck here. I was using the 0.8.0 files, updated to 0.8.1 and the software is still unable to start.
     
  5. Manurocker95

    Manurocker95 Game Developer & Pokémon Master

    Member
    5
    May 29, 2016
    Spain
    Madrid
    Try reinstalling the .nsp. It may work.
     
    Eredhel likes this.
  6. Eredhel

    Eredhel Member

    Newcomer
    3
    Dec 15, 2015
    Brazil
    No luck yet =/
     
  7. Manurocker95

    Manurocker95 Game Developer & Pokémon Master

    Member
    5
    May 29, 2016
    Spain
    Madrid
    Hmmm you can always play by layeredFS. At least it's something
     
    Eredhel likes this.
  8. blahblah

    blahblah GBAtemp Advanced Fan

    Member
    6
    May 16, 2018
    United States
    Your copy is a bad XCI conversion. Either download the real eShop NSP or download the NSP and convert using latest conversion software. 6.2.0 doesn't like mangled conversions.
     
    Eredhel likes this.
  9. Lacius

    Lacius GBAtemp Guru

    Member
    15
    May 11, 2008
    United States
    Does anybody have a list of which patches are which?
     
  10. noctis90210

    noctis90210 GBAtemp Advanced Fan

    Member
    4
    Dec 24, 2013
    @rajkosto is the author of es_patches...
    im just curious who is the author of fs_patches and nogc patches?
    is there any link on how they develop it? like github page or other?
    thanks and have a nice day...
     
  11. Eredhel

    Eredhel Member

    Newcomer
    3
    Dec 15, 2015
    Brazil
    @The-4n @blahblah @Manurocker95 Welps, I found the problem... My SD was formatted as ExFat... I reformatted as FAT32, installed everything back and voilá! Every game working as it should be.
    Thank you guys for the help and I hope my issue can solve others with the same problem I had.
     
    Last edited by Eredhel, Dec 5, 2018
  12. Manurocker95

    Manurocker95 Game Developer & Pokémon Master

    Member
    5
    May 29, 2016
    Spain
    Madrid
    Hmmm, what is weird is that the exFat driver should be installed on OFW 6.2 but if that worked, nice :D
     
  13. GDT

    GDT Member

    Newcomer
    3
    Nov 12, 2009
    Italy
    I run into nasty internet validation popup if I launch some games installed from NSP (e.g. Sonic Mania Plus, FIFA 19) both from SX OS and atmosphere (0.8.1). If i run XCI straight from SX OS I got no popup. Other games works well from NSP (e.g. Mario Odissey, Mario Kart...). I'm running fw 6.1.0.

    I converted my XCI to NSP with 4nxci with a key file downloaded from the web. Should I use keys dumped from my own console?
     
  14. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    17
    Aug 6, 2017
    United States
    New York City
    exFAT is not automatically applied on any firmware despite the fact that its supported on all non 1.0 firmwares. Its a completely separate patch from the firmware.
     
  15. blahblah

    blahblah GBAtemp Advanced Fan

    Member
    6
    May 16, 2018
    United States
    Use the latest 4nxci. All key files will be the same; if the app accepts them at all, the file is good.
     
  16. Ericthegreat

    Ericthegreat Not New Member

    Member
    9
    Nov 8, 2008
    United States
    Vana'diel
    Nogc is to prevent the gc slot update I'm pretty sure.
     
  17. Eredhel

    Eredhel Member

    Newcomer
    3
    Dec 15, 2015
    Brazil
    It was all ok with the driver. But ExFAT tend to corrupt some files. By the way, @GDT I was experiencing the same thing and formatting to FAT32 did the trick. You could just reformat to ExFAT and see if it works. Some key files were corrupted and I had to redo everything.
     
  18. CelicaGTS

    CelicaGTS Newbie

    Newcomer
    1
    Dec 6, 2018
    United States
    Im a nub. Do i just copy the es folder to the sd card or the whole folder thing?
     
  19. Shuttleu

    Shuttleu GBAtemp Regular

    Member
    3
    Sep 11, 2010
    I was running ReiNX and decided to switch to Atmosphere, all but 2 of my games run in Atmosphere with these patches, whereas they all run in ReiNX. I'm still on 6.0.1.

    Which "latest conversion software" are you referring to?
     
  20. blahblah

    blahblah GBAtemp Advanced Fan

    Member
    6
    May 16, 2018
    United States
Loading...