RELEASE I heard that you guys need some sweet patches for atmosphere

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by The-4n, Oct 18, 2018.

  1. duckbill007

    duckbill007 Advanced Member

    Newcomer
    4
    May 5, 2011
    Russia
    Small question about FS patches: for previous OFW patches for exfat and fat32 modules were applied to different offsets. For 9.0.0 exfat and fat32 modules patches are EXACTLY the same.

    Is it a mistake or in 9.0.0 exfat and fat32 modules really the same?
     
  2. The-4n
    OP

    The-4n GBAtemp Fan

    Member
    9
    Aug 3, 2018
    United States
    Before 6.0.0, exfat and fat32 patches offsets were the same.
    It changed in 6.0.0 so offsets were different.
    In 9.0.0, It is like pre 6.0.0, offsets are the same.
     
    peteruk, mathew77 and duckbill007 like this.
  3. Tasemu

    Tasemu Advanced Member

    Newcomer
    2
    Jul 9, 2018
    United Kingdom
    I have installed these sigpatches and am on 9.0... But i'm still getting this error when trying to install links awakening. This is so frustrating haha!

    [​IMG]
     
  4. OrGoN3

    OrGoN3 GBAtemp Addict

    Member
    8
    Apr 23, 2007
    United States
    Dumb questions: (1) You are using Goldleaf 0.7.1? And (2) the NSP is valid? The only NSPs for that game are custom from XCI's.
     
  5. Tasemu

    Tasemu Advanced Member

    Newcomer
    2
    Jul 9, 2018
    United Kingdom
    1: Yes I am using 0.7.1 and Quark and everything else I can find :)
    2: I'm not 100% sure, I would imagine so.
     
  6. OrGoN3

    OrGoN3 GBAtemp Addict

    Member
    8
    Apr 23, 2007
    United States
    Another dumb question. You are using fusee-primary to boot and not hekate? Or if you're using hekate, you're chainloading fusee-primary?
     
  7. Tasemu

    Tasemu Advanced Member

    Newcomer
    2
    Jul 9, 2018
    United Kingdom
    I am using Hekate 5.0.2 to boot. I'm not sure what chainloading is, last time I was in the scene was a while back. I just downloaded the latest Kosmos release and chucked it on the sd card and booted with Hekate. :)
     
  8. OrGoN3

    OrGoN3 GBAtemp Addict

    Member
    8
    Apr 23, 2007
    United States
    Okay. The patches in this thread are for when using fusee-primary to boot. If you are using Hekate, you need to use these patches: https://github.com/Joonie86/hekate/releases

    Edit: Also, if you're using Kosmos, make sure you are using the absolute latest version. They had an issue with sigpatches in previous versions.
     
    RAGEstacker likes this.
  9. RAGEstacker

    RAGEstacker Member

    Newcomer
    1
    Sep 17, 2019
    Italy
    Italia
    So if i use this guide in which downloading fusee-primary is not required should i just install hekste pacthes?

    Guide is from nh-server.github


    Forum dont let me post links yet
     
  10. OrGoN3

    OrGoN3 GBAtemp Addict

    Member
    8
    Apr 23, 2007
    United States
    IF you're using hekate to boot, then you need to copy over the hekate patches onto your SD card. It's as simple as that. Patches vary by bootloader.
     
    RAGEstacker likes this.
  11. RAGEstacker

    RAGEstacker Member

    Newcomer
    1
    Sep 17, 2019
    Italy
    Italia
    Ok thank you kind sir
     
    OrGoN3 likes this.
  12. Tasemu

    Tasemu Advanced Member

    Newcomer
    2
    Jul 9, 2018
    United Kingdom
    Thanks for the help, however i'm still getting the same error with the latest hekate sigpatches :/
     
    OrGoN3 likes this.
  13. OrGoN3

    OrGoN3 GBAtemp Addict

    Member
    8
    Apr 23, 2007
    United States
    When upgrading versions of Kosmos, make sure to delete the folders they tell you to. Then apply only the latest sig patches from Joonie. If you downloaded your Kosmos more than 3 days ago, you need to update it.

    Also, make sure to check the NSP. If others are having success from it, ask them to send you an MD5 of their file and compare it to yours. Make sure they are identical.
     
  14. Yung_Shyne

    Yung_Shyne GBAtemp Regular

    Member
    1
    Sep 14, 2019
    United States
    [​IMG]
    ?I am new to this so i dont know anything about kosmos or fusee. Also, instead of using quark, I just transfered nsp files into my sd card. Could somebody help
     
  15. Tasemu

    Tasemu Advanced Member

    Newcomer
    2
    Jul 9, 2018
    United Kingdom
    I have now deleted everything on my SD card except for the Nintendo folder, i have reinstalled the latest Kosmos and sig patches. I have tested sigpatches working by running a preinstalled nsp and it works correctly. I have also installed GoldLeaf 0.7.1. I am still getting the error. I guess it must be the nsp file... I need to try and find an md5. Could you please tell me how i can check the md5 of my nsp to compare?
     
  16. OrGoN3

    OrGoN3 GBAtemp Addict

    Member
    8
    Apr 23, 2007
    United States
    I use QuickHash https://quickhash-gui.org/downloads/.

    Alternatively, install the XCI using https://gbatemp.net/threads/switch-...a-smarter-faster-xci-to-nsp-converter.519930/ or convert the XCI to an NSP yourself using https://github.com/The-4n/4NXCI/releases.
     
    Last edited by OrGoN3, Sep 18, 2019
  17. Tasemu

    Tasemu Advanced Member

    Newcomer
    2
    Jul 9, 2018
    United Kingdom
    OrGoN3 likes this.
  18. OrGoN3

    OrGoN3 GBAtemp Addict

    Member
    8
    Apr 23, 2007
    United States
    No. I only download NSPs that originated from the eShop. I don't bother with converted XCI's. Sorry. And I don't currently use SX OS.
     
  19. Yung_Shyne

    Yung_Shyne GBAtemp Regular

    Member
    1
    Sep 14, 2019
    United States
    any takers?
     
  20. Tasemu

    Tasemu Advanced Member

    Newcomer
    2
    Jul 9, 2018
    United Kingdom
    Are you running a custom firmware? This looks like a nintendo error
     
Quick Reply
Draft saved Draft deleted
Loading...