RELEASE I heard that you guys need some sweet patches for atmosphere

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by The-4n, Oct 18, 2018.

  1. ShoyoJames

    ShoyoJames Newbie

    Newcomer
    1
    Nov 28, 2016
    United States
    How do you install these patches?
     
  2. The-4n
    OP

    The-4n GBAtemp Regular

    Member
    7
    Aug 3, 2018
    United States
    Copy/Paste in sd card
     
  3. CoolerSugar955

    CoolerSugar955 Member

    Newcomer
    3
    Feb 8, 2018
    United States
    What about systems on 1.0 what should they do?
     
  4. The-4n
    OP

    The-4n GBAtemp Regular

    Member
    7
    Aug 3, 2018
    United States
    Update to newer firmwares
     
    Skonikol likes this.
  5. The-4n
    OP

    The-4n GBAtemp Regular

    Member
    7
    Aug 3, 2018
    United States
    Current patches work on 6.2.0
     
    tiliarou, tomGER, hausa51 and 5 others like this.
  6. FightingPolygon

    FightingPolygon Member

    Newcomer
    2
    Jun 8, 2016
    United States
    Awesome!
     
  7. Adran_Marit

    Adran_Marit Walküre's Hacker

    Member
    7
    Oct 3, 2015
    Australia
    42*South
    Nice
     
  8. Eredhel

    Eredhel Member

    Newcomer
    3
    Dec 15, 2015
    Brazil
    Not all. There are still some games that are not working. (Xenoblade, Bayonetta, Octopath). But others are working (Smash, Pokemon, Dragon Ball FighterZ).
     
  9. The-4n
    OP

    The-4n GBAtemp Regular

    Member
    7
    Aug 3, 2018
    United States
    It's clear that FS and ES are not changed, hashes are the same
    However, it's again clear that ninty added some checks in 6.0+, like if you check converted nsps or homebrew nsps for data corruption, they'll be marked as corrupted which is likely due to invalid sig

    I've just received mixed reports, It's kinda strange cause patches are all related to FS and ES and they are not changed in 6.2.0
    Just give it a time so users can test more and report back so I can make sure it's surely related to patches
     
  10. peepoop

    peepoop Advanced Member

    Newcomer
    3
    Jun 29, 2006
    United States
    Looks like Atmosphere 0.8.1 was just released and it now INCLUDES these nogc patches and enables them automatically. Still no native sigpatching though?
     
  11. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    17
    Aug 6, 2017
    United States
    New York City
    Native sigpatching=piracy and ReSwitched=anti=piracy so...
     
    tiliarou and 8BitWonder like this.
  12. noX1609

    noX1609 B9S freak ;)

    Member
    3
    Aug 30, 2016
    Germany
    So did i get it right that with the package of this thread i‘m able to play installed xci and nsp games with the latest Atmosphere? Because i read that it can‘t play games/apps that need a certificate with default Atmosphere because of that you have to use the sigpatches (the ones linked in the first post) right? Just asking to get 100% sure i‘m not doing anything wrong because i used only SX OS by now and want to use Atmosphere until SX OS get‘s updated to support 6.2

    Also is it possible to boot atmosphere out of the SX OS Boot menu so i don‘t have to use a different .bin on my Trinket Chip?
     
  13. hippy dave

    hippy dave BBMB

    Member
    13
    Apr 30, 2012
    United Kingdom
    Right.

    Yes, put fusee-primary.bin on your sd card, and choose it from the sx loader's option to load another payload.
     
  14. smf

    smf GBAtemp Addict

    Member
    8
    Feb 23, 2009
    nsp yes, xci no (unless you convert the xci to nsp)
     
  15. noX1609

    noX1609 B9S freak ;)

    Member
    3
    Aug 30, 2016
    Germany
    Ok thanks then i will use Atmosphere until there are an update to SX OS (hope they release one in the next few days).
    By installing i mean the method with n1dus, it can install xci Games the same way then nsp. I know mounting XCI is only possible with SX OS :)
     
  16. annson24

    annson24 The Patient One

    Member
    6
    May 5, 2016
    Philippines
    I noticed that the latest atmosphere's nogc patches has the same file names as some of the files from the 2.0.0-6.2.0 patches you included in the OP. Wouldn't there be any conflicts with it?
     
    Last edited by annson24, Dec 1, 2018
  17. ccfman2004

    ccfman2004 GBAtemp Addict

    Member
    7
    Mar 5, 2008
    United States
    I'm still having issues installing NSP files. I dumped my copy of Minecraft and converted it to an NSP but I still get an error. I copied the patches to the proper spots on my SD card but still nothing. The funny thing is that the update partition installed no problem without these new patches. I get the error: Failed to open NCM ContentStorage. Error code: 0x0001cfc05.
     
  18. noX1609

    noX1609 B9S freak ;)

    Member
    3
    Aug 30, 2016
    Germany
    @ccfman2004: Did you dump you keys? Because rhey a needed to convert xci files or install xci Files.
     
  19. ccfman2004

    ccfman2004 GBAtemp Addict

    Member
    7
    Mar 5, 2008
    United States
    Yes I did. Turns out that 4nxci messed up somehow. I used xci2nsp and everything installed successfully.
     
  20. The-4n
    OP

    The-4n GBAtemp Regular

    Member
    7
    Aug 3, 2018
    United States
    It means that your keys are messed up, I suggest you to dump them again cause you need them for other apps like hactool :)

    no
     
    Last edited by The-4n, Dec 1, 2018
    annson24 likes this.
Loading...