RELEASE I heard that you guys need some sweet patches for atmosphere

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by The-4n, Oct 18, 2018.

  1. chr0m

    chr0m GBAtemp Fan

    Member
    4
    Oct 9, 2007
    Australia
    I'm not 100% sure which one I installed, but it would have definitely either been the scene release or one I downloaded myself from the CDN.

    I will try reinstalling it and see what happens
     
  2. blahblah

    blahblah GBAtemp Maniac

    Member
    8
    May 16, 2018
    United States
    My copy worked. Possible that the CDN tool you used didn't pack the NSP correctly, included a garbage ticket that newer installers don't like, who knows. I installed a known-good copy and it worked. I used Tinfoil/Nut for USB install.
     
    Last edited by blahblah, Apr 22, 2019
  3. chr0m

    chr0m GBAtemp Fan

    Member
    4
    Oct 9, 2007
    Australia
    Yeah I just reinstalled the scene release of Celeste and an update that I got from CDN and it works now.
     
  4. blahblah

    blahblah GBAtemp Maniac

    Member
    8
    May 16, 2018
    United States
    Yay! :)
     
  5. blahblah

    blahblah GBAtemp Maniac

    Member
    8
    May 16, 2018
    United States
    Okay, so. There is no corruption issue. Be sure to be on the absolute latest version of Atmosphere (the hotfix) and be sure not to use old XCI conversions. Serve up the XCI with Nut and install in Tinfoil DZ or Lithium.

    If you really want to convert the XCI on your computer, use the latest version of 4NXCI.

    Scene releases of Eshop stuff as well as untampered p2p Eshop stuff will work. No issues.

    It’s possible that certain homebrew NSPs (such as the VENOM dlc unlockers) may have issues on 8.X. I haven’t tested them, but I wouldn’t be surprised. But that would not be the fault of Atmo or the sig patches. That is caused by 8.X being stricter with regards to NCA integrity. Just like the old XCI converts issue.

    Same thing repeats over and over. Same 4NXCI issue was a thing with 6.2 and 7.0.0/1. Was fixed long, long ago. That’s why all the ‘corrupting’ games are ancient.
     
    Last edited by blahblah, Apr 22, 2019
  6. GODDUKEMONEXA

    GODDUKEMONEXA Member

    Newcomer
    2
    Mar 11, 2018
    Mexico
    日本 東京

    well... works for me :) no problems yet even can feel faster loading times
     
  7. blahblah

    blahblah GBAtemp Maniac

    Member
    8
    May 16, 2018
    United States
    That version has a bug where certain older games will crash on launch. Update. Grab Atmosphere off their github.
     
    Last edited by blahblah, Apr 22, 2019
  8. GODDUKEMONEXA

    GODDUKEMONEXA Member

    Newcomer
    2
    Mar 11, 2018
    Mexico
    日本 東京

    i did it, already overwrite fixed ams a09c0899 (even no problems with buggy version)
     
  9. DuveltjeDG

    DuveltjeDG Member

    Newcomer
    1
    Apr 5, 2019
    Netherlands
    Did a better test this morning and even now it all works flawlessly. I think some dumps are indeed not accepted by the system. But in regards of that, that is not a bad thing. So far so good.
     
  10. whateverg1012

    whateverg1012 Fringe Weaver

    Member
    6
    Sep 23, 2016
    United States
    VA-11 Hall-A
    To people having issues on 8.0.0, make sure your games are good dumps and you have the ticket installed for CDN dumps. You should not be having any problems with the latest es/fs patches.
     
  11. chr0m

    chr0m GBAtemp Fan

    Member
    4
    Oct 9, 2007
    Australia
    I still had weird behaviour with some games. Battle Chef Brigade didn't work unless I reinstalled both the base and update nsps.

    I was still having issues with Sonic Forces scene release. I reconverted the xci and it still got the corruption issue. Reinstalled an update from CDN and it started booting and then died with corruption issue.

    Deleted the whole game and reinstalled both again and now it seems to be working. Going to have to go through all 400 GB of my installed games :)

    Also had a bunch of those Arcade Archive games installed and none of them worked. I had to reinstall them all and now they work. They were all scene releases.

    Something weird going on still. It's possible that the eshop titles I'm having issues with were installed with sxos a while ago and sxos did something stupid with them

    It's probably related to this issue that was fixed in SXOS beta 2.5.1:
    "Fixed false positive ‘corrupted’ message for installer The Switch software management menu has an option for verifying the integrity of installed titles. When using this functionality with titles that have been installed through our NSP installer you would always get a message saying the title data is corrupt. This was mostly a false positive as the installed titles worked fine.. but we’ve hunted down the root cause of this and fixed this cosmetic shortcoming for all new installs!"

    Maybe 8.0 actually prevents the game from loading if it detects that the game has corrupt data
     
    Last edited by chr0m, Apr 22, 2019
  12. KTroopA

    KTroopA GBAtemp Advanced Fan

    Member
    5
    Mar 15, 2007
    Im about to update to ams 8.0 and wanted to ask about tickets. Ive always used goldleaf to install and remove nsps. Never touched the ticket menu for fear of removing the wrong one and bricking the switch. This was a thing on wii u. How do you tell which tickets are safe to remove, and do you even need to bother if just adding snd removing nsps as mentioned?
     
  13. toxic9

    toxic9 GBAtemp Regular

    Member
    3
    Dec 13, 2016
    there are much less patches in number on 8.0 vs 7.0.1 patches.
    or should we merge the two zips? (7.0.1 patches + 8.0 patches)
     
  14. DuveltjeDG

    DuveltjeDG Member

    Newcomer
    1
    Apr 5, 2019
    Netherlands
    Merge them together to make a complete package.
     
  15. stick267

    stick267 GBAtemp Fan

    Member
    4
    Dec 17, 2018
    United States
    Do any games explicitly need 8.0? Why not just downgrade to 7.0.1 with ChoidujourNX since it shares the same fuse count as 8.0 and doesn't have all of these issues with installed games.
     
  16. Dave_Chad

    Dave_Chad GBAtemp Advanced Fan

    Member
    6
    Jun 29, 2016
    Someone did post a complete set a few pages back...
     
  17. chr0m

    chr0m GBAtemp Fan

    Member
    4
    Oct 9, 2007
    Australia
    I only have issues with 2 types of games:
    • nsp that were created with an old 4nxci
    • nsp that were installed with older sxos
    If I reinstall then everything works.
     
    naddel81 likes this.
  18. Lacius

    Lacius GBAtemp Guru

    Member
    16
    May 11, 2008
    United States
    Some day in the future, games will require something higher than 7.0.x, so by downgrading, you're just putting off the issue.
     
  19. blahblah

    blahblah GBAtemp Maniac

    Member
    8
    May 16, 2018
    United States
    I am not seeing what you describe with the raw Eshop dump of Sonic Forces. Will try with the scene release. Were you using the US scene release or the EUR scene release?

    8.0 does not do what you describe. Titles installed through non-awful title installers are not automatically marked as bad. 8.0 rejects actually bad installs. SX's built in installer is awful, so that explains why you were having issues with some stuff that you installed before.
     
    Last edited by blahblah, Apr 22, 2019
  20. stick267

    stick267 GBAtemp Fan

    Member
    4
    Dec 17, 2018
    United States
    True, but by that time it's likely that most of these bugs will be ironed out. No harm in reverting back to 7.0.1 in the short term.
     
Loading...