RELEASE I heard that you guys need some sweet patches for atmosphere

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by The-4n, Oct 18, 2018.

  1. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    Game updates don't appear to be the problem.
     
  2. JJTapia19

    JJTapia19 I fight for my friends.

    Member
    10
    May 31, 2015
    Puerto Rico
    Do you have the latest silent update of atmosphere that released some hours ago?
     
  3. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    Yes, I do.
     
  4. JJTapia19

    JJTapia19 I fight for my friends.

    Member
    10
    May 31, 2015
    Puerto Rico
    For the goldleaf usb installation issue I suggest you use the nsp version instead of the nro. I'm also having problems with the nro usb installs and I'm on 7.0.1. the nsp version works but crashes when exiting via home. Not sure about the other problem.
     
  5. Hayato213

    Hayato213 GBAtemp Guru

    Member
    12
    Dec 26, 2015
    United States
    8.0.0 has some issue corrupting games data, until there is a better ES and FS patches, you just gonna have to dele
    Look the same as the one that was distributed here already.
     
  6. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    I already tried that, and nothing changed.
     
  7. blahblah

    blahblah GBAtemp Maniac

    Member
    8
    May 16, 2018
    United States
    Can someone give me a reliable way to reproduce this "corruption issue"? I've been trying most of the day with no luck. If someone can help me reproduce the issue I can work on solving the cause.
     
  8. Hayato213

    Hayato213 GBAtemp Guru

    Member
    12
    Dec 26, 2015
    United States
    @blahblah It is kinda random, but I think you need to use the initial atmosphere 0.88 release to replicate the problem, it involve games that was converted from XCI to NSP. Might to do with the hot fix today releases by SciresM. Games first fail to launch then they started corrupting.
     
    Last edited by Hayato213, Apr 22, 2019
  9. blahblah

    blahblah GBAtemp Maniac

    Member
    8
    May 16, 2018
    United States
    I can see it being possible for a user to launch a game with broken 0.88, the application to immediately die (due to the bug) and for the Switch to mark that installed application as corrupt & require a scan. That's totally valid, possible.

    What doesn't make sense is for someone to install an application on fixed 0.88 (using Dev Menu or Tinfoil DZ, I can't really support other installers) and have the application work for a while and eventually corrupt. That I do not understand.
     
    Hayato213 likes this.
  10. designgears

    designgears GBAtemp Regular

    Member
    4
    Aug 8, 2016
    United States
    He downloaded it from this thread and packed it with a broken version of atmos. very trusted.
     
    blahblah, DarknessPlay3r and Lacius like this.
  11. chr0m

    chr0m GBAtemp Fan

    Member
    4
    Oct 9, 2007
    Australia
    I only got it once so far. I had Mario Tennis Access installed (xci to nsp) and then I installed the 3.0 update while running previous Atmosphere 0.8.8 (87f7a6eb). When I tried to launch it gave the corruption error. I reconverted the xci to nsp and reinstalled it and it started working again.
     
  12. blahblah

    blahblah GBAtemp Maniac

    Member
    8
    May 16, 2018
    United States
    The other person that messaged me about this also was using an XCI to NSP conversion that was bad. I was able to reproduce their issue using the copy they used but solved it by using an actual eShop dump. I suspect I could also fix the issue by installing the cartridge using Tinfoil.
     
    Last edited by blahblah, Apr 22, 2019
  13. chr0m

    chr0m GBAtemp Fan

    Member
    4
    Oct 9, 2007
    Australia
    The only difference was that I used the latest version of 4nxci for the reconversion. The original one that got corrupt would have been converted using an older one. I don't know if it was already corrupted or if installing the 3.0 update.
     
  14. blahblah

    blahblah GBAtemp Maniac

    Member
    8
    May 16, 2018
    United States
    Yup, early versions of 4NXCI didn't produce entirely valid output, and newer Switch firmware not liking very old 4NXCI conversions has been a long running thing.

    — Posts automatically merged - Please don't double post! —

    Going to install the other two games that someone mentioned as being problematic - Ultra SF2 and Sonic Forces. If I can't reproduce the issue with valid copies of those games, I am going to go to sleep and check back in the morning.
     
  15. chr0m

    chr0m GBAtemp Fan

    Member
    4
    Oct 9, 2007
    Australia

    Ok cool, let me know if you want me to test anything. I will test those 2 games.

    I also have been going through all my xci to nsp installs and found that Bayonetta doesn't work now. It was working on 7.01. Reconverting with 4nxci again now.

    Just tested Sonic Forces and that doesn't work either. Will reconvert that as well
     
    Last edited by chr0m, Apr 22, 2019
    ModderFokker619 likes this.
  16. blahblah

    blahblah GBAtemp Maniac

    Member
    8
    May 16, 2018
    United States
    Ultra Street Fighter (real eShop dump) and Sonic Forces (same) work fine. Installed both without their update, they worked, installed the updates, still work. I went in game in both, saved, quit, save loaded fine.

    The problem people seem to be having is that newer OFW dislikes bad 4NXCI conversions, made with early versions of the app. Just serve up the real XCI using Nut or convert using the latest version of 4NXCI.
     
  17. chr0m

    chr0m GBAtemp Fan

    Member
    4
    Oct 9, 2007
    Australia
    Yep I agree. I've tested a few now and all those ones that didn't work are older xci to nsp conversions. Now I have to reconvert and install them all :)

    Actually, not true. I just tried Celeste and that didn't work either and that was an eshop nsp. Hmmmm
     
    Last edited by chr0m, Apr 22, 2019
  18. blahblah

    blahblah GBAtemp Maniac

    Member
    8
    May 16, 2018
    United States
    :D Glad we figured this one out.

    — Posts automatically merged - Please don't double post! —

    How sure are you that your Celeste copy is from the eShop and was not tampered with to make it work on an old firmware? What's the SHA256?

    I'm installing a known-good, 100% valid copy now. Will edit this post to report back.

    EDIT: Known good copy works fine. Base game works, update works.

    Everything I am installing, by the way, I am installing using Tinfoil and Nut to USB install.
     
    Last edited by blahblah, Apr 22, 2019
  19. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    @blahblah and I were talking over PM, and my issue was also a really old/bad XCI conversion.
     
  20. ModderFokker619

    ModderFokker619 GBAtemp Advanced Fan

    Member
    6
    Oct 2, 2015
    United States
    California

    Reconverting sonic, USF II, Mario tennis now.
     
Quick Reply
Draft saved Draft deleted
Loading...