1. Overwhelming

    OP Overwhelming GBAtemp Fan
    Member

    Joined:
    Dec 13, 2003
    Messages:
    350
    Country:
    For my dismay, I can't play the 3rd birthday nor FFIV CC. So I guess it's time to upgrade my PSP. So, I would like to ask you the following:

    1 - Do I really need to upgrade my PSP?
    2 - Is there a way to fix the ISOs, so I can play them in my current version?
    3 - If I need to upgrade, what would you recommend me? I would prefer one that wouldn't require me to hack it each time I reboot it...

    Thank you for you time. [​IMG]
     
  2. Schlupi

    Schlupi Gbatemp's Official Earthbound Maniac™
    Member

    Joined:
    Aug 31, 2007
    Messages:
    3,985
    Country:
    United States
    You can just patch (or download prepatched versions of) your isos you want working.

    Alternatively, just update to 6.20 TN-D (and perma patch it) if you want a "Lite-CFW" that is "Permanent", or update to 6.35 PRO-B3 (temporary CFW, need to reenable after every full shut down).

    It's your call. updating will make new releases work but it will make you lose a lot of PSX Pops compatibility.
     
  3. emigre

    emigre Recovering weeaboo
    Member

    Joined:
    Jan 28, 2009
    Messages:
    8,265
    Country:
    United Kingdom
    - (Fully hackable) 100X/200X -
    - PC -
    1. Download XGEN GEN D3 Updater. Place UPDATE in PSP/GAME and 550.PBP on the root of your memory stick
    2. Download Prometheus-4 5.50 GEN-D Addon and place the Prometheus folder in PSP/GAME

    - PSP -
    1. Run and update to GEN D3 (Be careful what you press on, there is also an option that upgrades to OFW 5.50 and we don't want that!)
    2. Run and update to Prometheus-4 and you're done!

    From Prowler's sticky.
     
  4. Schlupi

    Schlupi Gbatemp's Official Earthbound Maniac™
    Member

    Joined:
    Aug 31, 2007
    Messages:
    3,985
    Country:
    United States
    Oh fuck me. I forgot about Prome-4. >_>

    Looks like having a PSP Go made me forget about the proper way of 1000s.

    DO WHAT HE SAID.
     
  5. Overwhelming

    OP Overwhelming GBAtemp Fan
    Member

    Joined:
    Dec 13, 2003
    Messages:
    350
    Country:
    Thanks, somehow I missed that, as I've looked the 5.50 - 6.20 section only.

    I guess that I will only have to follow steps 2, as my PSP is already hacked to 5.50 Gen D3, right?
     
  6. emigre

    emigre Recovering weeaboo
    Member

    Joined:
    Jan 28, 2009
    Messages:
    8,265
    Country:
    United Kingdom
    Yeah, it sound slike you just need ot update to Prome-4, which perfectly from my experience.
     
  7. Overwhelming

    OP Overwhelming GBAtemp Fan
    Member

    Joined:
    Dec 13, 2003
    Messages:
    350
    Country:
    Thank you all. I've installed Prometheus 4 and FFIV is running fine, I guess I was successful. Thanks again. [​IMG]
     
Draft saved Draft deleted