I can't manage to let haxchi boot mocha.

Discussion in 'Wii U - Hacking & Backup Loaders' started by Jhnsn, Dec 15, 2016.

  1. Jhnsn
    OP

    Jhnsn *Flat is Justice*

    Member
    236
    113
    Sep 1, 2016
    Australia
    Yeah so, I tried to edit the config.txt from haxchi (newest version, no cbhc) and everytime I launch haxchi it gets to "Wii U Menu" then it freezes (or something like that, music is still playing in the background).

    Here's my config.txt and a screenshot of my sd:

    a=wiiu/apps/homebrew_launcher/homebrew_launcher.elf
    default=wiiu/apps/mocha/mocha.elf

    screen.PNG

    Is mocha not compatible with haxchi or am I just too stupid?

    Edit: Pressing a to boot HBL does the same.
    Edit: Default config.txt works flawlessly.
     
    Last edited by Jhnsn, Dec 15, 2016
  2. DarkGabbz

    DarkGabbz Resident XBOX Guy

    Member
    1,122
    648
    Dec 29, 2015
    Micronesia, Federated States of
    Modding Xbox'es
    Delete the config file and try again to boot mocha.
     
  3. Jhnsn
    OP

    Jhnsn *Flat is Justice*

    Member
    236
    113
    Sep 1, 2016
    Australia
    Now it beeps at a black screen when I launch haxchi.
     
  4. lembi2001

    lembi2001 GBAtemp Regular

    Member
    211
    165
    Dec 29, 2015
    Is that the correct extension for the config file? People keep talking about config.txt but your file looks like it's config.ini or config.cfg
     
  5. eroz76

    eroz76 GBAtemp Regular

    Member
    238
    55
    Feb 13, 2015
    United States
    Chicago
    What app did you use to edit your config.txt?
     
  6. Jhnsn
    OP

    Jhnsn *Flat is Justice*

    Member
    236
    113
    Sep 1, 2016
    Australia
    It's a config.txt.
    Notepad.
     
  7. lembi2001

    lembi2001 GBAtemp Regular

    Member
    211
    165
    Dec 29, 2015
    Not convinced. Can you enable file extenions and then take another screenshot or upload the file with your next post?
     
  8. Jhnsn
    OP

    Jhnsn *Flat is Justice*

    Member
    236
    113
    Sep 1, 2016
    Australia
    Wait you don't trust me? :c
    Here.
     

    Attached Files:

  9. lembi2001

    lembi2001 GBAtemp Regular

    Member
    211
    165
    Dec 29, 2015
    it wasn't that. the icon you have for the text file looks like an ini/cfg file and the file type in the screenshot shows it as a configuration file thats all
     
  10. Jhnsn
    OP

    Jhnsn *Flat is Justice*

    Member
    236
    113
    Sep 1, 2016
    Australia
    That's the mocha config
     
  11. lembi2001

    lembi2001 GBAtemp Regular

    Member
    211
    165
    Dec 29, 2015
    Apologies, long week!!

    I shall hide in the corner again now....
     
  12. eroz76

    eroz76 GBAtemp Regular

    Member
    238
    55
    Feb 13, 2015
    United States
    Chicago
    That might be the problem. Use Notepad++ instead.
     
  13. Jhnsn
    OP

    Jhnsn *Flat is Justice*

    Member
    236
    113
    Sep 1, 2016
    Australia
    After uninstalling und reinstalling haxchi it finally works like a charm! Don't know why it didn't work before. Now mocha boots when launching haxchi! Really nice.
     
  14. Reecey

    Reecey Mario 64 (favorite game of all time)

    Member
    4,260
    1,105
    Mar 7, 2010
    At Home :)
    You dont need mocha as>default=wiiu/apps/mocha/mocha.elf in your config.txt file thats not necessary that was your problem, Mocha boots from wiiu/apps/mocha/mocha.elf there's no need to put it on your sd route also it doesn't need to be on your config file either, it will boot asap from whatever you set in your mocha menu and press A. If you change your original config.txt again to your configuration you want but this time leave out the mocha default line and change it too say homebrew_launcher.elf instead you will be ok.
     
    Last edited by Reecey, Dec 16, 2016