I can't get Dolphin to run all that well on my Core i7 PC.

Discussion in 'Wii - Emulation and Homebrew' started by retrospect, Nov 16, 2014.

  1. retrospect
    OP

    retrospect GBAtemp Regular

    Member
    283
    53
    May 17, 2008
    My rig has a Core i7 920 @ 2.6GHz and an ATi HD 4800 2GB with Windows 7 x64. The machine isn't bang up to date, but it's not half bad either and I'm surprised by the following:

    Smash Bros Melee has glitchy audio and slows down during hectic fights and at the countdown to a fight.
    Metroid Prime Trilogy is a fuzzy video-mess, like you might expect if you had no TV antenna and had tuned into Hypnotoad. I've read that this used to be a problematic disc but that all the problems were fixed.

    I've tried the latest versions of Dolphin 4.0, 3.5 and 3.0 (x86 and x64) and set up the options according to popular opinion from YouTube and Emulator forums.

    Can anyone offer any insight? It doesn't seem to make any difference if I crank Internal Resolution up to maximum, or keep it on minimum. Melee plays exactly the same with either setting. It seems like if this was due to underpowered hardware, changing this setting should make a difference. I've tried 3 Melee ROMs from the internet (EU and US) since I don't have the right DVD drive to rip my actual disc.

    Who can help out?
    Cheers
     
  2. Zaide

    Zaide GBAtemp Regular

    Member
    296
    120
    Apr 2, 2009
    United States
    I had issues at first as well. My problem was that my laptop has two graphics cards (NVIDIA GTX 860M and Intel HD Graphics 4600). The idea is you can use the crappy intel one to save power.

    Anyway, my issue was that dolphin was only detecting the Intel card. I had to go to my NVIDIA control panel and change the settings for dolphin.exe to force it to use the NVIDIA card instead.

    Since you have an ATI I can't tell you exactly how to do that. But you can probably find information on google for your card.
     
  3. retrospect
    OP

    retrospect GBAtemp Regular

    Member
    283
    53
    May 17, 2008
    I'm not doing so well on this. The computer I described above is my desktop, which has only dedicated ATi graphics. I also tried on my laptop, which has NVIDIA graphcis and Intel HD 4XXX. Dolphin performs poorly on both machines when playing Smash Bros Melee.

    And Metroid Prime Trilogy still doesn't do much at all. I feel if these were common problems then the internet would be full of discussion about them, so I suspect both games should run fine.

    Can anyone offer any more ideas? What version of Dolphin works well for these games? Can anyone share their settings?

    Thanks
     
  4. sarkwalvein

    sarkwalvein More coffee, please!

    Member
    GBAtemp Patron
    sarkwalvein is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    5,423
    5,845
    Jun 29, 2007
    Germany
    Niedersachsen
    Hi. My notebook is way worse than your desktop regarding specs and it runs Melee quite fine.
    I have a Corei5 2450M@3GHz with an NVIDIA GT630M.
    Perhaps I can give you my settings and Dolphin version, but I think they are quite standard.

    PS: Some time ago dolphin ran like shit in this PC, and the reason was that the CPU overheated and automatically underclocked itself, a good clean to the cooler and heatsink (that were blocked by dust) made it work like a charm.

    Dolphin version: 4.0-3547
    Settings (quite standard):
    Warning: Spoilers inside!
     
  5. retrospect
    OP

    retrospect GBAtemp Regular

    Member
    283
    53
    May 17, 2008
    Thanks man, I'll try these out tonight!
     
  6. retrospect
    OP

    retrospect GBAtemp Regular

    Member
    283
    53
    May 17, 2008
    Using 4.0-3547 made a significant difference to Smash Bros. Melee right away. During a 4 player game there is still occasional slowdown. I typically get between 30 and 50 FPS now during a match.

    The "Ready..." screen before each Vs match still runs very badly, with bad audio and just a few frames per second. Is this normal?
     
  7. sarkwalvein

    sarkwalvein More coffee, please!

    Member
    GBAtemp Patron
    sarkwalvein is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    5,423
    5,845
    Jun 29, 2007
    Germany
    Niedersachsen
    Sorry, I just noticed your reply.
    I think the "Ready" screen in Melee usually stutters in my PC also, but I am not sure. I will check later and let you know.
     
  8. sarkwalvein

    sarkwalvein More coffee, please!

    Member
    GBAtemp Patron
    sarkwalvein is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    5,423
    5,845
    Jun 29, 2007
    Germany
    Niedersachsen

    Just checked.
    The ready screens stutters but it is less than half a second, just for a brief moment.
    Also, even with 4 players, I have mostly 58-60 FPS. (Melee USA version)

    PS: If you use an European version of Melee it is normal for it to go at 50FPS maximum, I suppose.
     
  9. retrospect
    OP

    retrospect GBAtemp Regular

    Member
    283
    53
    May 17, 2008
    It's quite a lot of stuttering on mine on the Ready screen, and there is the occasional stutter during play - roughly every 20 seconds. With the US version it does run between 50 and 60 fps.
    Can I tell it to render at 30fps and to prioritise smooth gameplay instead?

    Some good news is that Metroid Prime Trilogy seems to be working fine now :)
     
  10. sarkwalvein

    sarkwalvein More coffee, please!

    Member
    GBAtemp Patron
    sarkwalvein is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    5,423
    5,845
    Jun 29, 2007
    Germany
    Niedersachsen
    I think there is no frame skip option, so you cannot make it run at smooth 30fps.
    Try using the European version that renders at 50fps and disable VSync.
    Disable it in the OpenGL graphics configuration, and also try disabling it in your ATI driver. The drop from 50fps to 30fps you describe is typical of VSync problems.
    Also try using Dirct3D 11 instead of OpenGL. The OpenGL plugin works way better on NVIDIA cards.