I also got "Exception (DSI) occurred!" ... when starting Wiiflow ... so annoying

Discussion in 'Wii - Hacking' started by hama364, May 2, 2016.

  1. hama364
    OP

    hama364 Member

    Newcomer
    36
    0
    Sep 18, 2014
    Senegal
    Hi all, need expert help...

    I got the dreaded "Exception (DSI) occurred!" with stack/ code dump and auto-reload which prevents Wiiflow from starting. I did some research and found many different hints what to do. Now I'm not sure which one(s) to try. Please give me some good direction if you know better...

    What I did:
    1. fresh install of HBC (on white Wii with 4.3E) > OK, no errors
    2. install BootMii as IOS > OK, no errors
    3. make NAND backup with BootMii> OK, no errors
    4. install cIOS exactly as this https://sites.google.com/site/completesg/backup-launchers/installation (online install, soo all file should be correct and latest) > OK, no errors
    5. prepare SD 16GB card (SDHC as I did not have a big SD card, FAT32) with Wiiflow (https://sites.google.com/site/completesg/backup-launchers/usb/wiiflow) also overwrite files with boot_r1076 (as suggested) > OK, no errors
    6. put 3 games on the SDHC card with WiiBackupManager_Build78 > OK, no errors
    7. start Wiiflow from HBC: all 3 games are there, I can select them and music starts and small title is shown

    BUT
    A. can't download covers as it gives in internet connection error and
    B. when I select the game and click "start game" the screen goes dark and after 10 sec the Wii system menu starts

    8. did some research to fix this and found recommendation to go to Wiiflow settings and set start from 'auto' to cIOS 249. I tried that but same problem as above, also tried cIOS 250, didn't help either. Tried both setting in Wiiflow general settings and also the game settings.
    9. then I tried another setting in Wiiflow (the one above start settings = cIOS 249) something like "force cIOS" = on > THAT WAS A MISTAKE... afterwards I got the "Exception (DSI) occurred!"...
    no way to start Wiiflow any more and change any settings back...

    to try and fix "Exception (DSI) occurred!"
    10. I did a freshly unzipped Wiiflow on the SDHC card > didn't help, still "Exception (DSI) occurred!"
    11. installed again cIOS (https://sites.google.com/site/completesg/backup-launchers/installation) online > didn't help, still "Exception (DSI) occurred!"

    Now I'm not sure what to do next. Start with new HBC install, restore NAND, new Bootmi install...?

    I'm grateful for any help, thanks in advance...
    IMG_20160502_231312s.jpg
     
    Last edited by hama364, May 2, 2016
  2. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,108
    5,178
    Mar 17, 2010
    Norway
    Alola
    I'm not sure why that guide suggests installing both beta53 and beta52. You should replace cIOS 249 base 56 v10 beta53-alt with the beta52 version, it has better compatibility. Beta53 is only needed/recommended if you for some reason want to use the top rear USB port for USB loading, beta52 only loads from the bottom one.
    It might have nothing to do with your problem but it's best to have consistent cIOS installs.
    Also, try another USB loader such as USB Loader GX and see if the same problem occurs.
     
  3. hama364
    OP

    hama364 Member

    Newcomer
    36
    0
    Sep 18, 2014
    Senegal
    can I just install another cIOS over an existing version or do I have to un-install/ remove the previous version first?
    And how about he same thing for HBC, Bootmi?
     
  4. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    4,020
    776
    Mar 2, 2015
    United States
    Everything on Google Code is out of date as it is now shut down. This is the latest repository for WiiFlow mod. There are no binary releases there so you'll either have to compile it yourself or get r1076 from FIX94's Mediafire folder here.

    If use that WiiFlow Start Configurator app in the folder you can enable the "force CIOS" option and set it to 249 to avoid the DSI at startup.
     
  5. hama364
    OP

    hama364 Member

    Newcomer
    36
    0
    Sep 18, 2014
    Senegal
    Ok, thanks for the hints. I will try as soon as possible...
    Can you point me to some site where I can learn about cIOS (the different builds, functions, configuration, etc)?
    I have tried to find more in depth information but wasn't successful so far.
     
  6. hama364
    OP

    hama364 Member

    Newcomer
    36
    0
    Sep 18, 2014
    Senegal
    Was just reading again your advice (1st part). Did I not do that in my step 5.? I downloaded r1076 (boot_r1076.7z, 1.73 MB, 2014-09-17) from here and overwrite (extract over) the old Wiiflow (v4.2.1 Jan 1, 2014) from here. As it asks to do here.
     
  7. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    4,020
    776
    Mar 2, 2015
    United States
    No, that's right. WiiFlow gets an exception if it has issues accessing drives when it starts up, though. If you use that start configuration app you can set it to use a CIOS and it shouldn't crash. Unlike other loaders WiiFlow uses a save game to store that info and the extra app can change it without running the loader.
     
  8. willow34

    willow34 Newbie

    Newcomer
    2
    2
    Jan 29, 2017
    United States

    I ran into this same issue. Unfortunately (for me at least) the "configuration app" was also throwing an"exception (DSI) occured" error. After thinking about what @GreyWolf last said though, I remembered that there is save data for WiiFlow that can be deleted in the Wii system menu.

    Wii System menu > Data management > Wii > WiiFlow

    Anyway, this is an old question, but for anyone else who runs into this you shouldn't have to reinstall or download everything again. Just delete the WiiFlow save data and restart the Wii. There might be a chance where you hav to reinstall wiiflow, but most likely this will work without doing that. I didn't realize this worked at first because when I initially stared wiiflow after doing this I had a black screen for about 7-10 minutes and then finally it worked. After that it started loading fine again. So just be patient after deleting the save data and give it a chance to load.

    If that doesn't work try reinstalling WiiFlow and deleting the data again and restarting the device, but I would do that last. You shouldn't have to reinstall or install anything else if your using Wiiflow Masterpiece Mod 4.2.3 working with the CIOS from step 4. However, the other suggestions above could possibly help the wifi and other issues if you're having them.
     
    shyre and Nigleet like this.
  9. shyre

    shyre Newbie

    Newcomer
    1
    0
    Wednesday
    United States
    YOU ARE A GENIUS! I have been trying to figure this out for 2 days and researching. I've uninstalled and reinstalled and NOTHING. I read this and try it and it worked! Thank you so much!