How to use Homebrew laucher rpx version

TonyGgse Jun 26, 2019.

  1. TonyGgse
    OP

    TonyGgse Member

    Newcomer
    1
    Jun 10, 2019
    China
    rpx v2.1
     
  2. BaamAlex

    BaamAlex (*(vu64 *)0x1FF81100)

    Member
    6
    Jul 23, 2018
    Germany
    With the browser exploit?!
     
  3. TonyGgse
    OP

    TonyGgse Member

    Newcomer
    1
    Jun 10, 2019
    China
    Yeah, or any other methods
     
  4. BaamAlex

    BaamAlex (*(vu64 *)0x1FF81100)

    Member
    6
    Jul 23, 2018
    Germany
    No. You need an Entrypoint to start it. And if Haxchi, or even CBHC is installed on your console, it works without a browser exploit.
     
  5. TonyGgse
    OP

    TonyGgse Member

    Newcomer
    1
    Jun 10, 2019
    China
    AFAIK, Haxchi ONLY LOADS THE .ELF VERSION OF THE HOMBEBREW LAUNCHER which as of right now is v1.4...
    And browser exploit indeed only cannot work with v2.1 rpx?
     
  6. BaamAlex

    BaamAlex (*(vu64 *)0x1FF81100)

    Member
    6
    Jul 23, 2018
    Germany
    Why not the 2.1 version? I would say...try it. Here is the latest version.
     
  7. TonyGgse
    OP

    TonyGgse Member

    Newcomer
    1
    Jun 10, 2019
    China
    From fix94/haxchi page on github, it says this: This also ONLY LOADS THE .ELF VERSION OF THE HOMBEBREW LAUNCHER which as of right now is v1.4 so make sure to keep that on your sd card or you will just get error -5 when starting your haxchi channel.
     
  8. BaamAlex

    BaamAlex (*(vu64 *)0x1FF81100)

    Member
    6
    Jul 23, 2018
    Germany
    Otherwise install the channel directly? Then it should work defintely
     
  9. TonyGgse
    OP

    TonyGgse Member

    Newcomer
    1
    Jun 10, 2019
    China
    I know we can use channel version definitely, but I want to know in which circumstance we can use the rpx version?
     
  10. BaamAlex

    BaamAlex (*(vu64 *)0x1FF81100)

    Member
    6
    Jul 23, 2018
    Germany
    Use haxchi. Idk why the 2.1 shouldn't work with it. Have you ever tried it?
     
  11. TonyGgse
    OP

    TonyGgse Member

    Newcomer
    1
    Jun 10, 2019
    China
    I've tried just now, using rpx version of homebrew launcher, I got error -5 of black screen.
     
  12. CreeperMario

    CreeperMario GBAtemp Advanced Fan

    Member
    5
    Jun 18, 2016
    Australia
    Adelaide, South Australia
    Version 2.1 of the Homebrew Launcher only really works when it is installed as a "channel" on your console. If you want to use Haxchi or the web browser to open the Homebrew Launcher directly, you need to use v1.4, which is an ELF file that you store on your SD card.

    Prior to using v2.1, you need to launch a custom firmware that prevents signature checking (examples include Mocha and Haxchi's built-in custom firmware).

    There have been issues reported with v2.1 and how it launches ELF software, and so I would recommend sticking with v1.4 for now.
     
Quick Reply
Draft saved Draft deleted
Loading...