How to update sysnand from 6.x to 7.x (Have access to a gateway temporarily)

Discussion in '3DS - Flashcards & Custom Firmwares' started by apoptygma, Apr 8, 2015.

  1. apoptygma
    OP

    apoptygma GBAtemp Advanced Fan

    Member
    689
    145
    Mar 30, 2010
    I'm running 6.x and need to update to a 7.x firmware in order to have access to the encryption used in smash (have the clean CIA on the sysnand)
    Can I do that update with a rom from the gateway?
     


  2. michyprima

    michyprima GBAtemp Regular

    Member
    219
    114
    Feb 19, 2014
    Italy
    No. don't, or you will brick.
    get a real cartridge or a sky
     
  3. apoptygma
    OP

    apoptygma GBAtemp Advanced Fan

    Member
    689
    145
    Mar 30, 2010
    Yea that's what I was afraid of. I have seen guides on how to update emunand with a gw rom but I'm not using emunand on this console. Damn, I'll try find a legit cart then.
     
  4. apoptygma
    OP

    apoptygma GBAtemp Advanced Fan

    Member
    689
    145
    Mar 30, 2010
    So it looks like a copy of ORAS or Smash is what I need, just pop it in and update with the wifi turned off and I'm all good yea?
     
  5. michyprima

    michyprima GBAtemp Regular

    Member
    219
    114
    Feb 19, 2014
    Italy
    yeah!
     
  6. Loaffy

    Loaffy GBAtemp Regular

    Member
    136
    45
    Mar 27, 2015
    Canada
    I'm pretty certain you can update with ROMs on gateway, considering gateway has a built in update method (something like holding up on the d-pad when booting into gw mode or selecting the game, I don't own gw myself so can't quite remember). I've also read tons of posts about people using roms to update with gw, so...

    You could also update by downloading the .cias for the update version you want with 3DNUS and then installing those .cias with BigBlueMenu.3DS which GW can launch. This method would allow you to update to any version you wanted. But I think using a rom would be easier - just look for some posts about updating with gw roms (use google or gbatemp's search) to be sure you do things right.
     
  7. michyprima

    michyprima GBAtemp Regular

    Member
    219
    114
    Feb 19, 2014
    Italy
    you really want him to brick don't you?
    both methods you suggested would brick.

    I know you want to help, but it's not a good idea to give advices without research first.
     
  8. VerseHell

    VerseHell GBAtemp Psycho!

    Member
    3,067
    1,067
    Jun 29, 2014
    France
    Downgrade to 4.5,then you can upgrade with a rom, but only with an old launcher.dat like 2.2, never do that with 2.3+ launcher.dat.

    Edit : if it's not a 2ds ofc.
     
  9. Loaffy

    Loaffy GBAtemp Regular

    Member
    136
    45
    Mar 27, 2015
    Canada
    Can you explain why either of those methods would cause a brick? Is it only because he's going from 6.x to 7.x?

    Can you not upgrade sysnand while in gw mode? If not, that's kind of lame.

    edit: I guess apparently gw mode can only update sysnand below 6.x? I'm sorry then, this seems like a really lacking feature.
     
  10. apoptygma
    OP

    apoptygma GBAtemp Advanced Fan

    Member
    689
    145
    Mar 30, 2010
    That sounds like a brick waiting to happen, Can you even use an old launcher on a gateway that's been updated to 3.x?
     
  11. VerseHell

    VerseHell GBAtemp Psycho!

    Member
    3,067
    1,067
    Jun 29, 2014
    France
    Because updating sysnand while in gateway mode brick it with the news launcher.dat.
     
  12. apoptygma
    OP

    apoptygma GBAtemp Advanced Fan

    Member
    689
    145
    Mar 30, 2010
    Gateway's support of 7.x has always been a hack because it doesn't use the correct encryption. I think it was originally to maintain backward compatibility with older saves or something.
     
  13. michyprima

    michyprima GBAtemp Regular

    Member
    219
    114
    Feb 19, 2014
    Italy
    Cias upgrade work only if you are updating to a version using the same FIRM. this means no big jumps.

    new gw launchers bricks if you update with a cart on sysnand. the reason seems they patch FIRM on install.
     
  14. VerseHell

    VerseHell GBAtemp Psycho!

    Member
    3,067
    1,067
    Jun 29, 2014
    France
    Yes, just force the fgpa "update" by holding the R button instead of the L one.
     
  15. bache

    bache GBAtemp Advanced Fan

    Member
    694
    292
    Sep 28, 2009

    No it doesn't. What bricks the device is updates that change TWL_FIRM. As long as that's not touched, you can update just fine using any launcher.

    I and many others have updated from 9.0 to 9.2 using the Cooking Mama ROM. I use the latest Launcher.dat.
     
  16. VerseHell

    VerseHell GBAtemp Psycho!

    Member
    3,067
    1,067
    Jun 29, 2014
    France
    Yes, but like michyprima said, it will if you make a big jump like the OP is planning to do.
     
  17. apoptygma
    OP

    apoptygma GBAtemp Advanced Fan

    Member
    689
    145
    Mar 30, 2010
    I don't really have the guts to attempt it but essentially the process would be what? downgrade to 4.5, pop an old launcher.dat on, force 'update' to run it and then use a rom of what title?
     
  18. bache

    bache GBAtemp Advanced Fan

    Member
    694
    292
    Sep 28, 2009

    I know; I was correcting you in regards to the launcher.dat info you provided.
     
  19. VerseHell

    VerseHell GBAtemp Psycho!

    Member
    3,067
    1,067
    Jun 29, 2014
    France
    Yes, use ssb, I did it, and this guy did it too : https://gbatemp.net/threads/updating-7-2-emunand-to-9-5-how.385393/
     
  20. apoptygma
    OP

    apoptygma GBAtemp Advanced Fan

    Member
    689
    145
    Mar 30, 2010