[How-To] Switch from PBT/Pasta/Palantine CFW to rxTools (sig. patched)

Discussion in '3DS - Flashcards & Custom Firmwares' started by VerseHell, Jun 11, 2015.

  1. VerseHell
    OP

    VerseHell GBAtemp Psycho!

    Member
    3,067
    1,067
    Jun 29, 2014
    France
    Another little guide because this question was asked a lot on the original thread.


    Some reminders first :
    Pasta tutorials :
    - With CN : https://gbatemp.net/threads/pasta-c...d-on-old-and-new-3ds-required-ninjhax.388925/
    - With MSET (4.X only) : https://gbatemp.net/threads/release-pasta-cfw-without-cubic-ninja-mset-4-x-old3ds.389498/ (If you have an old3ds -non 2ds- on 5.1-9.2 you can backup your sysnand, downgrade it, setup pasta, switch to rxtools, then restore your nand backup if you want)
    Nand backup : get the last gateway launcher.dat from their site, put it on your sd card, open your browser, go to http://go.gateway-3ds.com/ then choose the backup nand option.
    Downgrade tutorial : https://gbatemp.net/threads/gateway-downgrading.378195/
    Setting Up the MSET exploit for the Pasta MSET installation
    How to setup and use rxTools : http://www.rxtools.net/#!howto


    1. If you're using PBT or Pasta :
    Then it's simple :
    - Use the gateway launcher.dat to create your emunand. (With the format emunand option, backup your sd card content first)
    - Update your emunand with rxTools
    (If you were already using the non patched version, you don't even have to do this, juste replace the rxTools.dat with the patched one)

    2. If you're using Palantine (no dual nand):
    - Use this tool to backup your cfw rednand (extract nand 1)
    - Use the same tool to reinject it as an emunand (inject emunand 1)
    - Update your emunand with rxTools

    3. If you have a dual nand Palantine/rxTools :
    - Use this tool to backup your cfw rednand (extract nand 2)
    - Backup your sd card content
    - Do a format emunand with gateway launcher.dat.
    - Reinject your redand as an emunand (inject emunand 1)
    - Update your emunand with rxTools


    Bonus : Use rxTools with the MSET exploit (4.X only)

    1. If you have a ds flashcart : Just execute the rxinstaller with it and follow the instrcutions
    2. If you don't have one (your last firmware digit must be 7 or more to use this) :
    - Download and execute webMultiloader.exe
    - Press 5.
    - Copy the code.bin in your sd card
    - Scan this qrcode :
    [​IMG]
    - In the browser, wait until you see the bottom screen "flashes" then hard shutdown your console.
     
    Last edited by VerseHell, Jun 24, 2015
    Hamedxz, zeruel85, tehrzky and 7 others like this.
  2. tinkle

    tinkle Member

    Newcomer
    12
    6
    Jun 9, 2015
    United States
    To confirm, this cannot be done with New 3DS yet, right?
     
  3. VerseHell
    OP

    VerseHell GBAtemp Psycho!

    Member
    3,067
    1,067
    Jun 29, 2014
    France
    Nope, O3DS only.
     
  4. insidexdeath

    insidexdeath .

    Member
    1,135
    463
    Apr 13, 2010
    Maybe you should consider adding CIA installation for those who are afraid of the whole process regarding downgrading and whatnot.
     
  5. VerseHell
    OP

    VerseHell GBAtemp Psycho!

    Member
    3,067
    1,067
    Jun 29, 2014
    France
    I don't think it's needed, there are already a lot of guides on how to install the cfws.
     
  6. SirByte

    SirByte GBAtemp Fan

    Member
    498
    192
    Dec 30, 2012
    Canada
    Does rxtools.dat have to be named that way? Can't I just rename it to Launcher.dat and use the standard Gateway MSET to run it? If it's not working, is it testing if it's named rxTools.dat and if not is doing something nasty?
     
  7. VerseHell
    OP

    VerseHell GBAtemp Psycho!

    Member
    3,067
    1,067
    Jun 29, 2014
    France
    You can't just rename it. And I don't understand how is this a problem. It's even better because you can have rxtools and a launcher.dat on the same sd card.
     
  8. HoboKen95

    HoboKen95 Banned

    Banned
    137
    15
    Feb 17, 2015
    United States
    how do I get devmenu
     
  9. VerseHell
    OP

    VerseHell GBAtemp Psycho!

    Member
    3,067
    1,067
    Jun 29, 2014
    France
    You have to install it with one of the two pasta tutorials before setting up rxTools.
     
  10. SirByte

    SirByte GBAtemp Fan

    Member
    498
    192
    Dec 30, 2012
    Canada
    How do you do this? If I use rxinstaller.nds won't that prevent GW Launcher.dat (and my Pasta Launcher.dat) from booting? I want to be able to just swap SD cards without messing with a DS mode flashcard every time I switch. And MSET is a requirement. Going through the trouble of scanning codes every time you want to switch is even worse.

    Perhaps I can rename the Launcher.dats on the other cards to rxTools.dat but I'd rather not risk messing with GW Launcher.dat in case it still contains brick code.

    I doubt our friend @AHP_person can patch the rxTools.dat so it will accept Launcher.dat (one extra character in the name).

    Edit: we need an MSET Launcher Standard that lets everyone boot their thing (GW, Pasta, rxTools, any other CFW) using the exact same MSET exploit installed.
     
  11. VerseHell
    OP

    VerseHell GBAtemp Psycho!

    Member
    3,067
    1,067
    Jun 29, 2014
    France
  12. SirByte

    SirByte GBAtemp Fan

    Member
    498
    192
    Dec 30, 2012
    Canada
    It may be more complicated, I thought if that's the case I just have the same file but named 'rxTools.dat' in the root, so if it wants to call it, it can. Perhaps it has to do with the memory offset it's loaded to.

    I get the 'An error has occurred, forcing the software to close. The system will now restart. (Unsaved data may be lost.)' error.
     
  13. Koryushin

    Koryushin GBAtemp Regular

    Member
    176
    46
    Mar 26, 2015
    France
    Thank you my friend.
    I'm a palantine and rxtool user but on 2 different SD cards.
    Now i know how to setup my palantine rednand as an emunand.

    Merci beaucoup VerseHell
     
  14. OctopusRift

    OctopusRift GBATemp's Local Octopus, Open 9am-2am. "Not Yet"

    Member
    1,460
    832
    Nov 19, 2014
    Saint Kitts and Nevis
    Tell me when someone does some amazing shit in 9.8 or 4.x that is new!
     
  15. RaMon90

    RaMon90 GBAtemp Advanced Fan

    Member
    592
    150
    Dec 3, 2013
    Italy
    Probably has been answered many times, do i need inet connection to update to latest emunand or it can be done offline?
     
  16. VerseHell
    OP

    VerseHell GBAtemp Psycho!

    Member
    3,067
    1,067
    Jun 29, 2014
    France
    You can do it online or with 3DNUS. But it's safer to do it with the system settings.
     
  17. Omenien

    Omenien Member

    Newcomer
    21
    6
    May 28, 2015
    United States
    I apologize for the probably stupid question, I'm fairly new to 3DS tinkering, what are the benefits to this over Pasta? If I haven't had any issues using SysNAND so far is there any reason to switch?
     
  18. VerseHell
    OP

    VerseHell GBAtemp Psycho!

    Member
    3,067
    1,067
    Jun 29, 2014
    France
    The pasta cfw is not compatible with pokemon shuffle, and from what I've heard, it also not compatible with ssb, except if you're using the legit version (only with eu console). And many people prefer installing things on emunand and keep their sysnands clean.
     
  19. Omenien

    Omenien Member

    Newcomer
    21
    6
    May 28, 2015
    United States
    How does one go about booting a launcher.dat when using Pasta?

    Edit: I'm dumb, all I had to do was use the Gateway exploit webpage to run it.l
     
    Last edited by Omenien, Jun 11, 2015
  20. VerseHell
    OP

    VerseHell GBAtemp Psycho!

    Member
    3,067
    1,067
    Jun 29, 2014
    France
    The file is named rxTools.dat, so you can have both on one sd card.