How to run DS games after I got A9LH?

Discussion in '3DS - Flashcards & Custom Firmwares' started by tombi, Jun 28, 2016.

  1. tombi
    OP

    tombi Member

    Newcomer
    45
    5
    Jun 25, 2016
    Gambia, The
    Hello there. I have a "new 3DS XL" device. It is running the newest version of A9LH with Luma3DS, on SysNAND with ne newest firmware 11.x.

    I now want to run DS games on it. As I can see there are currently only flashcards that can run DS games for version 9.2, is this right?

    How can I now use these flash cards? Or is there any other way to run DS games?

    I have not bought any flashcard yet, so what flashcard could I use? I have seen "DSTwo Plus". Any other better flashcard, maybe a cheaper one?

    And if I really need 9.2 to run DS games: How can I use newest firmware and 9.2 with a9lh on the same time? Or will I have any problems? :/
     
    Last edited by tombi, Jun 28, 2016


  2. DavidRO99

    DavidRO99 Official depressed pikachu

    Member
    964
    267
    Jun 11, 2016
    Korea, North
    your back-door
    Find DSWare CIA files and install them
     
  3. Ziefer846

    Ziefer846 GBAtemp Fan

    Member
    447
    121
    Jun 22, 2015
    United States
    You need a flashcart for DS games, unless it is available via DSiWare. You can use pretty much any flashcart once you install the patch — which is fairly simple to do on a A9LH 3DS. DSTwo Plus is one that is highly recommended because it is still compatible with the latest firmware without a patch. You can also use the latest system firmware and still be able to run flashcarts.
     
    cvskid likes this.
  4. tombi
    OP

    tombi Member

    Newcomer
    45
    5
    Jun 25, 2016
    Gambia, The
    Could you explain me what patch I need? How can I activate or "install" this patch?
    As I know "DSTwo Plus" is officially only working on 9.2 firmware. How can I use it on the newest firmware (>9.2) ?
     
  5. MajinCubyan

    MajinCubyan The Funky Super Saiyan

    Member
    GBAtemp Patron
    MajinCubyan is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    583
    898
    Nov 24, 2014
    United States
    Orre
    I got an r4i rts 3ds flashcard for 18 bucks, works on the latest firmware regardless of a9lh, so it'll work fine for you. I highly recommend it if you are looking for a good, cheap card.
     
  6. Ziefer846

    Ziefer846 GBAtemp Fan

    Member
    447
    121
    Jun 22, 2015
    United States
    Actually, yeah might be. I'm not too sure about the DSTwo Plus. The patch can be installed via cia. Those files are installed using the FBI installer.
     
  7. tombi
    OP

    tombi Member

    Newcomer
    45
    5
    Jun 25, 2016
    Gambia, The
    And what patch and how can I get it? Officially gateway, DSTwo Plus and maybe other flashcards only support version 9.2 and below but not the newest firmwares. But I am only interested into DS games on flashcard (that are not available as DSWare games).

    @MajinCubyan There was no need to install a patch or something? The flashcard works fine on newest firmare 11.x?
     
    Last edited by tombi, Jun 28, 2016
  8. Ziefer846

    Ziefer846 GBAtemp Fan

    Member
    447
    121
    Jun 22, 2015
    United States
    Find a patched version of TWL_FIRM cia from somewhere. I may be wrong though. This is what I had to do back when I had rxTools. I'm not 100% it will work on Luma or if luma even needs the firm to be patched.
     
  9. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,402
    4,730
    Mar 17, 2010
    Norway
    Alola
    DS mode works on DSTWO+ on the latest firmware, only 3DS mode is limited to <=9.2. But with their new "freegame" CFW you can use the DSTWO+ in 3DS mode with A9LH, though that isn't recommended for use yet, it still has a lot of issues that need fixing.
    All the popular DS flashcarts work on the latest firmware.
     
    Last edited by The Real Jdbye, Jun 28, 2016
    Quantumcat and MajinCubyan like this.
  10. MajinCubyan

    MajinCubyan The Funky Super Saiyan

    Member
    GBAtemp Patron
    MajinCubyan is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    583
    898
    Nov 24, 2014
    United States
    Orre
    Yep, no need to do anything. Though I am pretty sure that luma cfw auto patches the twl firm.
     
  11. tombi
    OP

    tombi Member

    Newcomer
    45
    5
    Jun 25, 2016
    Gambia, The
    Could anybody confirm that any flashcard works fine with Luma3DS and firmware 11.x? :) So let's check what flashcard I'll buy, what do you think is better: DSTwo Plus, R4i rts or Gateway? Hm.. Just need it for DS stuff because I already have a Sky3ds+ in case I need a flashcard for 3ds games.
     
  12. MajinCubyan

    MajinCubyan The Funky Super Saiyan

    Member
    GBAtemp Patron
    MajinCubyan is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    583
    898
    Nov 24, 2014
    United States
    Orre
    I can confirm it works, just used my old r4i 3ds (which was blocked after 6.whatever) on my n3ds xl wit luma. And sysnand updated. I would get the r4i that I said earlier. Its good and cheap.
     
  13. Drona

    Drona Advanced Member

    Newcomer
    60
    12
    Jan 10, 2014
    France
    M3I Zero,R4 Gold and DSTWO work fine on 11CFW +A9LH+Luma.
     
    Last edited by Drona, Jun 28, 2016
    MajinCubyan likes this.
  14. CrispyYoshi

    CrispyYoshi GBAtemp Advanced Maniac

    Member
    1,506
    491
    Mar 20, 2010
    United States
    Just thought I'd mention: There is a difference between "Custom Firmware 11.x" and "Official Firmware 11.x". You cannot boot Luma on OFW 11.0, and must downgrade to 9.2. If you do manage to get on 9.2, you can set up an EmuNand (or more preferably A9LH), where you will then be allowed to update your system to latest firm while keeping your hacks enabled.

    Unfortunately, 11.0 isn't very easy to downgrade, but it would benefit you for 3DS hacking past DS games. Here are some options you can do:
    - Stay on 11.0 and wait out a new kernel exploit (Unlikely, but possible)
    - Buy a DS flashcart that works on latest OFW like the DSTWO, which costs around $30-$40. (Not to be confused with the DSTWO+, which supports 3ds hacks ONLY if you are <=9.2 or already hacked)
    - Buy a different 3ds that's on 10.5 or lower firmware (if 10.6 or 10.7, you'll need a hackable game like cubic ninja/freakyforms deluxe/ocarina of time+powersaves), hack it, system transfer, then sell your current 3ds
    - Hardmod your system and downgrade NATIVE_FIRM (or commission someone to do it for you)
    - Continue to update your 3DS on OFW and not worry about 3ds hacks
     
    Last edited by CrispyYoshi, Jun 28, 2016
    MajinCubyan likes this.
  15. esmith13

    esmith13 GBAtemp Regular

    Member
    151
    41
    Aug 19, 2006
    United States
    South Jersey
    confirmed working on my A9LH/Luma3DS/CFW11.0:
    Gateway Blue Card
    R4i
    R4i clones (I have two different crappy cards)
    DSone
    DStwo

    None of them needed any patching done by me. Luma3DS handles that at the A9LH level before the NAND boots so even if you're on 9.2 now, you can do a system update to 11.0 and still have your A9LH and DS flash card functionality.

    You should boot your 3DS holding SELECT to see the Luma3DS config and make sure "Show current NAND in System Settings" is turned on, then press START to save and finish boot up. Now, as long as when you go in to System Settings you see "Sys 9.2.0" instead of "Ver. 9.2.0" in the bottom right of top screen, you know you can safely update without losing any hacks or patched DS Card functionality.

    Unless you're also using a gateway card with A9LH you should NEVER see anything but "Sys" next to your firmware version when using a CFW sysNAND but better safe than sorry.
     
    Last edited by esmith13, Jun 28, 2016
  16. Temptress Cerise

    Temptress Cerise Miss Magic~ <3

    Member
    2,181
    1,415
    May 1, 2016
    United States
    DSTwo will work right out of the box, even on a stock 11.0. I've tested it on a stock//vanilla 11.0 system, as well without any TWL patching on Corbenik.
     
  17. Alex658

    Alex658 GBAtemp Maniac

    Member
    1,139
    337
    Jun 4, 2010
    Venezuela
    Venezuela
    Luma3ds automatically patches DS flashcart games, so even if they were blocked on OFW 11.0 they will work effortlessly on CFW11.0 (regardless of a9lh or emunand).
    I have a 9.2 sysnand + Luma3ds 11.0 Emunand and it executes my dsi r4iLL flashcart with no patching needed.

    This includes any flashcart that worked at any point during the 3ds lifetime (or even DSi flashcarts or original r4 provided you have apache thunder's launcher installed).

    Some crappy clones work on latest ofw 11.0 without patching like the r4 dual core (platinum 2016) or the crappiest of them all, the purple r4dstt 3ds 2016.

    Basically if you have luma set up you shouldn't worry at all because most, if not all of the flashcarts will work without patching anything.
     
  18. zanetheinsane

    zanetheinsane Newbie

    Newcomer
    1
    1
    Jun 29, 2016
    United States
    I've got my N3DS on A9LH/Luma/CFW11.0 and I absolutely cannot get my blue card working. I'm using the R4i files that come with Omega 3.7.1. If I leave _dsmenu.dat off of the card I see Deep Labyrinth and it starts up and understandably wants to know where _dsmenu.dat is. When I put _dsmenu.dat on the blue card, as soon as I insert the blue card into the N3DS the theme music (from CHMM2) stops. When that happens, pressing any button on the 3DS hard locks it.

    It's basically a barebones A9LH setup other than the custom theme. Does yours have a theme and still work with the blue card?

    UPDATE: Chose one of the "basic" themes and it started working without a problem. CHHM2 theme was somehow causing the lockup. Ugh, I've been trying to get this to work for 2 days and it turns out to be something stupid.
     
    Last edited by zanetheinsane, Jun 29, 2016
    Quantumcat likes this.
  19. Jayro

    Jayro MediCat DVD and Mini Windows 10 Developer

    Member
    GBAtemp Patron
    Jayro is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    4,714
    2,466
    Jul 23, 2012
    United States
    Octo Canyon
    How on earth does it run in 3DS mode? I thought hardware changes were needed, not just a CFW. Does it play 3DS games off of it?
     
  20. Temptress Cerise

    Temptress Cerise Miss Magic~ <3

    Member
    2,181
    1,415
    May 1, 2016
    United States
    The DSTwo+ (Not the non-plus) version, allows for playing 3DS games. It has the necessary hardware changes to do it, I guess.

    Here's a tutorial on how to get it working on o3DS + A9LH.
    Link: http://gbatemp.net/threads/tutorial...e-work-with-latest-emunand-on-old-3ds.429035/

    Otherwise, people are waiting for freegame CFW, which is just a bad ripoff ReiNAND, and I don't even think it works, haha!