How to play pokmon XY /ver ORAS online

Discussion in '3DS - Flashcards & Custom Firmwares' started by treyfixx, May 14, 2015.

  1. treyfixx
    OP

    treyfixx Newbie

    Newcomer
    4
    0
    Jan 14, 2010
    Slovenia
    Hello,

    I am sorry to bother you all and I appologize if this question has ben asked allready, but after searching for answers for the last 2 hours online, I decided to write to you wit a few questions about playing Pokemon online.

    Let me get straight to the broad question: How can I play pokemon XY and ORAS online?
    I have a Gateway card with 2.7 omega firmware.
    The emunand is 9.4

    Here's what I found out:
    - For any rom to be played online safely, it has to have a, preferably private, header (I have found the guide from the user MattKimura)
    - The games (cartrige games) need to be updated to at least version 1.2 to be played online (I know that the updates go to 1.5)

    There a re a lot of roms out there and I am not sure which one to download so that I could inject the header and safely play online. Is there a way to update the games to version 1.5 or lower? On top of that I don't know which roms are allready updated (if any)
    If this has allready been answered, plase direct me to the thread.


    I hope you'll take the time to answer me.

    Kind regards
     


  2. Pedeadstrian

    Pedeadstrian GBAtemp's Official frill-necked lizard.

    Member
    3,495
    1,552
    Oct 12, 2012
    United States
    Sandy Eggo
    ROMs themselves (for the most part) aren't updated. The updates are applied to your console instead. So don't worry about which version to download. Just grab a copy, apply a header (or don't if you got a .cia file), install the game update via emuNAND eShop or by downloading the game update from some website (that I can't name here), and you're all set.
     
    Osmosis and treyfixx like this.
  3. treyfixx
    OP

    treyfixx Newbie

    Newcomer
    4
    0
    Jan 14, 2010
    Slovenia
    Pedeastrian, thank you very much!
    Is there maybe a guide on how to install the game update via emuNAND eShop?
     
  4. Pedeadstrian

    Pedeadstrian GBAtemp's Official frill-necked lizard.

    Member
    3,495
    1,552
    Oct 12, 2012
    United States
    Sandy Eggo
    If you're installing the update through emuNAND, first things first, you need to update your Gateway to the most recent version, which you can find on their official website. After that, you update your emuNAND (through System Settings) to the most recent version. Finally, once your console is updated, you simply select your game in Gateway's multi-rom menu, and update it when prompted to.
     
    Osmosis likes this.
  5. Osmosis

    Osmosis Accidents Happen. Don't be one of them.

    Member
    760
    181
    Dec 20, 2014
    United States
    What I think Pedeadstrian meant was:

    Don't make your life more complicated than it already is. Go get the GW Ultra 3.2.1 pack. Update your GW. Then once you have your GW working on Ultra 3.2.1 update your emuNAND to 9.7. Install a .CIA version that doesn't require a private header. Use eShop on emuNAND 9.7 to update patches. Move on with life.

    Or go find online patched .CIA versions from a reputable website of which we cannot name.

    But you're better off taking Pedeadstrian's advice. Update your GW, use a .CIA, then eShop to patch. Enjoy.
     
  6. treyfixx
    OP

    treyfixx Newbie

    Newcomer
    4
    0
    Jan 14, 2010
    Slovenia
    Ok, one last question.
    How do I use a .CIA?
     
  7. Osmosis

    Osmosis Accidents Happen. Don't be one of them.

    Member
    760
    181
    Dec 20, 2014
    United States
    When you go to do a System Update to 9.7 make sure System Settings reads GW3D 9.X.X-XXx. If you do a system update and it doesn't say GW3D before the firmware, YOU ARE ON sysNAND AND WILL RUIN YOUR 3DS!!!!

    Make sure it says GW3 9.X.X-XXx, then click on SYSTEM UPDATE and proceed.
     
    treyfixx likes this.
  8. treyfixx
    OP

    treyfixx Newbie

    Newcomer
    4
    0
    Jan 14, 2010
    Slovenia
    Ok, great. I'll definitly do that.
    One more question if I may, how do I install a cia after that?
     
  9. Pedeadstrian

    Pedeadstrian GBAtemp's Official frill-necked lizard.

    Member
    3,495
    1,552
    Oct 12, 2012
    United States
    Sandy Eggo
    Injecting a header takes a few seconds. It's hardly complicated, and it also takes significantly less time than the work required for a .cia installation. But, that's just my opinion/preference.
    To install a .cia file, you need DevMenu or BigBlueMenu, which you can easily find online. Grab a .3ds copy, then run it, go to the SD card tab, find the .cia file, import it, and you're done. An optional step is to then install a .cia version of DevMenu or BigBlueMenu using your .3ds version, but that's up to user preference.
     
  10. Osmosis

    Osmosis Accidents Happen. Don't be one of them.

    Member
    760
    181
    Dec 20, 2014
    United States
    You need BigBlueMenu to install .CIA ROMs.

    First go to the Gateway3DS.com website and download the Ultra 3.2.1 pack:
    http://www.gateway-3ds.com/downloads/

    Follow the Gateway 3DS manual on how to update your Red Card and to load the Gateway Menu from web browser:
    http://maxconsole.com/maxconsole_files/v3.1.pdf

    Then once Red Card works and you are in Gateway Mode from web browser menu, make sure you are in emuNAND and not sysNAND. Then you may do a system update to 9.7. You can follow the instructions here:
    http://www.maxconsole.com/maxcon_forums/threads/286487-3DS-N3DS-Gateway-Ultra-Guide

    Then install the BigBlueMenu onto your Red Card and SD. DL your .CIA ROM from website and then press SELECT while in Gateway Mode. Choose the BigBlueMenu icon and then you need to MOUNT the .CIA from your SD card. Same instructions:
    http://www.maxconsole.com/maxcon_forums/threads/286487-3DS-N3DS-Gateway-Ultra-Guide
     
  11. Osmosis

    Osmosis Accidents Happen. Don't be one of them.

    Member
    760
    181
    Dec 20, 2014
    United States
    Agreed, but at this point he just needs to update and start using .CIA's. You were right the first time.
     
  12. Osmosis

    Osmosis Accidents Happen. Don't be one of them.

    Member
    760
    181
    Dec 20, 2014
    United States
    I didn't know you could install the .CIA version of BBM using the .3DS BBM... gonna go do that now.

    BTW, which is better? BBM or DevMenu?
     
  13. Kawaii

    Kawaii GBAtemp Regular

    Member
    264
    94
    Apr 30, 2015
    New Zealand
    Not near you
    Why do we need online patched cia for ORAS? Arent all cia headerless
     
  14. Osmosis

    Osmosis Accidents Happen. Don't be one of them.

    Member
    760
    181
    Dec 20, 2014
    United States
    Yes.

    You only need patched .CIA's if you don't want to run emuNAND on latest firmware (no eShop option).

    Which is why it is best to get GW updated and running on 9.7 so OP can use eShop to install patches and use .CIA ROMs. Then no need to ever worry about headers or ban hammer. Best/easiest route.

    The patched .CIA option is just an option for those who wish to not update their emuNAND to latest FW. Or when Gateway can't support 9.7 anymore and we end up in a giant wait period.
     
  15. Kawaii

    Kawaii GBAtemp Regular

    Member
    264
    94
    Apr 30, 2015
    New Zealand
    Not near you
    Well, i havent started playing ORAS or XY yet so havent actually tried the online option. But to my understanding we dont really have to be on the latest FW to play online games as long as the game have the latest update installed. We do have option to get title updates via cia.

    Wait by patched cia do you mean title update cia?
     
  16. Osmosis

    Osmosis Accidents Happen. Don't be one of them.

    Member
    760
    181
    Dec 20, 2014
    United States
    Yeeeeeesss...?? I dunno. Never used them.

    To play certain games you'll need their latest patches to play online. Games like Pokemon or SSB or UMH4. The easiest way is to just update your emuNAND FW to latest (currently 9.7). Then link your NNID to emuNAND and now you can use eShop to DL the patches.

    The other option is to get the ONLINE PATCHED ROMs. Not a guarantee that they have the latest patches, but most of the time they should. Not sure if .CIA or .3DS or if just patches or full game+patches. But the option is there for those who can't access eShop. Especially when GW can't run latest FW (which DOES happen).

    Best route is to update emuNAND FW. Workaround is using PATCHED ROMs.

    Nor can I tell you WHERE to get them. Good luck. (forum's rules, don't blame me)
     
  17. Kawaii

    Kawaii GBAtemp Regular

    Member
    264
    94
    Apr 30, 2015
    New Zealand
    Not near you
    Just google 'diy update cia'. You'll find what u need.
     
    Osmosis likes this.
  18. lampdemon

    lampdemon GBAtemp Regular

    Member
    151
    56
    Oct 28, 2013
    Canada
    Where the land sea lions live.
    Do I still have to inject a header from my own dumps?
    I'm still kinda new to this and it's 10 times easier to play on gateway than keep switching carts.
     
  19. Osmosis

    Osmosis Accidents Happen. Don't be one of them.

    Member
    760
    181
    Dec 20, 2014
    United States
    If you use .CIA ROMs they don't require private headers. Fin. Punto. The End.

    If you're using .3DS/Z ROMs, yes. You must use private headers. Better to use .CIA's and not worry about it.
     
  20. Typhin

    Typhin GBAtemp Fan

    Member
    305
    101
    Jan 30, 2008
    United States
    Something that doesn't seem to have been mentioned before is that if you are on a New 3DS, emuNand above 9.5 isn't supported yet. So, if you are using an Old 3DS, then the steps above will get you online. If you are using a New 3DS, then do not update your emuNand. You won't be able to grab the Pokemon update off of the eShop, but you should be able to find .cia versions of the updates available for download, which will work for both retail/.3ds versions as well as .cia versions of the games.

    To play a .3ds/.3dz game online, you will need a header. The best headers to use come from a dump of your own retail card, because you know that nobody else will have that card ID. You can use the same header with every game, so you only need one, they don't have to come from the same title.

    Yes, using .cia versions can be easier, since these don't have a card ID at all. However, if one already has a .3ds version of a game, they would have to convert or re-download the game, which can be a pain.