How to play movies on my Wii off a USB?

Discussion in 'Wii - Hacking' started by KatieOoT, Feb 26, 2013.

  1. KatieOoT
    OP

    KatieOoT Member

    Newcomer
    41
    0
    Jan 16, 2013
    Canada
    I have WiiMC and put a movie on my USB (which works great) and the movie wouldn't load? Nothing happened really. The movie was a iTunes movies.

    Do I need to download something else?
     
  2. XDel

    XDel Author of the Alien Breed Odamex Projekt.

    Member
    1,407
    413
    Jul 25, 2012
    United States
    Solaris
    What do you mean precisely when you say it didn't load? Were you able to select the movie in WiiMC's menu selection? Does it then just freeze your system, not even attempt to load your file, or give you a code dump?


    In the mean time, assuming you are using Winblows, right click the movie and goto it's properties. Goto details and tell me what the screen resolution is for the movie you are trying to view.
     
  3. KatieOoT
    OP

    KatieOoT Member

    Newcomer
    41
    0
    Jan 16, 2013
    Canada
    I guess I should have been more specific, sorry haha! There's this bar that loads at the bottom of the screen then nothing happens at all once it finishes.

    The movie was iTunes HD so do you think that might be it?
     
  4. XDel

    XDel Author of the Alien Breed Odamex Projekt.

    Member
    1,407
    413
    Jul 25, 2012
    United States
    Solaris
    I've never used iTunes HD, but I presume it is comparable with Blue Ray resolutions? I can not be sure.

    What Operating System are you running on your computer? If you are on Windows, you can find out for sure using the method I described above.

    My first guess, given by what you told me, is that the movie's codec file is not supported, or the resolution is too high.

    If the resolution is too high, you can use free software like Freemake Video Converter to easily convert that into a different format and reduce the resolution so that your Wii's meager CPU can handle it. It's a drag and drop program, and all you have to do is select the "to DVD" option at the bottom of the program's screen to convert it to a format that should play friendly with your Wii, without reducing video quality to the point where it just looks horrid.

    http://www.freemake.com/
     
  5. LoloLakitu

    LoloLakitu Shwowow Schogog

    Member
    177
    19
    Jul 26, 2012
    Canada
    That new rad hangout.
    720p or 1080p?
     
  6. XDel

    XDel Author of the Alien Breed Odamex Projekt.

    Member
    1,407
    413
    Jul 25, 2012
    United States
    Solaris
    Ideally you'll want something around the area of 720x400. Not those exact numbers of course, but anything higher than that usually chugs on my Wii if not crashes is. I.E. Uncompressed Blue Ray rips will not work. :)
     
  7. KatieOoT
    OP

    KatieOoT Member

    Newcomer
    41
    0
    Jan 16, 2013
    Canada

    I'm 99.9% sure it's because of the resolution. I'll try the software you posted & see if that works! Thanks! (:
     
  8. XDel

    XDel Author of the Alien Breed Odamex Projekt.

    Member
    1,407
    413
    Jul 25, 2012
    United States
    Solaris
    No prob, hope that sets you straight. :)
     
  9. Sychophantom

    Sychophantom I'm a plant.

    Member
    1,190
    344
    Mar 7, 2008
    United States
    Born on the Bayou
    Silly question, but if it was a movie from iTunes, was it a purchased one, or encoded for iTunes?

    Anything bought from iTunes won't generally play on anything but an iDevice.
     
  10. KatieOoT
    OP

    KatieOoT Member

    Newcomer
    41
    0
    Jan 16, 2013
    Canada
    I think you might be right. It didn't work still & I used the program XDel gave me on a different HD movie too (not from iTunes) to make it a lower res. and that worked.

    So, It must be just iTunes movies :P
     
  11. Fishaman P

    Fishaman P Speedrunner

    Member
    3,241
    507
    Jan 2, 2010
    United States
    Wisconsin
    iTunes has that retarded DRM, but I'm pretty sure that if you're patient, you can get around it by using a screen capture program while it's playing and then encoding that to a 640x460 (4:3) or 640x360 (16:9) file.
     
  12. KatieOoT
    OP

    KatieOoT Member

    Newcomer
    41
    0
    Jan 16, 2013
    Canada
    So if you're still here, I did this with a different movie(use freemake) because it was 1080p and all I got was a folder full of crap hahaa, what do I do here? Untitled.png
     
  13. trumpet-205

    trumpet-205 Embrace the darkness within

    Member
    4,363
    542
    Jan 14, 2009
    United States
    Those are DVD video format, your video should be in VTS_01_1.vob

    Wii can only handle video file in following specification,

    * 480p (720 x 480) with reference frame less than or equal to 6. Ideally in progressive as Wii isn't powerful to deinterlace.
    * AAC (Low complexity), MP3, AC3, FLAC, Vorbis in Stereo only.
     
  14. XDel

    XDel Author of the Alien Breed Odamex Projekt.

    Member
    1,407
    413
    Jul 25, 2012
    United States
    Solaris

    I am terribly sorry, I slightly misguided you. Delete that entire Folder along with all the Folders within.

    I meant, and should have said clearly to select your format (I generally use MP4), then in the next window it will say SAME AS SOURCE as the default option. Click on that and select DVD then click CONVERT.

    This will produce a single Video file with the MP4 extension and the video will be in a resolution of: 720x576 (yes a little higher res than what I quoted before). If that still makes your Wii crash, chug, skip frames, or what have you, then try TV instead of DVD, but I tend to have good luck with DVD.

    Again, sorry for this misguidance, I was going off the top of my head last time.
     
  15. KatieOoT
    OP

    KatieOoT Member

    Newcomer
    41
    0
    Jan 16, 2013
    Canada
    Thank you, movies are running great now! (:
     
  16. XDel

    XDel Author of the Alien Breed Odamex Projekt.

    Member
    1,407
    413
    Jul 25, 2012
    United States
    Solaris
    Awesome, great to hear!!!! Thanks for letting me know!