Tutorial  Updated

How to play DS games online with your Mac's hotspot

So, you might know that you can use your Mac as a Wi-Fi hotspot. That can be used to play DS games with Wiimmfi. In Big Sur, Apple removed the option in the System Preferences to create a hotspot with no security, but it's still possible to make an open hotspot. I'm going to college very soon, so I wanted to figure out a way to play DS games in my dorm. In this tutorial I will also tell you how to set up port forwarding so you can matchmake properly. I tested this briefly.

You can use either Ethernet or an iPhone with cellular data as your hotspot. (You cannot use the personal hotspot feature on the iPhone, because it does not support making WEP or open hotspots).

If you want to use an iPhone as your hotspot:

  1. Connect your iPhone to your Mac with the Lightning cable.
  2. Make sure Personal Hotspot is turned on in your iPhone's settings.
  3. Go to System Preferences > Network.
  4. Press the + icon in the corner and select iPhone USB.
  5. You want to use the hotspot without a cable? Click "Set Up Bluetooth tethering", then in the Bluetooth menu right click on "Connect".
If you want to use Ethernet as your hotspot, continue on.

  1. Go to System Preferences > Sharing.
  2. Press "Internet Sharing", and then under "Share your connection from" select Bluetooth PAN 2 if using your iPhone wirelessly, iPhone USB if using your iPhone plugged into your computer, or Ethernet if you're using Ethernet.
  3. Check Wi-Fi under "To computers using"
  4. Click "Wi-Fi Options" and make a name for your hotspot, then press OK. If you're on Catalina or lower, select the option to make a hotspot with no password. (Some versions of macOS around Mountain Lion or lower support making a WEP hotspot, but I don't think you're still using a version that old, are you?
  5. Check the "Internet Sharing" box.
If on Big Sur, you need to manually set the hotspot to have no password. If you're on Catalina or lower, skip this step.

  1. Open the Terminal application.
  2. Type in sudo nano /Library/Preferences/SystemConfiguration/com.apple.airport.preferences.plist
  3. Enter your password then press Enter (you won't be able to see the password being typed).
  4. Change the line <string>WPA2/WPA3 Personal</string> to <string>Open</string>.
  5. Press Control+X, then press Y, then press Enter.
Now we will set up the port forwarding so you can matchmake properly.

  1. Open the Terminal application if you haven't already.
  2. Type in sudo nano /etc/pf.conf
  3. Enter your password then press Enter (you won't be able to see the password being typed).
  4. Add a new line at the end containing: rdr pass inet proto udp from any to any port 1024:65535 ->
  5. Press Control+X, then press Y, then press Enter.
  6. Restart your Mac.
Finally, we will configure the Internet settings on your DS system.

  1. Open the Nintendo Wi-Fi Connection Settings.
  2. Search for networks and select yours.
  3. Open the manual settings, and select "No" for Auto-obtain IP Address.
  4. Type in for the IP Address.
  5. Type in for the Subnet Mask.
  6. Type in for the Gateway.
  7. Type in for the Primary DNS.
  8. Type in for the Secondary DNS.
Do a connection test. Hopefully everything works and you can start playing!
Last edited by Larsenv,


Dr. Wii, Ph.D
Sep 28, 2013
United States
Personally I don't use the setup I created, because it caused problems. I couldn't use the DNS and it would only work when I restarted my computer. It still might be useful to people running macOS Catalina or lower, instead of Big Sur.

I'm in college now, and I just hooked up an AirPort Express with WEP on it. You can get one on eBay for cheap. I have to run https://github.com/RiiConnect24/DNS-Server on it since my college blocks DNS.


A catgirl with a DSi
Jun 26, 2019
United States
I just tested this myself and want to mention, I skipped the port forwarding and manual IP entry steps entirely to see if it'd work and it worked fine for me. I'm using Monterey on a 2010 MacBook forwarding from ethernet if that makes any difference, just figured I should mention that those steps seem unnecessary, at least with this setup.

I'll also mention that it said "WPA2 Personal" for me rather than WPA2/WPA3, presumably because my computer is too old to support WPA3, so if you see that it's not an issue.
General chit-chat
Help Users
  • No one is chatting at the moment.
    Psionic Roshambo @ Psionic Roshambo: Now I want to Google that but I'm afraid lol