How to launch RxTools Without Internet/Browser? (No Flashcart or CubicNinja)

Discussion in '3DS - Flashcards & Custom Firmwares' started by -NOP-, Nov 19, 2016.

  1. -NOP-
    OP

    -NOP- Member

    Newcomer
    16
    2
    Nov 19, 2016
    Canada
    Hi,

    I have already set up RxTools/EmuNAND. Everything works perfect. All I need now is to be able to launch RxTools/EmuNAND without going through the browser/needing internet.

    I have done this before on another 3DS. I can go to DS Profile and RxTools launches. But the video tutorial I followed before was deleted...

    SysNAND and EmuNAND are unlinked.
    SysNAND is running 4.2.0
    EmuNAND is running latest version.

    Thanks for your help!
     


  2. Tomato Hentai

    Tomato Hentai snart

    Member
    3,670
    5,800
    Oct 30, 2014
    Canada
    actually north korea. please send help
    You could do that with Menuhax, although you'd need to upgrade your sysNAND to a higher firmware.
     
  3. -NOP-
    OP

    -NOP- Member

    Newcomer
    16
    2
    Nov 19, 2016
    Canada
    I was reading about this. Is there an easy way to upgrade the sysNAND? I believe Menuhax needs 9.2.
     
  4. Tomato Hentai

    Tomato Hentai snart

    Member
    3,670
    5,800
    Oct 30, 2014
    Canada
    actually north korea. please send help
    Do you have FBI or some other CIA installer injected into Health & Safety on sysNAND?
    If you do, then you should install sysUpdater with it, then go and grab the 9.2 update files from that ISO site, and update using sysUpdater. I think updates have to be in SDMC:/update/ but I'm not sure. It'll probably be somewhere on the sysUpdater GitHub page.
     
  5. ihaveamac

    ihaveamac GBAtemp Guru

    Member
    5,339
    5,752
    Apr 20, 2015
    United States
    Tigard, OR
    you don't need to update your sysnand. in fact I don't think it's recommended anymore, the new and safer method is using ctrtransfer (if possible, which it is here).
     
  6. Lilith Valentine

    Lilith Valentine GBATemp's Wolfdog™ I drool on my knife

    Member
    19,348
    19,650
    Sep 13, 2009
    Antarctica
    Between insane and insecure
  7. Tomato Hentai

    Tomato Hentai snart

    Member
    3,670
    5,800
    Oct 30, 2014
    Canada
    actually north korea. please send help
    ...You do a CTRTransfer when setting up Menuhax too, now?
     
  8. ihaveamac

    ihaveamac GBAtemp Guru

    Member
    5,339
    5,752
    Apr 20, 2015
    United States
    Tigard, OR
    if you're on 9.2 or lower, you would go to 2.1 from there. no real need to update to 9.2. the 9.2 images are only if you have a9lh already, and your system is bricked/want to region-change/something else.
     
    Tomato Hentai likes this.
  9. Zidapi

    Zidapi GBAtemp Addict

    Member
    2,974
    1,774
    Dec 1, 2002
    Welp :ph34r:'d

    Honestly, you should move away from rxTools and onto a more modern setup and if you're planning on playing Pokemon Sun or Moon you're going to have to.

    Follow this guide if you want to update your setup.

    https://plailect.github.io/Guide/

    When you reach the end of the guide you'll have a system that automatically, and immediately boots into the CFW luma3DS from the moment you power on your 3DS.

    This achieves what you're trying to do by eliminating the need to have an internet connection, and is the method we all recommend.

    If however you're insistent on staying in the 3DS hacking Stone Age, your only option is the DS Profile exploit.
     
    Last edited by Zidapi, Nov 19, 2016
    -NOP- and Tomato Hentai like this.
  10. -NOP-
    OP

    -NOP- Member

    Newcomer
    16
    2
    Nov 19, 2016
    Canada


    Thanks for all the responses. I'm looking into this guide and trying to follow it. Why is Pokemon Sun or Moon unplayable through the old method of RxTools?
     
    Last edited by -NOP-, Nov 19, 2016
  11. xtheman

    xtheman GBAtemp Guru

    Member
    5,843
    5,252
    Jan 28, 2016
    It uses an old firm. Sun and Moon require an updated one. Follow this guide to get a cfw with an updated firm https://plailect.github.io/Guide/
     
  12. -NOP-
    OP

    -NOP- Member

    Newcomer
    16
    2
    Nov 19, 2016
    Canada
    But when the sysNAND and emuNAND are unlinked the emuNAND can be updated to run the latest firmware, right?
     
  13. xtheman

    xtheman GBAtemp Guru

    Member
    5,843
    5,252
    Jan 28, 2016
    firm is not the same as firmware.
    Their is a thing called native_firm. Certain games need that updated to work. sun/moon carts and acnl amiibo to be exact.
     
  14. Rehv

    Rehv Member

    Newcomer
    48
    18
    Sep 14, 2013
    Brazil
    Just in case you don't know, rxtools will run the cia version of pokemon sun/moon just fine. But really, you should consider updating using the plailect guide.
     
  15. -NOP-
    OP

    -NOP- Member

    Newcomer
    16
    2
    Nov 19, 2016
    Canada

    This tutorial worked. Thanks!
     
    Last edited by -NOP-, Nov 19, 2016
  16. Zidapi

    Zidapi GBAtemp Addict

    Member
    2,974
    1,774
    Dec 1, 2002
    Happy to help, welcome to the future! :D
     
    -NOP- likes this.
  17. -NOP-
    OP

    -NOP- Member

    Newcomer
    16
    2
    Nov 19, 2016
    Canada
    It's wonderful here
     
    tatumanu likes this.
  18. Arkansaw

    Arkansaw GBAtemp Advanced Fan

    Member
    993
    194
    Jul 23, 2005
    Trinidad and Tobago
    FBI 1.x can install mset rop for rxtools and various other cfw

    If you really want to mess with a9lh, don't follow the guides blindly and update sysnand past 9.2 (keep that emunand). It is fairly troublesome and risky to downgrade sysnand later on and some tools don't work the same way after you are "stuck" in cfw/a9lh.
     
    Last edited by Arkansaw, Nov 19, 2016
  19. -NOP-
    OP

    -NOP- Member

    Newcomer
    16
    2
    Nov 19, 2016
    Canada

    So you're saying not to update sysNAND past 9.2, but use it to launch into RxTools which would be updated all the way in emuNAND?
     
    Arkansaw likes this.
  20. xtheman

    xtheman GBAtemp Guru

    Member
    5,843
    5,252
    Jan 28, 2016
    Please ignore that bullshit.
    Nothing he said is true. With a9lh it is always safe to update sysnand. Don't use rxtools as it is broken.